Shunde

Shunde.NET Framework Class Library

Shunde Namespace

The main namespace for the Shunde Framework.

Namespace hierarchy

Classes

Class | Description
ConcurrencyException | A concurrency exception is thrown when the same data is updated at once. The first to complete will go through, however the 2nd to complete will throw a concurrency exception.
ObjectDoesNotExistException | A miscellaneous exception
ShundeException | A miscellaneous exception
ShundeSqlException | An Sql Exception
ValidationException | Exceptions that are to do with validation. The error message should be a friendly message to deliver to the client.
WarningException | A warning only. Different from a ValidationException in that it may be valid, but there is a suspicion that something may not be right anyway

Enumerations

Enumeration | Description
SearchType | Search types for full-text searches

Send comments on this topic.

Copyright Daniel Flower


ConcurrencyException Class

A concurrency exception is thrown when the same data is updated at once. The first to complete will go through, however the 2nd to complete will throw a concurrency exception.

For a list of all members of this type, see ConcurrencyException Members.

System.Object
Exception
ShundeException
ValidationException
ConcurrencyException

public class ConcurrencyException : ValidationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde

Assembly: Shunde (in Shunde.dll)

See Also

ConcurrencyException Members | Shunde Namespace

Send comments on this topic.

Copyright Daniel Flower

Generated from assembly Shunde [3.0.0.0]


ConcurrencyException Members

ConcurrencyException overview

Public Instance Constructors

ConcurrencyException Overloaded. Initializes a new instance of the ConcurrencyException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConcurrencyException Class | Shunde Namespace


ConcurrencyException Constructor

Misc exception

Overload List

Misc exception

public ConcurrencyException();

Misc exception, with details

public ConcurrencyException(String);

See Also

ConcurrencyException Class | Shunde Namespace


ConcurrencyException Constructor ()

Misc exception

public ConcurrencyException();

See Also

ConcurrencyException Class | Shunde Namespace | ConcurrencyException Constructor Overload List


ConcurrencyException Constructor (String)

Misc exception, with details

public ConcurrencyException(
String message
);

See Also

ConcurrencyException Class | Shunde Namespace | ConcurrencyException Constructor Overload List


ObjectDoesNotExistException Class

A miscellaneous exception

For a list of all members of this type, see ObjectDoesNotExistException Members.

System.Object
Exception
ShundeException
ObjectDoesNotExistException

public class ObjectDoesNotExistException : ShundeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde

Assembly: Shunde (in Shunde.dll)

See Also

ObjectDoesNotExistException Members | Shunde Namespace


ObjectDoesNotExistException Members

ObjectDoesNotExistException overview

Public Instance Constructors

ObjectDoesNotExistException Overloaded. Initializes a new instance of the ObjectDoesNotExistException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectDoesNotExistException Class | Shunde Namespace


ObjectDoesNotExistException Constructor

Misc exception

Overload List

Misc exception

public ObjectDoesNotExistException();

Misc exception, with details

public ObjectDoesNotExistException(String);

See Also

ObjectDoesNotExistException Class | Shunde Namespace


ObjectDoesNotExistException Constructor ()

Misc exception

public ObjectDoesNotExistException();

See Also

ObjectDoesNotExistException Class | Shunde Namespace | ObjectDoesNotExistException Constructor Overload List


ObjectDoesNotExistException Constructor (String)

Misc exception, with details

public ObjectDoesNotExistException(
String message
);

See Also

ObjectDoesNotExistException Class | Shunde Namespace | ObjectDoesNotExistException Constructor Overload List


SearchType Enumeration

Search types for full-text searches

public enum SearchType

Members

Member Name | Description
And | All words must be contained
Or | Any words must be contained

Requirements

Namespace: Shunde

Assembly: Shunde (in Shunde.dll)

See Also

Shunde Namespace


ShundeException Class

A miscellaneous exception

For a list of all members of this type, see ShundeException Members.

System.Object
Exception
ShundeException
ObjectDoesNotExistException
ValidationException
WarningException

public class ShundeException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde

Assembly: Shunde (in Shunde.dll)

See Also

ShundeException Members | Shunde Namespace


ShundeException Members

ShundeException overview

Public Instance Constructors

ShundeException Overloaded. Initializes a new instance of the ShundeException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShundeException Class | Shunde Namespace


ShundeException Constructor

Misc exception

Overload List

Misc exception

public ShundeException();

Misc exception, with details

public ShundeException(String);

See Also

ShundeException Class | Shunde Namespace


ShundeException Constructor ()

Misc exception

public ShundeException();

See Also

ShundeException Class | Shunde Namespace | ShundeException Constructor Overload List


ShundeException Constructor (String)

Misc exception, with details

public ShundeException(
String message
);

See Also

ShundeException Class | Shunde Namespace | ShundeException Constructor Overload List


ShundeSqlException Class

An Sql Exception

For a list of all members of this type, see ShundeSqlException Members.

System.Object
Exception
ShundeSqlException

public class ShundeSqlException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde

Assembly: Shunde (in Shunde.dll)

See Also

ShundeSqlException Members | Shunde Namespace


ShundeSqlException Members

ShundeSqlException overview

Public Instance Constructors

ShundeSqlException Constructor Creates a new exception

Public Instance Fields

sqlStatement The SQL statement that caused the error

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | The reason for the problem
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToHtml | Prints out details of this exception
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShundeSqlException Class | Shunde Namespace


ShundeSqlException Constructor

Creates a new exception

public ShundeSqlException(
String sqlStatement,
Exception ex
);

Parameters

String
Exception

See Also

ShundeSqlException Class | Shunde Namespace


ShundeSqlException Fields

The fields of the ShundeSqlException class are listed below. For a complete list of ShundeSqlException class members, see the ShundeSqlException Members topic.

Public Instance Fields

sqlStatement The SQL statement that caused the error

See Also

ShundeSqlException Class | Shunde Namespace


ShundeSqlException.sqlStatement Field

The SQL statement that caused the error

public String sqlStatement;

See Also

ShundeSqlException Class | Shunde Namespace


ShundeSqlException Properties

The properties of the ShundeSqlException class are listed below. For a complete list of ShundeSqlException class members, see the ShundeSqlException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | The reason for the problem
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ShundeSqlException Class | Shunde Namespace


Message Property

Shunde.NET Framework Class Library

ShundeSqlException.Message Property

The reason for the problem

public override Message {get;}

See Also

ShundeSqlException Class | Shunde Namespace


ShundeSqlException Methods

The methods of the ShundeSqlException class are listed below. For a complete list of ShundeSqlException class members, see the ShundeSqlException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToHtml | Prints out details of this exception
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ShundeSqlException Class | Shunde Namespace


ShundeSqlException.ToHtml Method

Prints out details of this exception

public string ToHtml();

See Also

ShundeSqlException Class | Shunde Namespace


ValidationException Class

Exceptions that are to do with validation. The error message should be a friendly message to deliver to the client.

For a list of all members of this type, see ValidationException Members.

System.Object
Exception
ShundeException
ValidationException
ConcurrencyException

public class ValidationException : ShundeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde

Assembly: Shunde (in Shunde.dll)

See Also

ValidationException Members | Shunde Namespace


ValidationException Members

ValidationException overview

Public Instance Constructors

ValidationException Overloaded. Initializes a new instance of the ValidationException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValidationException Class | Shunde Namespace


ValidationException Constructor

Misc exception

Overload List

Misc exception

public ValidationException();

Misc exception, with details

public ValidationException(String);

See Also

ValidationException Class | Shunde Namespace


ValidationException Constructor ()

Misc exception

public ValidationException();

See Also

ValidationException Class | Shunde Namespace | ValidationException Constructor Overload List


ValidationException Constructor (String)

Misc exception, with details

public ValidationException(
String message
);

See Also

ValidationException Class | Shunde Namespace | ValidationException Constructor Overload List


WarningException Class

A warning only. Different from a ValidationException in that it may be valid, but there is a suspicion that something may not be right anyway

For a list of all members of this type, see WarningException Members.

System.Object
Exception
ShundeException
WarningException

public class WarningException : ShundeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde

Assembly: Shunde (in Shunde.dll)

See Also

WarningException Members | Shunde Namespace


WarningException Members

WarningException overview

Public Instance Constructors

WarningException Overloaded. Initializes a new instance of the WarningException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WarningException Class | Shunde Namespace


WarningException Constructor

Misc exception

Overload List

Misc exception

public WarningException();

Misc exception, with details

public WarningException(String);

See Also

WarningException Class | Shunde Namespace


WarningException Constructor ()

Misc exception

public WarningException();

See Also

WarningException Class | Shunde Namespace | WarningException Constructor Overload List


WarningException Constructor (String)

Misc exception, with details

public WarningException(
String message
);

See Also

WarningException Class | Shunde Namespace | WarningException Constructor Overload List


Shunde.Common

Shunde.NET Framework Class Library

Shunde.Common Namespace

This namespace contains classes which are not part of the actual framework, but are useful classes that are often used in applications.

Namespace hierarchy

Classes

Class | Description
Attrib | An Attrib, short for Attribute, is just an attribute for an object
AttribDataType | The type of data that an Attrib holds
AttribRelation | A relation between an object and an attribute
AttribType | An Type of an Attrib
Email | An email message that can be sent to people
GenericType | This is a generic class for a type, for example a type of event
GenericTypeType | This is a type of a GenericType, for example "Event Type"
TextSection | Some text, stored in the database
TreeNode | A node of a tree, to allow for heirachical structures
WebPage | The base of each webpage.
WebsiteVisit | Information on a website visit
WebsiteVisitAction | An action during a visit

Interfaces

Interface | Description
IAttribRelation | A relation between some object and an attribute


Attrib Class

An Attrib, short for Attribute, is just an attribute for an object

For a list of all members of this type, see Attrib Members.

System.Object
DBObject
TreeNode
Attrib

public class Attrib : TreeNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class exists so that you don't need to create a database table for every single kind of attribute. An example of an attribute is Screen Type (LCD or CRT etc) of a Monitor. The monitor would have screenType variable of type Attrib, which would be one of the Attribs in the database with the "ScreenType" AttribType.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

Attrib Members | Shunde.Common Namespace


Attrib Members

Attrib overview

Public Static Methods

CreateFromValue | Creates a new Attrib with the given Value and Parent and returns the newly created object
GetAttribsAsForest | Gets and populates all the Attribs for a given AttribType

Public Instance Constructors

Attrib Constructor Initializes a new instance of the Attrib class.

Public Instance Properties

AttribType | The type of this Attribute
Children (inherited from TreeNode) | The Children of this TreeNode
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName (inherited from TreeNode) | Gets the friendly name of the object
FullName (inherited from TreeNode) | Returns the Name of this TreeNode, with all ancestors names
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
IsHidden (inherited from TreeNode) | Specifies that this TreeNode is hidden
IsLeaf (inherited from TreeNode) | Returns true if this TreeNode is a leaf node (ie. has no Children)
IsShaded (inherited from TreeNode) | Specifies whether a TreeNode is visible, or shaded
IsVisible (inherited from TreeNode) | Returns true if this TreeNode, and none of its parents, are hidden
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name (inherited from TreeNode) | The Name of the TreeNode
Notes (inherited from TreeNode) | Notes pertaining to this TreeNode
Parent (inherited from TreeNode) | The Parent of this TreeNode
RootNode (inherited from TreeNode) | Returns the root node of the tree that this TreeNode belongs in
TextualValue | Returns the textual value of this attribute
Value | The Value of this attribute

Public Instance Methods

CompareTo (inherited from TreeNode) | Compares the Name of this string to another TreeNode
Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
FindDescendant (inherited from TreeNode) | Finds the TreeNode from the Children, or descendants of this TreeNode
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateAncestors (inherited from TreeNode) | Populates the ancestors of this tree node
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save | Saves this object
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Attrib Class | Shunde.Common Namespace


Attrib Constructor

Initializes a new instance of the Attrib class.

public Attrib();

See Also

Attrib Class | Shunde.Common Namespace


Attrib Properties

The properties of the Attrib class are listed below. For a complete list of Attrib class members, see the Attrib Members topic.

Public Instance Properties

AttribType | The type of this Attribute
Children (inherited from TreeNode) | The Children of this TreeNode
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName (inherited from TreeNode) | Gets the friendly name of the object
FullName (inherited from TreeNode) | Returns the Name of this TreeNode, with all ancestors names
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
IsHidden (inherited from TreeNode) | Specifies that this TreeNode is hidden
IsLeaf (inherited from TreeNode) | Returns true if this TreeNode is a leaf node (ie. has no Children)
IsShaded (inherited from TreeNode) | Specifies whether a TreeNode is visible, or shaded
IsVisible (inherited from TreeNode) | Returns true if this TreeNode, and none of its parents, are hidden
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name (inherited from TreeNode) | The Name of the TreeNode
Notes (inherited from TreeNode) | Notes pertaining to this TreeNode
Parent (inherited from TreeNode) | The Parent of this TreeNode
RootNode (inherited from TreeNode) | Returns the root node of the tree that this TreeNode belongs in
TextualValue | Returns the textual value of this attribute
Value | The Value of this attribute

See Also

Attrib Class | Shunde.Common Namespace


AttribType Property

Shunde.NET Framework Class Library

Attrib.AttribType Property

The type of this Attribute

public AttribType {get; set;}

Remarks

For example, "ScreenType".

See Also

Attrib Class | Shunde.Common Namespace


TextualValue Property

Shunde.NET Framework Class Library

Attrib.TextualValue Property

Returns the textual value of this attribute

public TextualValue {get;}

See Also

Attrib Class | Shunde.Common Namespace


Value Property

Shunde.NET Framework Class Library

Attrib.Value Property

The Value of this attribute

public Value {get; set;}

See Also

Attrib Class | Shunde.Common Namespace


Attrib Methods

The methods of the Attrib class are listed below. For a complete list of Attrib class members, see the Attrib Members topic.

Public Static Methods

CreateFromValue | Creates a new Attrib with the given Value and Parent and returns the newly created object
GetAttribsAsForest | Gets and populates all the Attribs for a given AttribType

Public Instance Methods

CompareTo (inherited from TreeNode) | Compares the Name of this string to another TreeNode
Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
FindDescendant (inherited from TreeNode) | Finds the TreeNode from the Children, or descendants of this TreeNode
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateAncestors (inherited from TreeNode) | Populates the ancestors of this tree node
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save | Saves this object
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Attrib Class | Shunde.Common Namespace


Attrib.CreateFromValue Method

Creates a new Attrib with the given Value and Parent and returns the newly created object

public static Attrib CreateFromValue(
AttribType attribType,
String value,
Attrib parent
);

Remarks

If the object already existed and the AttribType is a shared attribute, then nothing is created and that object is returned.

See Also

Attrib Class | Shunde.Common Namespace


Attrib.GetAttribsAsForest Method

Gets and populates all the Attribs for a given AttribType

public static Attrib[] GetAttribsAsForest(
AttribType attribType
);

Parameters

AttribType
The AttribType that the attribs are for

Return Value

Returns a forest of 0 or more Attribs for the given AttribType

See Also

Attrib Class | Shunde.Common Namespace


Attrib.Save Method

Saves this object

public override void Save();

See Also

Attrib Class | Shunde.Common Namespace


AttribDataType Class

The type of data that an Attrib holds

For a list of all members of this type, see AttribDataType Members.

System.Object
DBObject
AttribDataType

public class AttribDataType : DBObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

AttribDataType Members | Shunde.Common Namespace


AttribDataType Members

AttribDataType overview

Public Static Methods

GetAttribDataTypes Gets and populates all the AttribDataTypes

Public Instance Constructors

AttribDataType Constructor Initializes a new instance of the AttribDataType class.

Public Instance Properties

DataClassName | The C# class Name of this data type
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Gets the name of this object
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of this data type

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetDataType | Gets the data Type of the attribute
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttribDataType Class | Shunde.Common Namespace


AttribDataType Constructor

Initializes a new instance of the AttribDataType class.

public AttribDataType();

See Also

AttribDataType Class | Shunde.Common Namespace


AttribDataType Properties

The properties of the AttribDataType class are listed below. For a complete list of AttribDataType class members, see the AttribDataType Members topic.

Public Instance Properties

DataClassName | The C# class Name of this data type
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Gets the name of this object
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of this data type

See Also

AttribDataType Class | Shunde.Common Namespace


DataClassName Property

Shunde.NET Framework Class Library

AttribDataType.DataClassName Property

The C# class Name of this data type

public DataClassName {get; set;}

See Also

AttribDataType Class | Shunde.Common Namespace


FriendlyName Property

Shunde.NET Framework Class Library

AttribDataType.FriendlyName Property

Gets the name of this object

public override FriendlyName {get;}

See Also

AttribDataType Class | Shunde.Common Namespace


Name Property

Shunde.NET Framework Class Library

AttribDataType.Name Property

The Name of this data type

public Name {get; set;}

See Also

AttribDataType Class | Shunde.Common Namespace


AttribDataType Methods

The methods of the AttribDataType class are listed below. For a complete list of AttribDataType class members, see the AttribDataType Members topic.

Public Static Methods

GetAttribDataTypes Gets and populates all the AttribDataTypes

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetDataType | Gets the data Type of the attribute
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttribDataType Class | Shunde.Common Namespace


AttribDataType.GetAttribDataTypes Method

Gets and populates all the AttribDataTypes

public static AttribDataType[] GetAttribDataTypes();

Return Value

Returns an array of 0 or more AttribDataTypes

See Also

AttribDataType Class | Shunde.Common Namespace


AttribDataType.GetDataType Method

Gets the data Type of the attribute

public Type GetDataType();

See Also

AttribDataType Class | Shunde.Common Namespace


AttribRelation Class

A relation between an object and an attribute

For a list of all members of this type, see AttribRelation Members.

System.Object
DBObject
AttribRelation

public class AttribRelation : DBObject,

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

AttribRelation Members | Shunde.Common Namespace


AttribRelation Members

AttribRelation overview

Public Static Methods

GetAttribRelations | Gets the relations for a given attribute type and object
GetAttribsRelatedTo | Gets and populates all the Attribs that are related (by an AttribRelation) to the given Object

Public Instance Constructors

AttribRelation Constructor Initializes a new instance of the AttribRelation class.

Public Instance Properties

Attrib | The attribute in the relation
DBObject | The object related to the attribute
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName (inherited from DBObject) | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttribRelation Class | Shunde.Common Namespace


AttribRelation Constructor

Initializes a new instance of the AttribRelation class.

public AttribRelation();

See Also

AttribRelation Class | Shunde.Common Namespace


AttribRelation Properties

The properties of the AttribRelation class are listed below. For a complete list of AttribRelation class members, see the AttribRelation Members topic.

Public Instance Properties

Attrib | The attribute in the relation
DBObject | The object related to the attribute
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName (inherited from DBObject) | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object

See Also

AttribRelation Class | Shunde.Common Namespace


Attrib Property

Shunde.NET Framework Class Library

AttribRelation.Attrib Property

The attribute in the relation

public Attrib {get; set;}

Implements

IAttribRelation.

See Also

AttribRelation Class | Shunde.Common Namespace


DBObject Property

Shunde.NET Framework Class Library

AttribRelation.DBObject Property

The object related to the attribute

public DBObject {get; set;}

Implements

IAttribRelation.

See Also

AttribRelation Class | Shunde.Common Namespace | AttribRelation.DBObject Overload List


AttribRelation Methods

The methods of the AttribRelation class are listed below. For a complete list of AttribRelation class members, see the AttribRelation Members topic.

Public Static Methods

GetAttribRelations | Gets the relations for a given attribute type and object
GetAttribsRelatedTo | Gets and populates all the Attribs that are related (by an AttribRelation) to the given Object

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttribRelation Class | Shunde.Common Namespace


AttribRelation.GetAttribRelations Method

Gets the relations for a given attribute type and object

public static AttribRelation[] GetAttribRelations(
DBObject relatedObject
);

Remarks

Returns deleted relations also

See Also

AttribRelation Class | Shunde.Common Namespace


AttribRelation.GetAttribsRelatedTo Method

Gets and populates all the Attribs that are related (by an AttribRelation) to the given Object

public static Attrib[] GetAttribsRelatedTo(
DBObject relatedObject
);

Return Value

Returns an array of 0 or more Attrib objects

See Also

AttribRelation Class | Shunde.Common Namespace


AttribType Class

An Type of an Attrib

For a list of all members of this type, see AttribType Members.

System.Object
DBObject
AttribType

public class AttribType : DBObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

AttribType Members | Shunde.Common Namespace


AttribType Members

AttribType overview

Public Static Methods

GetAttribType | Gets an AttribType with the given Name
GetAttribTypes | Gets and populates the AttribTypes that exist in the given object

Public Instance Constructors

AttribType Constructor Initializes a new instance of the AttribType class.

Public Instance Properties

AllowMultiSelections | Allow multiple selections to be made. Only valid if this is a shared attribute type.
CurrentRelations | Currently selected relations for this attribute type
DataType | The type of the attribute
DecimalPlaces | The number of decimal places to round to, for float numbers
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName (inherited from DBObject) | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id (inherited from DBObject) | The id of the object
Instructions | Instructions on how this attribute should be filled in, for site administrators
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
IsImage | Applicable to Binary data; specifies that it is an image
IsMultiLine | Applicable to strings only, specifies that it is a multi-line string
IsRequired | Specifies that this attribute is required to have a value
IsShared | Specifies that this is a shared attribute. This means more than one object can access this attribute.
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of this attribute
Owner | The object that this Attribute Type belongs to
Suffix | The text which should follow the Value of the attribute
UseRichTextEditor | Applicable to Multiline strings only, specifies that, if available, a rich-text editor should be used for editing

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetDataType | Gets the Type of the attribute
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttribType Class | Shunde.Common Namespace


AttribType Constructor

Initializes a new instance of the AttribType class.

public AttribType();

See Also

AttribType Class | Shunde.Common Namespace


AttribType Properties

The properties of the AttribType class are listed below. For a complete list of AttribType class members, see the AttribType Members topic.

Public Instance Properties

AllowMultiSelections | Allow multiple selections to be made. Only valid if this is a shared attribute type.
CurrentRelations | Currently selected relations for this attribute type
DataType | The type of the attribute
DecimalPlaces | The number of decimal places to round to, for float numbers
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName (inherited from DBObject) | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id (inherited from DBObject) | The id of the object
Instructions | Instructions on how this attribute should be filled in, for site administrators
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
IsImage | Applicable to Binary data; specifies that it is an image
IsMultiLine | Applicable to strings only, specifies that it is a multi-line string
IsRequired | Specifies that this attribute is required to have a value
IsShared | Specifies that this is a shared attribute. This means more than one object can access this attribute.
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of this attribute
Owner | The object that this Attribute Type belongs to
Suffix | The text which should follow the Value of the attribute
UseRichTextEditor | Applicable to Multiline strings only, specifies that, if available, a rich-text editor should be used for editing

See Also

AttribType Class | Shunde.Common Namespace


AllowMultiSelections Property

Shunde.NET Framework Class Library

AttribType.AllowMultiSelections Property

Allow multiple selections to be made. Only valid if this is a shared attribute type.

public AllowMultiSelections {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


CurrentRelations Property

Shunde.NET Framework Class Library

AttribType.CurrentRelations Property

Currently selected relations for this attribute type

public CurrentRelations {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


DataType Property

Shunde.NET Framework Class Library

AttribType.DataType Property

The type of the attribute

public DataType {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


DecimalPlaces Property

Shunde.NET Framework Class Library

AttribType.DecimalPlaces Property

The number of decimal places to round to, for float numbers

public DecimalPlaces {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


Instructions Property

Shunde.NET Framework Class Library

AttribType.Instructions Property

Instructions on how this attribute should be filled in, for site administrators

public Instructions {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


IsImage Property

Shunde.NET Framework Class Library

AttribType.IsImage Property

Applicable to Binary data; specifies that it is an image

public IsImage {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


IsMultiLine Property

Shunde.NET Framework Class Library

AttribType.IsMultiLine Property

Applicable to strings only, specifies that it is a multi-line string

public IsMultiLine {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


IsRequired Property

Shunde.NET Framework Class Library

AttribType.IsRequired Property

Specifies that this attribute is required to have a value

public IsRequired {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


IsShared Property

Shunde.NET Framework Class Library

AttribType.IsShared Property

Specifies that this is a shared attribute. This means more than one object can access this attribute.

public IsShared {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


Name Property

Shunde.NET Framework Class Library

AttribType.Name Property

The Name of this attribute

public Name {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


Owner Property

Shunde.NET Framework Class Library

AttribType.Owner Property

The object that this Attribute Type belongs to

public Owner {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


Suffix Property

Shunde.NET Framework Class Library

AttribType.Suffix Property

The text which should follow the Value of the attribute

public Suffix {get; set;}

Remarks

This is useful for those attributes which are measures. For example, the Suffix may be "meters", in which case "meters" will follow the Value of the attribute

See Also

AttribType Class | Shunde.Common Namespace


UseRichTextEditor Property

Shunde.NET Framework Class Library

AttribType.UseRichTextEditor Property

Applicable to Multiline strings only, specifies that, if available, a rich-text editor should be used for editing

public UseRichTextEditor {get; set;}

See Also

AttribType Class | Shunde.Common Namespace


AttribType Methods

The methods of the AttribType class are listed below. For a complete list of AttribType class members, see the AttribType Members topic.

Public Static Methods

GetAttribType | Gets an AttribType with the given Name
GetAttribTypes | Gets and populates the AttribTypes that exist in the given object

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetDataType | Gets the Type of the attribute
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttribType Class | Shunde.Common Namespace


AttribType.GetAttribType Method

Gets an AttribType with the given Name

public static AttribType GetAttribType(
String name
);

See Also

AttribType Class | Shunde.Common Namespace


AttribType.GetAttribTypes Method

Gets and populates the AttribTypes that exist in the given object

public static AttribType[] GetAttribTypes(
DBObject owner
);

See Also

AttribType Class | Shunde.Common Namespace


AttribType.GetDataType Method

Gets the Type of the attribute

public Type GetDataType();

See Also

AttribType Class | Shunde.Common Namespace


Email Class

An email message that can be sent to people

For a list of all members of this type, see Email Members.

System.Object
MailMessage
Email

public class Email : MailMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

Email Members | Shunde.Common Namespace


Email Members

Email overview

Public Static Fields

FixedSizeFont | CSS Style used fixed-width characters
NiceFont | Arial CSS

Public Instance Constructors

Email Constructor Constructor

Public Instance Properties

AlternateViews (inherited from MailMessage) | Gets the attachment collection used to store alternate forms of the message body.
Attachments (inherited from MailMessage) | Gets the attachment collection used to store data attached to this e-mail message.
Bcc (inherited from MailMessage) | Gets the address collection that contains the blind carbon copy (BCC) recipients for this e-mail message.
Body (inherited from MailMessage) | Gets or sets the message body.
BodyEncoding (inherited from MailMessage) | Gets or sets the encoding used to encode the message body.
CC (inherited from MailMessage) | Gets the address collection that contains the carbon copy (CC) recipients for this e-mail message.
DeliveryNotificationOptions (inherited from MailMessage) | Gets or sets the delivery notifications for this e-mail message.
From (inherited from MailMessage) | Gets or sets the from address for this e-mail message.
Headers (inherited from MailMessage) | Gets the e-mail headers that are transmitted with this e-mail message.
IsBodyHtml (inherited from MailMessage) | Gets or sets a value indicating whether the mail message body is in Html.
Priority (inherited from MailMessage) | Gets or sets the priority of this e-mail message.
ReplyTo (inherited from MailMessage) | Gets or sets the ReplyTo address for the mail message.
Sender (inherited from MailMessage) | Gets or sets the sender's address for this e-mail message.
Subject (inherited from MailMessage) | Gets or sets the subject line for this e-mail message.
SubjectEncoding (inherited from MailMessage) | Gets or sets the encoding used for the subject content for this e-mail message.
To (inherited from MailMessage) | Gets the address collection that contains the recipients of this e-mail message.

Public Instance Methods

BulkSend | Sends this email to bulk recipients
Dispose (inherited from MailMessage) | Overloaded. Releases all resources used by the MailMessage.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Send | Overloaded. Sends this email message
SetHtmlMessage | Sets the message body as HTML
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from MailMessage) | Overloaded. Releases the unmanaged resources used by the MailMessage and optionally releases the managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Email Class | Shunde.Common Namespace


Email Constructor

Constructor

public Email();

See Also

Email Class | Shunde.Common Namespace


Email Fields

The fields of the Email class are listed below. For a complete list of Email class members, see the Email Members topic.

Public Static Fields

FixedSizeFont | CSS Style used fixed-width characters
NiceFont | Arial CSS

See Also

Email Class | Shunde.Common Namespace


Email.FixedSizeFont Field

CSS Style used fixed-width characters

public const String FixedSizeFont = "body { font-family: Courier New; font-size: 14px; }";

See Also

Email Class | Shunde.Common Namespace


Email.NiceFont Field

Arial CSS

public const String NiceFont = "body { font-family: Arial; font-size: 14px; }";

See Also

Email Class | Shunde.Common Namespace


Email Methods

The methods of the Email class are listed below. For a complete list of Email class members, see the Email Members topic.

Public Instance Methods

BulkSend | Sends this email to bulk recipients
Dispose (inherited from MailMessage) | Overloaded. Releases all resources used by the MailMessage.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Send | Overloaded. Sends this email message
SetHtmlMessage | Sets the message body as HTML
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from MailMessage) | Overloaded. Releases the unmanaged resources used by the MailMessage and optionally releases the managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Email Class | Shunde.Common Namespace


Email.BulkSend Method

Sends this email to bulk recipients

public void BulkSend(
String smtpServer,
Int32 port,
List<T> recipients
);

Parameters

String
Int32
List<T>

Remarks

Places the email addresses in the BCC fields, breaking it up into multiple sends if necessary

See Also

Email Class | Shunde.Common Namespace


Send Method

Shunde.NET Framework Class Library

Email.Send Method

Sends this email message

Overload List

Sends this email message

public void Send();

Sends this email message

public void Send(String);

Sends this email message

public void Send(String,Int32);

See Also

Email Class | Shunde.Common Namespace


Email.Send Method ()

Sends this email message

public void Send();

Remarks

Uses SMTP server localhost on port 25

See Also

Email Class | Shunde.Common Namespace | Email.Send Overload List


Email.Send Method (String)

Sends this email message

public void Send(
String server
);

Parameters

String

Remarks

Uses Port 25

See Also

Email Class | Shunde.Common Namespace | Email.Send Overload List


Email.Send Method (String, Int32)

Sends this email message

public void Send(
String server,
Int32 port
);

Parameters

String
Int32

See Also

Email Class | Shunde.Common Namespace | Email.Send Overload List


Email.SetHtmlMessage Method

Sets the message body as HTML

public void SetHtmlMessage(
String message,
String cssStyles
);

Parameters

String
String

See Also

Email Class | Shunde.Common Namespace


GenericType Class

This is a generic class for a type, for example a type of event

For a list of all members of this type, see GenericType Members.

System.Object
DBObject
GenericType

public class GenericType : DBObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This allows multiple type objects, normally kept in separate tables, to all be stored in one Table.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

GenericType Members | Shunde.Common Namespace


GenericType Members

GenericType overview

Public Static Methods

GetGenericTypes Overloaded. Gets and populates all the GenericTypes for the given type

Public Instance Constructors

GenericType Constructor Initializes a new instance of the GenericType class.

Public Instance Fields

objects The objects within this type

Public Instance Properties

Code | A unique code to identify this GenericType
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FormatInfo | Optional text field containing format information, such as a colour Code
FriendlyName | Gets the friendly name of the object
GenericTypeType | The type of generic type that this is
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of this data type
Notes | Any extra Notes about this type

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericType Class | Shunde.Common Namespace


GenericType Constructor

Initializes a new instance of the GenericType class.

public GenericType();

See Also

GenericType Class | Shunde.Common Namespace


GenericType Fields

The fields of the GenericType class are listed below. For a complete list of GenericType class members, see the GenericType Members topic.

Public Instance Fields

objects The objects within this type

See Also

GenericType Class | Shunde.Common Namespace


GenericType.objects Field

The objects within this type

public IEnumerable<T> objects;

See Also

GenericType Class | Shunde.Common Namespace


GenericType Properties

The properties of the GenericType class are listed below. For a complete list of GenericType class members, see the GenericType Members topic.

Public Instance Properties

Code | A unique code to identify this GenericType
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FormatInfo | Optional text field containing format information, such as a colour Code
FriendlyName | Gets the friendly name of the object
GenericTypeType | The type of generic type that this is
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of this data type
Notes | Any extra Notes about this type

See Also

GenericType Class | Shunde.Common Namespace


Code Property

Shunde.NET Framework Class Library

GenericType.Code Property

A unique code to identify this GenericType

public Code {get; set;}

See Also

GenericType Class | Shunde.Common Namespace


FormatInfo Property

Shunde.NET Framework Class Library

GenericType.FormatInfo Property

Optional text field containing format information, such as a colour Code

public FormatInfo {get; set;}

See Also

GenericType Class | Shunde.Common Namespace


FriendlyName Property

Shunde.NET Framework Class Library

GenericType.FriendlyName Property

Gets the friendly name of the object

public override FriendlyName {get;}

See Also

GenericType Class | Shunde.Common Namespace


GenericTypeType Property

Shunde.NET Framework Class Library

GenericType.GenericTypeType Property

The type of generic type that this is

public GenericTypeType {get; set;}

See Also

GenericType Class | Shunde.Common Namespace


Name Property

Shunde.NET Framework Class Library

GenericType.Name Property

The Name of this data type

public Name {get; set;}

See Also

GenericType Class | Shunde.Common Namespace


Notes Property

Shunde.NET Framework Class Library

GenericType.Notes Property

Any extra Notes about this type

public Notes {get; set;}

See Also

GenericType Class | Shunde.Common Namespace


GenericType Methods

The methods of the GenericType class are listed below. For a complete list of GenericType class members, see the GenericType Members topic.

Public Static Methods

GetGenericTypes Overloaded. Gets and populates all the GenericTypes for the given type

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericType Class | Shunde.Common Namespace


GetGenericTypes Method

Shunde.NET Framework Class Library

GenericType.GetGenericTypes Method

Gets all the generic types in the database, irrespective of the GenericTypeType

Overload List

Gets all the generic types in the database, irrespective of the GenericTypeType

public static GenericType[] GetGenericTypes();

Gets and populates all the GenericTypes for the given type

public static GenericType[] GetGenericTypes(GenericTypeType);

Gets and populates all the GenericTypes for the given Code

public static GenericType[] GetGenericTypes(Int32);

See Also

GenericType Class | Shunde.Common Namespace


GenericType.GetGenericTypes Method ()

Gets all the generic types in the database, irrespective of the GenericTypeType

public static GenericType[] GetGenericTypes();

Return Value

Returns an array of 0 or more GenericTypes

See Also

GenericType Class | Shunde.Common Namespace | GenericType.GetGenericTypes Overload List


GenericType.GetGenericTypes Method (GenericTypeType)

Gets and populates all the GenericTypes for the given type

public static GenericType[] GetGenericTypes(
GenericTypeType genericTypeType
);

Parameters

GenericTypeType

Return Value

Returns an array of 0 or more GenericTypes

See Also

GenericType Class | Shunde.Common Namespace | GenericType.GetGenericTypes Overload List


GenericType.GetGenericTypes Method (Int32)

Gets and populates all the GenericTypes for the given Code

public static GenericType[] GetGenericTypes(
Int32 genericTypeTypeCode
);

Parameters

Int32

Return Value

Returns an array of 0 or more GenericTypes

See Also

GenericType Class | Shunde.Common Namespace | GenericType.GetGenericTypes Overload List


GenericTypeType Class

This is a type of a GenericType, for example "Event Type"

For a list of all members of this type, see GenericTypeType Members.

System.Object
DBObject
GenericTypeType

public class GenericTypeType : DBObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

GenericTypeType Members | Shunde.Common Namespace


GenericTypeType Members

GenericTypeType overview

Public Static Methods

GetGenericTypeType | Gets the GenericTypeType with the given Code
GetGenericTypeTypes | Gets and populates all the GenericTypeTypes

Public Instance Constructors

GenericTypeType Constructor Initializes a new instance of the GenericTypeType class.

Public Instance Properties

Code | A unique Code identifying this type
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Gets the friendly name of the object
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of this data type
Notes | Any extra Notes about this type

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericTypeType Class | Shunde.Common Namespace


GenericTypeType Constructor

Initializes a new instance of the GenericTypeType class.

public GenericTypeType();

See Also

GenericTypeType Class | Shunde.Common Namespace


GenericTypeType Properties

The properties of the GenericTypeType class are listed below. For a complete list of GenericTypeType class members, see the GenericTypeType Members topic.

Public Instance Properties

Code | A unique Code identifying this type
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Gets the friendly name of the object
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of this data type
Notes | Any extra Notes about this type

See Also

GenericTypeType Class | Shunde.Common Namespace


Code Property

Shunde.NET Framework Class Library

GenericTypeType.Code Property

A unique Code identifying this type

public Code {get; set;}

See Also

GenericTypeType Class | Shunde.Common Namespace


FriendlyName Property

Shunde.NET Framework Class Library

GenericTypeType.FriendlyName Property

Gets the friendly name of the object

public override FriendlyName {get;}

See Also

GenericTypeType Class | Shunde.Common Namespace


Name Property

Shunde.NET Framework Class Library

GenericTypeType.Name Property

The Name of this data type

public Name {get; set;}

See Also

GenericTypeType Class | Shunde.Common Namespace


Notes Property

Shunde.NET Framework Class Library

GenericTypeType.Notes Property

Any extra Notes about this type

public Notes {get; set;}

See Also

GenericTypeType Class | Shunde.Common Namespace


GenericTypeType Methods

The methods of the GenericTypeType class are listed below. For a complete list of GenericTypeType class members, see the GenericTypeType Members topic.

Public Static Methods

GetGenericTypeType | Gets the GenericTypeType with the given Code
GetGenericTypeTypes | Gets and populates all the GenericTypeTypes

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GenericTypeType Class | Shunde.Common Namespace


GenericTypeType.GetGenericTypeType Method

Gets the GenericTypeType with the given Code

public static GenericTypeType GetGenericTypeType(
Int32 code
);

See Also

GenericTypeType Class | Shunde.Common Namespace


GenericTypeType.GetGenericTypeTypes Method

Gets and populates all the GenericTypeTypes

public static GenericTypeType[] GetGenericTypeTypes();

Return Value

Returns an array of 0 or more GenericTypeTypes

See Also

GenericTypeType Class | Shunde.Common Namespace


IAttribRelation Interface

A relation between some object and an attribute

For a list of all members of this type, see IAttribRelation Members.

public interface IAttribRelation

Types that implement IAttribRelation

Type | Description
AttribRelation | A relation between an object and an attribute

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

IAttribRelation Members | Shunde.Common Namespace


IAttribRelation Members

IAttribRelation overview

Public Instance Properties

Attrib | The attribute in the relation
DBObject | The object that is related to the attrib
IsDeleted | Specifies whether this relation is deleted or not

Public Instance Methods

Save Saves any changes to this relation;

See Also

IAttribRelation Interface | Shunde.Common Namespace


IAttribRelation Properties

The properties of the IAttribRelation interface are listed below. For a complete list of IAttribRelation interface members, see the IAttribRelation Members topic.

Public Instance Properties

Attrib | The attribute in the relation
DBObject | The object that is related to the attrib
IsDeleted | Specifies whether this relation is deleted or not

See Also

IAttribRelation Interface | Shunde.Common Namespace


Attrib Property

Shunde.NET Framework Class Library

IAttribRelation.Attrib Property

The attribute in the relation

Attrib {get; set;}

See Also

IAttribRelation Interface | Shunde.Common Namespace


DBObject Property

Shunde.NET Framework Class Library

IAttribRelation.DBObject Property

The object that is related to the attrib

DBObject {get; set;}

See Also

IAttribRelation Interface | Shunde.Common Namespace


IsDeleted Property

Shunde.NET Framework Class Library

IAttribRelation.IsDeleted Property

Specifies whether this relation is deleted or not

IsDeleted {get; set;}

See Also

IAttribRelation Interface | Shunde.Common Namespace


IAttribRelation Methods

The methods of the IAttribRelation interface are listed below. For a complete list of IAttribRelation interface members, see the IAttribRelation Members topic.

Public Instance Methods

Save Saves any changes to this relation;

See Also

IAttribRelation Interface | Shunde.Common Namespace


IAttribRelation.Save Method

Saves any changes to this relation;

void Save();

See Also

IAttribRelation Interface | Shunde.Common Namespace


TextSection Class

Some text, stored in the database

For a list of all members of this type, see TextSection Members.

System.Object
DBObject
TextSection

public class TextSection : DBObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

TextSection Members | Shunde.Common Namespace


TextSection Members

TextSection overview

Public Instance Constructors

TextSection Overloaded. Initializes a new instance of the TextSection class.

Public Instance Properties

Code | Unique Code identifying this object
Content | The Content of the text
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Returns the header name if one exists; otherwise the default friendly name is returned
Header | An optional Header
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
NameForAdministrators | The name for this textblock for administrators, for editing purposes, for example 'Homepage'

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetTextSectionsForAdministration | Gets all the text sections that have a value specified for administrators
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextSection Class | Shunde.Common Namespace


TextSection Constructor

Default Constructor

Overload List

Default Constructor

public TextSection();

Creates a new TextSection object and populates it using the specified Code

public TextSection(String);

See Also

TextSection Class | Shunde.Common Namespace


TextSection Constructor ()

Default Constructor

public TextSection();

Remarks

This constructor exists only because all DBObjects must have a constructor that takes no paramaters. You should use the other constructor when creating a TextSection object.

See Also

TextSection Class | Shunde.Common Namespace | TextSection Constructor Overload List


TextSection Constructor (String)

Creates a new TextSection object and populates it using the specified Code

public TextSection(
String code
);

Parameters

String

See Also

TextSection Class | Shunde.Common Namespace | TextSection Constructor Overload List


TextSection Properties

The properties of the TextSection class are listed below. For a complete list of TextSection class members, see the TextSection Members topic.

Public Instance Properties

Code | Unique Code identifying this object
Content | The Content of the text
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Returns the header name if one exists; otherwise the default friendly name is returned
Header | An optional Header
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
NameForAdministrators | The name for this textblock for administrators, for editing purposes, for example 'Homepage'

See Also

TextSection Class | Shunde.Common Namespace


Code Property

Shunde.NET Framework Class Library

TextSection.Code Property

Unique Code identifying this object

public Code {get; set;}

Remarks

This can be any unique identify, however, it is recommended that the URL of a page is used, ignoring the querystring.

See Also

TextSection Class | Shunde.Common Namespace


Content Property

Shunde.NET Framework Class Library

TextSection.Content Property

The Content of the text

public Content {get; set;}

See Also

TextSection Class | Shunde.Common Namespace


FriendlyName Property

Shunde.NET Framework Class Library

TextSection.FriendlyName Property

Returns the header name if one exists; otherwise the default friendly name is returned

public override FriendlyName {get;}

See Also

TextSection Class | Shunde.Common Namespace


Header Property

Shunde.NET Framework Class Library

TextSection.Header Property

An optional Header

public Header {get; set;}

See Also

TextSection Class | Shunde.Common Namespace


NameForAdministrators Property

Shunde.NET Framework Class Library

TextSection.NameForAdministrators Property

The name for this textblock for administrators, for editing purposes, for example 'Homepage'

public NameForAdministrators {get; set;}

See Also

TextSection Class | Shunde.Common Namespace


TextSection Methods

The methods of the TextSection class are listed below. For a complete list of TextSection class members, see the TextSection Members topic.

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetTextSectionsForAdministration | Gets all the text sections that have a value specified for administrators
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextSection Class | Shunde.Common Namespace


TextSection.GetTextSectionsForAdministration Method

Gets all the text sections that have a value specified for administrators

public TextSection[] GetTextSectionsForAdministration();

See Also

TextSection Class | Shunde.Common Namespace


TreeNode Class

A node of a tree, to allow for heirachical structures

For a list of all members of this type, see TreeNode Members.

System.Object
DBObject
TreeNode
Attrib

public class TreeNode : DBObject,

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

TreeNode Members | Shunde.Common Namespace


TreeNode Members

TreeNode overview

Public Static Methods

ConvertToFlatArray | Overloaded. Converts a heirachacle Array of Categories into a flat array of Categories
FindTreeNode | Finds the TreeNode with the TreeNode id catId from the tree of categories
GetTreeNodesAsForest | Overloaded. Gets all the tree nodes in the database
Search | Searches for a TreeNode

Protected Static Methods

ConvertToForest Converts an array of TreeNode objects into a forest of trees

Public Instance Properties

Children | The Children of this TreeNode
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Gets the friendly name of the object
FullName | Returns the Name of this TreeNode, with all ancestors names
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
IsHidden | Specifies that this TreeNode is hidden
IsLeaf | Returns true if this TreeNode is a leaf node (ie. has no Children)
IsShaded | Specifies whether a TreeNode is visible, or shaded
IsVisible | Returns true if this TreeNode, and none of its parents, are hidden
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of the TreeNode
Notes | Notes pertaining to this TreeNode
Parent | The Parent of this TreeNode
RootNode | Returns the root node of the tree that this TreeNode belongs in

Public Instance Methods

CompareTo | Compares the Name of this string to another TreeNode
Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
FindDescendant | Finds the TreeNode from the Children, or descendants of this TreeNode
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateAncestors | Populates the ancestors of this tree node
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Constructors

TreeNode Constructor Initializes a new instance of the TreeNode class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode Constructor

Initializes a new instance of the TreeNode class.

protected TreeNode();

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode Properties

The properties of the TreeNode class are listed below. For a complete list of TreeNode class members, see the TreeNode Members topic.

Public Instance Properties

Children | The Children of this TreeNode
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Gets the friendly name of the object
FullName | Returns the Name of this TreeNode, with all ancestors names
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
IsHidden | Specifies that this TreeNode is hidden
IsLeaf | Returns true if this TreeNode is a leaf node (ie. has no Children)
IsShaded | Specifies whether a TreeNode is visible, or shaded
IsVisible | Returns true if this TreeNode, and none of its parents, are hidden
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
Name | The Name of the TreeNode
Notes | Notes pertaining to this TreeNode
Parent | The Parent of this TreeNode
RootNode | Returns the root node of the tree that this TreeNode belongs in

See Also

TreeNode Class | Shunde.Common Namespace


Children Property

Shunde.NET Framework Class Library

TreeNode.Children Property

The Children of this TreeNode

public Children {get; set;}

See Also

TreeNode Class | Shunde.Common Namespace


FriendlyName Property

Shunde.NET Framework Class Library

TreeNode.FriendlyName Property

Gets the friendly name of the object

public override FriendlyName {get;}

See Also

TreeNode Class | Shunde.Common Namespace


FullName Property

Shunde.NET Framework Class Library

TreeNode.FullName Property

Returns the Name of this TreeNode, with all ancestors names

public FullName {get;}

See Also

TreeNode Class | Shunde.Common Namespace


IsHidden Property

Shunde.NET Framework Class Library

TreeNode.IsHidden Property

Specifies that this TreeNode is hidden

public IsHidden {get; set;}

See Also

TreeNode Class | Shunde.Common Namespace


IsLeaf Property

Shunde.NET Framework Class Library

TreeNode.IsLeaf Property

Returns true if this TreeNode is a leaf node (ie. has no Children)

public IsLeaf {get;}

See Also

TreeNode Class | Shunde.Common Namespace


IsShaded Property

Shunde.NET Framework Class Library

TreeNode.IsShaded Property

Specifies whether a TreeNode is visible, or shaded

public IsShaded {get;}

Remarks

A TreeNode is 'shaded' if either it is hidden, or one of its ancestors is hidden - this is not set from the database; rather it is a 'cached' variable, only valid if set, to save time working it out every time it is needed.

See Also

TreeNode Class | Shunde.Common Namespace


IsVisible Property

Shunde.NET Framework Class Library

TreeNode.IsVisible Property

Returns true if this TreeNode, and none of its parents, are hidden

public IsVisible {get;}

See Also

TreeNode Class | Shunde.Common Namespace


Name Property

Shunde.NET Framework Class Library

TreeNode.Name Property

The Name of the TreeNode

public Name {get; set;}

See Also

TreeNode Class | Shunde.Common Namespace


Notes Property

Shunde.NET Framework Class Library

TreeNode.Notes Property

Notes pertaining to this TreeNode

public Notes {get; set;}

See Also

TreeNode Class | Shunde.Common Namespace


Parent Property

Shunde.NET Framework Class Library

TreeNode.Parent Property

The Parent of this TreeNode

public Parent {get; set;}

See Also

TreeNode Class | Shunde.Common Namespace


RootNode Property

Shunde.NET Framework Class Library

TreeNode.RootNode Property

Returns the root node of the tree that this TreeNode belongs in

public RootNode {get;}

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode Methods

The methods of the TreeNode class are listed below. For a complete list of TreeNode class members, see the TreeNode Members topic.

Public Static Methods

ConvertToFlatArray | Overloaded. Converts a heirachacle Array of Categories into a flat array of Categories
FindTreeNode | Finds the TreeNode with the TreeNode id catId from the tree of categories
GetTreeNodesAsForest | Overloaded. Gets all the tree nodes in the database
Search | Searches for a TreeNode

Protected Static Methods

ConvertToForest Converts an array of TreeNode objects into a forest of trees

Public Instance Methods

CompareTo | Compares the Name of this string to another TreeNode
Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
FindDescendant | Finds the TreeNode from the Children, or descendants of this TreeNode
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateAncestors | Populates the ancestors of this tree node
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode.CompareTo Method

Compares the Name of this string to another TreeNode

public virtual int CompareTo(
Object another
);

Implements

IComparable.

See Also

TreeNode Class | Shunde.Common Namespace


ConvertToFlatArray Method

Shunde.NET Framework Class Library

TreeNode.ConvertToFlatArray Method

Converts a heirachacle Array of Categories into a flat array of Categories

Overload List

Converts a heirachacle Array of Categories into a flat array of Categories

public static TreeNode[] ConvertToFlatArray(TreeNode[]);

Converts a heirachacle Array of Categories into a flat array of Categories

public static TreeNode[] ConvertToFlatArray(TreeNode[],Type);

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode.ConvertToFlatArray Method (TreeNode[])

Converts a heirachacle Array of Categories into a flat array of Categories

public static TreeNode[] ConvertToFlatArray(
TreeNode[] cats
);

Remarks

The relationships between Parent/Children are retained. It orders the categories alphabetically.

See Also

TreeNode Class | Shunde.Common Namespace | TreeNode.ConvertToFlatArray Overload List


TreeNode.ConvertToFlatArray Method (TreeNode[], Type)

Converts a heirachacle Array of Categories into a flat array of Categories

public static TreeNode[] ConvertToFlatArray(
TreeNode[] cats,
Type baseType
);

Remarks

The relationships between Parent/Children are retained. It orders the categories alphabetically.

See Also

TreeNode Class | Shunde.Common Namespace | TreeNode.ConvertToFlatArray Overload List


TreeNode.ConvertToForest Method

Converts an array of TreeNode objects into a forest of trees

protected static TreeNode[] ConvertToForest(
TreeNode[] allCats,
Type baseType
);

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode.FindDescendant Method

Finds the TreeNode from the Children, or descendants of this TreeNode

public TreeNode FindDescendant(
Int32 catId
);

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode.FindTreeNode Method

Finds the TreeNode with the TreeNode id catId from the tree of categories

public static TreeNode FindTreeNode(
TreeNode[] cats,
Int32 catId
);

See Also

TreeNode Class | Shunde.Common Namespace


GetTreeNodesAsForest Method

Shunde.NET Framework Class Library

TreeNode.GetTreeNodesAsForest Method

Gets all the tree nodes in the database

Overload List

Gets all the tree nodes in the database

public static TreeNode[] GetTreeNodesAsForest(String,Type,Type[]);

Gets all the tree nodes in the database

public static TreeNode[] GetTreeNodesAsForest(Type,Type[]);

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode.GetTreeNodesAsForest Method (String, Type, Type[])

Gets all the tree nodes in the database

public static TreeNode[] GetTreeNodesAsForest(
String where,
Type baseType,
Type[] catTypes
);

See Also

TreeNode Class | Shunde.Common Namespace | TreeNode.GetTreeNodesAsForest Overload List


TreeNode.GetTreeNodesAsForest Method (Type, Type[])

Gets all the tree nodes in the database

public static TreeNode[] GetTreeNodesAsForest(
Type baseType,
Type[] catTypes
);

Remarks

Even gets deleted tree nodes

See Also

TreeNode Class | Shunde.Common Namespace | TreeNode.GetTreeNodesAsForest Overload List


TreeNode.PopulateAncestors Method

Populates the ancestors of this tree node

public void PopulateAncestors();

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode.Save Method

Saves this object to the database

public override void Save();

Remarks

Before saving, TreeNode loops are checked for

See Also

TreeNode Class | Shunde.Common Namespace


TreeNode.Search Method

Searches for a TreeNode

public static TreeNode[] Search(
String query,
TreeNode[] cats
);

Parameters

String
TreeNode[]

See Also

TreeNode Class | Shunde.Common Namespace


WebPage Class

The base of each webpage.

For a list of all members of this type, see WebPage Members.

System.Object
Control
TemplateControl
Page
WebPage

public class WebPage : Page

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This is inherited by each ASP.NET page. It exposes certain properties and methods needed throughout a website

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

WebPage Members | Shunde.Common Namespace


WebPage Members

WebPage overview

Public Instance Properties

Application (inherited from Page) | Gets the HttpApplicationState object for the current Web request.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
AppRelativeVirtualPath (inherited from TemplateControl) | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled.
AsyncTimeout (inherited from Page) | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
Buffer (inherited from Page) | Sets a value indicating whether the page output is buffered.
Cache (inherited from Page) | Gets the Cache object associated with the application in which the page resides.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ClientQueryString (inherited from Page) | Gets the query string portion of the requested URL.
ClientScript (inherited from Page) | Gets a ClientScriptManager object used to manage, register, and add script to the page.
ClientTarget (inherited from Page) | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients.
CodePage (inherited from Page) | Sets the code page identifier for the current Page.
ConnectionString | Gets the database connection string
ContentType (inherited from Page) | Sets the HTTP MIME type for the HttpResponse object associated with the page.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Culture (inherited from Page) | Sets the culture ID for the Thread object associated with the page.
EnableEventValidation (inherited from Page) |
EnableTheming (inherited from TemplateControl) | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class.
EnableViewState (inherited from Page) | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends.
EnableViewStateMac (inherited from Page) | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client.
ErrorPage (inherited from Page) | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception.
ErrorsEmail | Gets the errors email address for this website
Form (inherited from Page) | Gets the HTML form for the page.
Header (inherited from Page) | Gets the document header for the page if the head element is defined with a runat=server in the page declaration.
ID (inherited from Page) | Gets or sets an identifier for a particular instance of the Page class.
IdSeparator (inherited from Page) | Gets the character used to separate control identifiers when building a unique ID for a control on a page.
IsAsync (inherited from Page) | Gets a value indicating whether the page is processed asynchronously.
IsCallback (inherited from Page) | Gets a value indicating whether the page request is the result of a call back.
IsCrossPagePostBack (inherited from Page) | Gets a value indicating whether the page is involved in a cross-page postback.
IsPostBack (inherited from Page) | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.
IsReusable (inherited from Page) | Gets a value indicating whether the Page object can be reused.
IsValid (inherited from Page) | Gets a value indicating whether page validation succeeded.
Items (inherited from Page) | Gets a list of objects stored in the page context.
LCID (inherited from Page) | Sets the locale identifier for the Thread object associated with the page.
MaintainScrollPositionOnPostBack (inherited from Page) | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback.
Master (inherited from Page) | Gets the master page that determines the overall look of the page.
MasterPageFile (inherited from Page) | Gets or sets the file name of the master page.
MaxPageStateFieldLength (inherited from Page) | Gets or sets the maximum length for the page's state field.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
PageAdapter (inherited from Page) | Gets the adapter that renders the page for the specific requesting browser.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PreviousPage (inherited from Page) | Gets the page that transferred control to the current page.
Request (inherited from Page) | Gets the HttpRequest object for the requested page.
Response (inherited from Page) | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response.
ResponseEncoding (inherited from Page) | Sets the encoding language for the current HttpResponse object.
Server (inherited from Page) | Gets the Server object, which is an instance of the HttpServerUtility class.
Session (inherited from Page) | Gets the current Session object provided by ASP.NET.
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from Control) | Gets or sets the skin to apply to the control.
SmartNavigation (inherited from Page) | Obsolete. Gets or sets a value indicating whether smart navigation is enabled.
SmtpPortNumber | The port number of the SMTP server
SmtpServer | The IP address or host Name of the SMTP server
StyleSheetTheme (inherited from Page) | Gets or sets the name of the style sheet applied to this page.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Theme (inherited from Page) | Gets or sets the name of the page theme.
Title (inherited from Page) | Gets or sets the title for the page.
Trace (inherited from Page) | Gets the TraceContext object for the current Web request.
TraceEnabled (inherited from Page) | Sets a value indicating whether tracing is enabled for the Page object.
TraceModeValue (inherited from Page) | Sets the mode in which trace statements are displayed on the page.
UICulture (inherited from Page) | Sets the user interface (UI) ID for the Thread object associated with the page.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
User (inherited from Page) | Gets information about the user making the page request.
Validators (inherited from Page) | Gets a collection of all validation controls contained on the requested page.
ViewStateEncryptionMode (inherited from Page) | Gets or sets the encryption mode of the view state.
ViewStateUserKey (inherited from Page) | Assigns an identifier to an individual user in the view-state variable associated with the current page.
Visible (inherited from Page) | Gets or sets a value indicating whether the Page object is rendered.
WebsiteName | Gets the website Name

Public Instance Methods

AddOnPreRenderCompleteAsync (inherited from Page) | Overloaded. Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
DesignerInitialize (inherited from Page) | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteRegisteredAsyncTasks (inherited from Page) | Starts the execution of an asynchronous task.
FindControl (inherited from Page) | Overloaded. Searches the page naming container for a server control with the specified identifier.
Focus (inherited from Control) | Sets input focus to a control.
GetDataItem (inherited from Page) | Gets the data item at the top of the data-binding context stack.
GetDoubleParam | Gets a double from the querystring. Returns -1 if the param does not exist or is in an incorrect format
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIntParam | Gets an int from the querystring. Returns -1 if the param does not exist or is in an incorrect format
GetPostBackClientEvent (inherited from Page) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments.
GetPostBackClientHyperlink (inherited from Page) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments.
GetPostBackEventReference (inherited from Page) | Overloaded. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
GetStringParam | Gets a string from the querystring. Returns an empty string if the param does not exist
GetTextSection | Gets some text with the given Code
GetType (inherited from Object) | Gets the Type of the current instance.
GetTypeHashCode (inherited from Page) | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy.
GetValidators (inherited from Page) | Returns a collection of control validators for a specified validation group.
HandleException | Handles any exceptions that occur on the site
HasControls (inherited from Control) | Determines if the server control contains any child controls.
IsClientScriptBlockRegistered (inherited from Page) | Obsolete. Determines whether the client script block with the specified key is registered with the page.
IsStartupScriptRegistered (inherited from Page) | Obsolete. Determines whether the client startup script is registered with the Page object.
LoadControl (inherited from TemplateControl) | Overloaded. Loads a Control object from a file based on a specified virtual path.
LoadTemplate (inherited from TemplateControl) | Obtains an instance of the ITemplate interface from an external file.
MapPath (inherited from Page) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to.
Page_Error | Gets called whenever there is a page error
Page_Init | Called when the page loads
Page_Load | Called when the page loads
Page_Unload | Called when the page un-loads
ParseControl (inherited from TemplateControl) | Parses an input string into a Control object on the Web Forms page or user control.
ProcessRequest (inherited from Page) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties.
ReadStringResource (inherited from TemplateControl) | Reads a string resource. The ReadStringResource method is not intended for use from within your code.
Redirect | Redirets to the given URL (absolute or relative)
RegisterArrayDeclaration (inherited from Page) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered.
RegisterAsyncTask (inherited from Page) | Registers a new asynchronous task with the page.
RegisterClientScriptBlock (inherited from Page) | Obsolete. Emits client-side script blocks to the response.
RegisterHiddenField (inherited from Page) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered.
RegisterOnSubmitStatement (inherited from Page) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere.
RegisterRequiresControlState (inherited from Page) | Registers a control as one whose control state must be persisted.
RegisterRequiresPostBack (inherited from Page) | Registers a control as one that requires postback handling when the page is posted back to the server.
RegisterRequiresRaiseEvent (inherited from Page) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object.
RegisterRequiresViewStateEncryption (inherited from Page) | Registers a control with the page as one requiring view-state encryption.
RegisterStartupScript (inherited from Page) | Obsolete. Emits a client-side script block in the page response.
RegisterViewStateHandler (inherited from Page) | Causes page view state to be persisted, if called.
RemoveCache | Overloaded. Removes all the cached objects
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RequiresControlState (inherited from Page) | Determines whether the specified Control object is registered to participate in control state management.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetFocus (inherited from Page) | Overloaded. Sets the browser focus to the specified control.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
TestDeviceFilter (inherited from TemplateControl) | Returns a Boolean value indicating whether a device filter applies to the HTTP request.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterRequiresControlState (inherited from Page) | Stops persistence of control state for the specified control.
Validate (inherited from Page) | Overloaded. Instructs any validation controls included on the page to validate their assigned information.
VerifyRenderingInServerForm (inherited from Page) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time.

Public Instance Events

AbortTransaction (inherited from TemplateControl) | Occurs when a user ends a transaction.
CommitTransaction (inherited from TemplateControl) | Occurs when a transaction completes.
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Error (inherited from TemplateControl) | Occurs when an unhandled exception is thrown.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in its lifecycle.
InitComplete (inherited from Page) | Occurs when page initialization is complete.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LoadComplete (inherited from Page) | Occurs at the end of the load stage of the page's life cycle.
PreInit (inherited from Page) | Occurs at the beginning of page initialization.
PreLoad (inherited from Page) | Occurs before the page Load event.
PreRender (inherited from Control) | Occurs after the Control object is loaded but prior to rendering.
PreRenderComplete (inherited from Page) | Occurs before the page content is rendered.
SaveStateComplete (inherited from Page) | Occurs after the page has completed saving all view state and control state information for the page and controls on the page.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

Protected Instance Constructors

WebPage Constructor Initializes a new instance of the WebPage class.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
AspCompatMode (inherited from Page) | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread.
AsyncMode (inherited from Page) | Sets a value indicating whether the page is processed synchronously or asynchronously.
AutoHandlers (inherited from TemplateControl) | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
FileDependencies (inherited from Page) | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
PageStatePersister (inherited from Page) | Gets the PageStatePersister object associated with the page.
SupportAutoEvents (inherited from TemplateControl) | Gets a value indicating whether the TemplateControl control supports automatic events.
TransactionMode (inherited from Page) | Sets the level of transaction support for the page.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
AspCompatBeginProcessRequest (inherited from Page) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications.
AspCompatEndProcessRequest (inherited from Page) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications.
AsyncPageBeginProcessRequest (inherited from Page) | Begins processing an asynchronous page request.
AsyncPageEndProcessRequest (inherited from Page) | Ends processing an asynchronous page request.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
Construct (inherited from TemplateControl) | Performs design-time logic.
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateResourceBasedLiteralControl (inherited from TemplateControl) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl method is not intended for use from within your code.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
FrameworkInitialize (inherited from Page) | Initializes the control tree during page generation based on the declarative nature of the page.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetGlobalResourceObject (inherited from TemplateControl) | Overloaded. Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
GetLocalResourceObject (inherited from TemplateControl) | Overloaded. Gets a page-level resource object based on the specified ResourceKey property.
GetWrappedFileDependencies (inherited from Page) | Returns a list of physical file names that correspond to a list of virtual file locations.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
InitializeCulture (inherited from Page) | Sets the Culture and UICulture for the current thread of the page.
InitOutputCache (inherited from Page) | Overloaded. Initializes the output cache for the current page request.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from Control) | Restores view-state information from a previous page request that was saved by the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAbortTransaction (inherited from TemplateControl) | Raises the AbortTransaction event.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnCommitTransaction (inherited from TemplateControl) | Raises the CommitTransaction event.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnError (inherited from TemplateControl) | Raises the Error event.
OnInitComplete (inherited from Page) | Raises the InitComplete event after page initialization.
OnLoadComplete (inherited from Page) | Raises the LoadComplete event at the end of the page load stage.
OnPreInit (inherited from Page) | Raises the PreInit event at the beginning of page initialization.
OnPreLoad (inherited from Page) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad event.
OnPreRenderComplete (inherited from Page) | Raises the PreRenderComplete event after the OnPreRenderComplete event and before the page is rendered.
OnSaveStateComplete (inherited from Page) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium.
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RaisePostBackEvent (inherited from Page) | Notifies the server control that caused the postback that it should handle an incoming postback event.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from Control) | Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
SetStringResourcePointer (inherited from TemplateControl) | Sets a pointer to a string resource. The SetStringResourcePointer method is used by generated classes and is not intended for use from within your code.
TrackViewState (inherited from Control) | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property.
WriteUTF8ResourceString (inherited from TemplateControl) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString method is used by generated classes and is not intended for use from within your code.

Protected Internal Instance Properties

Context (inherited from Page) | Gets the HttpContext object associated with the page.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.
UniqueFilePathSuffix (inherited from Page) | Gets a unique suffix to append to the file path for caching browsers.

Protected Internal Instance Methods

AddContentTemplate (inherited from Page) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page.
AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
AddWrappedFileDependencies (inherited from Page) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code.
CreateChildControls (inherited from Control) | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
CreateHtmlTextWriter (inherited from Page) | Creates an HtmlTextWriter object to render the page's content.
DeterminePostBackMode (inherited from Page) | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command.
Eval (inherited from TemplateControl) | Overloaded. Evaluates a data-binding expression.
InitOutputCache (inherited from Page) | Overloaded. Initializes the output cache for the current page request based on an OutputCacheParameters object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
LoadPageStateFromPersistenceMedium (inherited from Page) | Loads any saved view-state information to the Page object.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnInit (inherited from Page) | Raises the Init event to initialize the page.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from Page) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.
SavePageStateToPersistenceMedium (inherited from Page) | Saves any view-state and control-state information for the page.
XPath (inherited from TemplateControl) | Overloaded. Evaluates an XPath data-binding expression.
XPathSelect (inherited from TemplateControl) | Overloaded. Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.

See Also

WebPage Class | Shunde.Common Namespace


WebPage Constructor

Initializes a new instance of the WebPage class.

protected WebPage();

See Also

WebPage Class | Shunde.Common Namespace


WebPage Properties

The properties of the WebPage class are listed below. For a complete list of WebPage class members, see the WebPage Members topic.

Public Instance Properties

Application (inherited from Page) | Gets the HttpApplicationState object for the current Web request.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
AppRelativeVirtualPath (inherited from TemplateControl) | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled.
AsyncTimeout (inherited from Page) | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
Buffer (inherited from Page) | Sets a value indicating whether the page output is buffered.
Cache (inherited from Page) | Gets the Cache object associated with the application in which the page resides.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ClientQueryString (inherited from Page) | Gets the query string portion of the requested URL.
ClientScript (inherited from Page) | Gets a ClientScriptManager object used to manage, register, and add script to the page.
ClientTarget (inherited from Page) | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients.
CodePage (inherited from Page) | Sets the code page identifier for the current Page.
ConnectionString | Gets the database connection string
ContentType (inherited from Page) | Sets the HTTP MIME type for the HttpResponse object associated with the page.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Culture (inherited from Page) | Sets the culture ID for the Thread object associated with the page.
EnableEventValidation (inherited from Page) |
EnableTheming (inherited from TemplateControl) | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class.
EnableViewState (inherited from Page) | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends.
EnableViewStateMac (inherited from Page) | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client.
ErrorPage (inherited from Page) | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception.
ErrorsEmail | Gets the errors email address for this website
Form (inherited from Page) | Gets the HTML form for the page.
Header (inherited from Page) | Gets the document header for the page if the head element is defined with a runat=server in the page declaration.
ID (inherited from Page) | Gets or sets an identifier for a particular instance of the Page class.
IdSeparator (inherited from Page) | Gets the character used to separate control identifiers when building a unique ID for a control on a page.
IsAsync (inherited from Page) | Gets a value indicating whether the page is processed asynchronously.
IsCallback (inherited from Page) | Gets a value indicating whether the page request is the result of a call back.
IsCrossPagePostBack (inherited from Page) | Gets a value indicating whether the page is involved in a cross-page postback.
IsPostBack (inherited from Page) | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time.
IsReusable (inherited from Page) | Gets a value indicating whether the Page object can be reused.
IsValid (inherited from Page) | Gets a value indicating whether page validation succeeded.
Items (inherited from Page) | Gets a list of objects stored in the page context.
LCID (inherited from Page) | Sets the locale identifier for the Thread object associated with the page.
MaintainScrollPositionOnPostBack (inherited from Page) | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback.
Master (inherited from Page) | Gets the master page that determines the overall look of the page.
MasterPageFile (inherited from Page) | Gets or sets the file name of the master page.
MaxPageStateFieldLength (inherited from Page) | Gets or sets the maximum length for the page's state field.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
PageAdapter (inherited from Page) | Gets the adapter that renders the page for the specific requesting browser.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PreviousPage (inherited from Page) | Gets the page that transferred control to the current page.
Request (inherited from Page) | Gets the HttpRequest object for the requested page.
Response (inherited from Page) | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response.
ResponseEncoding (inherited from Page) | Sets the encoding language for the current HttpResponse object.
Server (inherited from Page) | Gets the Server object, which is an instance of the HttpServerUtility class.
Session (inherited from Page) | Gets the current Session object provided by ASP.NET.
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from Control) | Gets or sets the skin to apply to the control.
SmartNavigation (inherited from Page) | Obsolete. Gets or sets a value indicating whether smart navigation is enabled.
SmtpPortNumber | The port number of the SMTP server
SmtpServer | The IP address or host Name of the SMTP server
StyleSheetTheme (inherited from Page) | Gets or sets the name of the style sheet applied to this page.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Theme (inherited from Page) | Gets or sets the name of the page theme.
Title (inherited from Page) | Gets or sets the title for the page.
Trace (inherited from Page) | Gets the TraceContext object for the current Web request.
TraceEnabled (inherited from Page) | Sets a value indicating whether tracing is enabled for the Page object.
TraceModeValue (inherited from Page) | Sets the mode in which trace statements are displayed on the page.
UICulture (inherited from Page) | Sets the user interface (UI) ID for the Thread object associated with the page.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
User (inherited from Page) | Gets information about the user making the page request.
Validators (inherited from Page) | Gets a collection of all validation controls contained on the requested page.
ViewStateEncryptionMode (inherited from Page) | Gets or sets the encryption mode of the view state.
ViewStateUserKey (inherited from Page) | Assigns an identifier to an individual user in the view-state variable associated with the current page.
Visible (inherited from Page) | Gets or sets a value indicating whether the Page object is rendered.
WebsiteName | Gets the website Name

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
AspCompatMode (inherited from Page) | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread.
AsyncMode (inherited from Page) | Sets a value indicating whether the page is processed synchronously or asynchronously.
AutoHandlers (inherited from TemplateControl) | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
FileDependencies (inherited from Page) | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
PageStatePersister (inherited from Page) | Gets the PageStatePersister object associated with the page.
SupportAutoEvents (inherited from TemplateControl) | Gets a value indicating whether the TemplateControl control supports automatic events.
TransactionMode (inherited from Page) | Sets the level of transaction support for the page.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Internal Instance Properties

Context (inherited from Page) | Gets the HttpContext object associated with the page.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.
UniqueFilePathSuffix (inherited from Page) | Gets a unique suffix to append to the file path for caching browsers.

See Also

WebPage Class | Shunde.Common Namespace


ConnectionString Property

Shunde.NET Framework Class Library

WebPage.ConnectionString Property

Gets the database connection string

public abstract ConnectionString {get;}

See Also

WebPage Class | Shunde.Common Namespace


ErrorsEmail Property

Shunde.NET Framework Class Library

WebPage.ErrorsEmail Property

Gets the errors email address for this website

public abstract ErrorsEmail {get;}

See Also

WebPage Class | Shunde.Common Namespace


SmtpPortNumber Property

Shunde.NET Framework Class Library

WebPage.SmtpPortNumber Property

The port number of the SMTP server

public abstract SmtpPortNumber {get;}

See Also

WebPage Class | Shunde.Common Namespace


SmtpServer Property

Shunde.NET Framework Class Library

WebPage.SmtpServer Property

The IP address or host Name of the SMTP server

public abstract SmtpServer {get;}

See Also

WebPage Class | Shunde.Common Namespace


WebsiteName Property

Shunde.NET Framework Class Library

WebPage.WebsiteName Property

Gets the website Name

public abstract WebsiteName {get;}

See Also

WebPage Class | Shunde.Common Namespace


WebPage Methods

The methods of the WebPage class are listed below. For a complete list of WebPage class members, see the WebPage Members topic.

Public Instance Methods

AddOnPreRenderCompleteAsync (inherited from Page) | Overloaded. Registers beginning and ending event handler delegates that do not require state information for an asynchronous page.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
DesignerInitialize (inherited from Page) | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExecuteRegisteredAsyncTasks (inherited from Page) | Starts the execution of an asynchronous task.
FindControl (inherited from Page) | Overloaded. Searches the page naming container for a server control with the specified identifier.
Focus (inherited from Control) | Sets input focus to a control.
GetDataItem (inherited from Page) | Gets the data item at the top of the data-binding context stack.
GetDoubleParam | Gets a double from the querystring. Returns -1 if the param does not exist or is in an incorrect format
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIntParam | Gets an int from the querystring. Returns -1 if the param does not exist or is in an incorrect format
GetPostBackClientEvent (inherited from Page) | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments.
GetPostBackClientHyperlink (inherited from Page) | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments.
GetPostBackEventReference (inherited from Page) | Overloaded. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object.
GetStringParam | Gets a string from the querystring. Returns an empty string if the param does not exist
GetTextSection | Gets some text with the given Code
GetType (inherited from Object) | Gets the Type of the current instance.
GetTypeHashCode (inherited from Page) | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy.
GetValidators (inherited from Page) | Returns a collection of control validators for a specified validation group.
HandleException | Handles any exceptions that occur on the site
HasControls (inherited from Control) | Determines if the server control contains any child controls.
IsClientScriptBlockRegistered (inherited from Page) | Obsolete. Determines whether the client script block with the specified key is registered with the page.
IsStartupScriptRegistered (inherited from Page) | Obsolete. Determines whether the client startup script is registered with the Page object.
LoadControl (inherited from TemplateControl) | Overloaded. Loads a Control object from a file based on a specified virtual path.
LoadTemplate (inherited from TemplateControl) | Obtains an instance of the ITemplate interface from an external file.
MapPath (inherited from Page) | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to.
Page_Error | Gets called whenever there is a page error
Page_Init | Called when the page loads
Page_Load | Called when the page loads
Page_Unload | Called when the page un-loads
ParseControl (inherited from TemplateControl) | Parses an input string into a Control object on the Web Forms page or user control.
ProcessRequest (inherited from Page) | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties.
ReadStringResource (inherited from TemplateControl) | Reads a string resource. The ReadStringResource method is not intended for use from within your code.
Redirect | Redirets to the given URL (absolute or relative)
RegisterArrayDeclaration (inherited from Page) | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered.
RegisterAsyncTask (inherited from Page) | Registers a new asynchronous task with the page.
RegisterClientScriptBlock (inherited from Page) | Obsolete. Emits client-side script blocks to the response.
RegisterHiddenField (inherited from Page) | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered.
RegisterOnSubmitStatement (inherited from Page) | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere.
RegisterRequiresControlState (inherited from Page) | Registers a control as one whose control state must be persisted.
RegisterRequiresPostBack (inherited from Page) | Registers a control as one that requires postback handling when the page is posted back to the server.
RegisterRequiresRaiseEvent (inherited from Page) | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object.
RegisterRequiresViewStateEncryption (inherited from Page) | Registers a control with the page as one requiring view-state encryption.
RegisterStartupScript (inherited from Page) | Obsolete. Emits a client-side script block in the page response.
RegisterViewStateHandler (inherited from Page) | Causes page view state to be persisted, if called.
RemoveCache | Overloaded. Removes all the cached objects
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RequiresControlState (inherited from Page) | Determines whether the specified Control object is registered to participate in control state management.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetFocus (inherited from Page) | Overloaded. Sets the browser focus to the specified control.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
TestDeviceFilter (inherited from TemplateControl) | Returns a Boolean value indicating whether a device filter applies to the HTTP request.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterRequiresControlState (inherited from Page) | Stops persistence of control state for the specified control.
Validate (inherited from Page) | Overloaded. Instructs any validation controls included on the page to validate their assigned information.
VerifyRenderingInServerForm (inherited from Page) | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time.

Protected Instance Methods

AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
AspCompatBeginProcessRequest (inherited from Page) | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications.
AspCompatEndProcessRequest (inherited from Page) | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications.
AsyncPageBeginProcessRequest (inherited from Page) | Begins processing an asynchronous page request.
AsyncPageEndProcessRequest (inherited from Page) | Ends processing an asynchronous page request.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
Construct (inherited from TemplateControl) | Performs design-time logic.
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateResourceBasedLiteralControl (inherited from TemplateControl) | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl method is not intended for use from within your code.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
FrameworkInitialize (inherited from Page) | Initializes the control tree during page generation based on the declarative nature of the page.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
GetGlobalResourceObject (inherited from TemplateControl) | Overloaded. Gets an application-level resource object based on the specified ClassKey and ResourceKey properties.
GetLocalResourceObject (inherited from TemplateControl) | Overloaded. Gets a page-level resource object based on the specified ResourceKey property.
GetWrappedFileDependencies (inherited from Page) | Returns a list of physical file names that correspond to a list of virtual file locations.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
InitializeCulture (inherited from Page) | Sets the Culture and UICulture for the current thread of the page.
InitOutputCache (inherited from Page) | Overloaded. Initializes the output cache for the current page request.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from Control) | Restores view-state information from a previous page request that was saved by the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnAbortTransaction (inherited from TemplateControl) | Raises the AbortTransaction event.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnCommitTransaction (inherited from TemplateControl) | Raises the CommitTransaction event.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnError (inherited from TemplateControl) | Raises the Error event.
OnInitComplete (inherited from Page) | Raises the InitComplete event after page initialization.
OnLoadComplete (inherited from Page) | Raises the LoadComplete event at the end of the page load stage.
OnPreInit (inherited from Page) | Raises the PreInit event at the beginning of page initialization.
OnPreLoad (inherited from Page) | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad event.
OnPreRenderComplete (inherited from Page) | Raises the PreRenderComplete event after the OnPreRenderComplete event and before the page is rendered.
OnSaveStateComplete (inherited from Page) | Raises the SaveStateComplete event after the page state has been saved to the persistence medium.
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RaisePostBackEvent (inherited from Page) | Notifies the server control that caused the postback that it should handle an incoming postback event.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from Control) | Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
SetStringResourcePointer (inherited from TemplateControl) | Sets a pointer to a string resource. The SetStringResourcePointer method is used by generated classes and is not intended for use from within your code.
TrackViewState (inherited from Control) | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property.
WriteUTF8ResourceString (inherited from TemplateControl) | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString method is used by generated classes and is not intended for use from within your code.

Protected Internal Instance Methods

AddContentTemplate (inherited from Page) | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page.
AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
AddWrappedFileDependencies (inherited from Page) | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code.
CreateChildControls (inherited from Control) | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
CreateHtmlTextWriter (inherited from Page) | Creates an HtmlTextWriter object to render the page's content.
DeterminePostBackMode (inherited from Page) | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command.
Eval (inherited from TemplateControl) | Overloaded. Evaluates a data-binding expression.
InitOutputCache (inherited from Page) | Overloaded. Initializes the output cache for the current page request based on an OutputCacheParameters object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
LoadPageStateFromPersistenceMedium (inherited from Page) | Loads any saved view-state information to the Page object.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnInit (inherited from Page) | Raises the Init event to initialize the page.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from Page) | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.
SavePageStateToPersistenceMedium (inherited from Page) | Saves any view-state and control-state information for the page.
XPath (inherited from TemplateControl) | Overloaded. Evaluates an XPath data-binding expression.
XPathSelect (inherited from TemplateControl) | Overloaded. Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface.

See Also

WebPage Class | Shunde.Common Namespace


WebPage.GetDoubleParam Method

Gets a double from the querystring. Returns -1 if the param does not exist or is in an incorrect format

public double GetDoubleParam(
String paramName
);

Parameters

String

Return Value

Returns retrieved parameter as a double

See Also

WebPage Class | Shunde.Common Namespace


WebPage.GetIntParam Method

Gets an int from the querystring. Returns -1 if the param does not exist or is in an incorrect format

public int GetIntParam(
String paramName
);

Parameters

String

Return Value

Returns retrieved parameter as an int

See Also

WebPage Class | Shunde.Common Namespace


WebPage.GetStringParam Method

Gets a string from the querystring. Returns an empty string if the param does not exist

public string GetStringParam(
String paramName
);

Parameters

String

Return Value

Returns retrieved parameter as a string

See Also

WebPage Class | Shunde.Common Namespace


WebPage.GetTextSection Method

Gets some text with the given Code

public virtual TextSection GetTextSection(
String code,
String nameForAdministrators
);

Parameters

String
The Code of the text
String
The name to give for administrators

Return Value

Returns a TextSection object

Remarks

Uses data in the cache if available. If not available, it is retrieved from the database and added to the cache. Using a Code that doesn't exist is how you create new sections.

See Also

WebPage Class | Shunde.Common Namespace


WebPage.HandleException Method

Handles any exceptions that occur on the site

public string HandleException(
Exception ex,
HttpRequest request,
String extraInformation
);

Parameters

Exception
HttpRequest
String

See Also

WebPage Class | Shunde.Common Namespace


WebPage.Page_Error Method

Gets called whenever there is a page error

public void Page_Error(
Object Sender,
EventArgs e
);

See Also

WebPage Class | Shunde.Common Namespace


WebPage.Page_Init Method

Called when the page loads

public virtual void Page_Init(
Object Sender,
EventArgs e
);

See Also

WebPage Class | Shunde.Common Namespace


WebPage.Page_Load Method

Called when the page loads

public virtual void Page_Load(
Object Sender,
EventArgs e
);

See Also

WebPage Class | Shunde.Common Namespace


WebPage.Page_Unload Method

Called when the page un-loads

public virtual void Page_Unload(
Object Sender,
EventArgs e
);

See Also

WebPage Class | Shunde.Common Namespace


WebPage.Redirect Method

Redirets to the given URL (absolute or relative)

public void Redirect(
String url
);

See Also

WebPage Class | Shunde.Common Namespace


RemoveCache Method

Shunde.NET Framework Class Library

WebPage.RemoveCache Method

Removes all the cached objects

Overload List

Removes all the cached objects

public void RemoveCache();

Removes the cache from the site

public void RemoveCache(String);

See Also

WebPage Class | Shunde.Common Namespace


WebPage.RemoveCache Method ()

Removes all the cached objects

public void RemoveCache();

See Also

WebPage Class | Shunde.Common Namespace | WebPage.RemoveCache Overload List


WebPage.RemoveCache Method (String)

Removes the cache from the site

public void RemoveCache(
String cacheName
);

Parameters

String

Remarks

Giving cacheToRemove a Value of {REMOVEALL} removes all the cached items

See Also

WebPage Class | Shunde.Common Namespace | WebPage.RemoveCache Overload List


WebsiteVisit Class

Information on a website visit

For a list of all members of this type, see WebsiteVisit Members.

System.Object
DBObject
WebsiteVisit

public class WebsiteVisit : DBObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

WebsiteVisit Members | Shunde.Common Namespace


WebsiteVisit Members

WebsiteVisit overview

Public Static Methods

GetNumberWithoutHostNames | Gets the number of site visits that don't have host names
GetWebsiteVisitsWhere | Gets an array of UserVisit objects with the given SQL WHERE clause
GetWebsiteVisitsWithoutHostName | Gets 20 random UserVisit objects with no UserHostName
UpdateHostNames | Attempts to update the host Name of site visits that don't have host names, returning the number of successes

Public Instance Constructors

WebsiteVisit Overloaded. Initializes a new instance of the WebsiteVisit class.

Public Instance Properties

CountryCode | The country code the visit originated from
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
EndTime | The end time of this Visit
FriendlyName (inherited from DBObject) | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id (inherited from DBObject) | The id of the object
IPAddress | The IP address of the client
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
NumberOfPagesViewed | The number of pages which were viewed
SearchString | The string that the person searched for to find the website
SiteReferrer | The place that this visit came from
StartTime | The start time of this visit
UserAgent | The user agent string
UserHostName | The User-host Name
Visitor | The visitor, or null if unknown

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
SetEndTime | Sets the end time for those occasions where the session has timed out
SetUserHostName | Sets the user host Name
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit Constructor

Creates a new instance of a UserVisit

Overload List

Creates a new instance of a UserVisit

public WebsiteVisit();

Creates a new instance of a UserVisit populating the variables with values from an HttpRequest object

public WebsiteVisit(HttpRequest);

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit Constructor ()

Creates a new instance of a UserVisit

public WebsiteVisit();

See Also

WebsiteVisit Class | Shunde.Common Namespace | WebsiteVisit Constructor Overload List


WebsiteVisit Constructor (HttpRequest)

Creates a new instance of a UserVisit populating the variables with values from an HttpRequest object

public WebsiteVisit(
HttpRequest request
);

See Also

WebsiteVisit Class | Shunde.Common Namespace | WebsiteVisit Constructor Overload List


WebsiteVisit Properties

The properties of the WebsiteVisit class are listed below. For a complete list of WebsiteVisit class members, see the WebsiteVisit Members topic.

Public Instance Properties

CountryCode | The country code the visit originated from
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
EndTime | The end time of this Visit
FriendlyName (inherited from DBObject) | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id (inherited from DBObject) | The id of the object
IPAddress | The IP address of the client
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
NumberOfPagesViewed | The number of pages which were viewed
SearchString | The string that the person searched for to find the website
SiteReferrer | The place that this visit came from
StartTime | The start time of this visit
UserAgent | The user agent string
UserHostName | The User-host Name
Visitor | The visitor, or null if unknown

See Also

WebsiteVisit Class | Shunde.Common Namespace


CountryCode Property

Shunde.NET Framework Class Library

WebsiteVisit.CountryCode Property

The country code the visit originated from

public CountryCode {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


EndTime Property

Shunde.NET Framework Class Library

WebsiteVisit.EndTime Property

The end time of this Visit

public EndTime {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


IPAddress Property

Shunde.NET Framework Class Library

WebsiteVisit.IPAddress Property

The IP address of the client

public IPAddress {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


NumberOfPagesViewed Property

Shunde.NET Framework Class Library

WebsiteVisit.NumberOfPagesViewed Property

The number of pages which were viewed

public NumberOfPagesViewed {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


SearchString Property

Shunde.NET Framework Class Library

WebsiteVisit.SearchString Property

The string that the person searched for to find the website

public SearchString {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


SiteReferrer Property

Shunde.NET Framework Class Library

WebsiteVisit.SiteReferrer Property

The place that this visit came from

public SiteReferrer {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


StartTime Property

Shunde.NET Framework Class Library

WebsiteVisit.StartTime Property

The start time of this visit

public StartTime {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


UserAgent Property

Shunde.NET Framework Class Library

WebsiteVisit.UserAgent Property

The user agent string

public UserAgent {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


UserHostName Property

Shunde.NET Framework Class Library

WebsiteVisit.UserHostName Property

The User-host Name

public UserHostName {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


Visitor Property

Shunde.NET Framework Class Library

WebsiteVisit.Visitor Property

The visitor, or null if unknown

public Visitor {get; set;}

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit Methods

The methods of the WebsiteVisit class are listed below. For a complete list of WebsiteVisit class members, see the WebsiteVisit Members topic.

Public Static Methods

GetNumberWithoutHostNames | Gets the number of site visits that don't have host names
GetWebsiteVisitsWhere | Gets an array of UserVisit objects with the given SQL WHERE clause
GetWebsiteVisitsWithoutHostName | Gets 20 random UserVisit objects with no UserHostName
UpdateHostNames | Attempts to update the host Name of site visits that don't have host names, returning the number of successes

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
SetEndTime | Sets the end time for those occasions where the session has timed out
SetUserHostName | Sets the user host Name
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit.GetNumberWithoutHostNames Method

Gets the number of site visits that don't have host names

public static int GetNumberWithoutHostNames();

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit.GetWebsiteVisitsWhere Method

Gets an array of UserVisit objects with the given SQL WHERE clause

public static WebsiteVisit[] GetWebsiteVisitsWhere(
String whereClause,
Int32 numToGet
);

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit.GetWebsiteVisitsWithoutHostName Method

Gets 20 random UserVisit objects with no UserHostName

public static WebsiteVisit[] GetWebsiteVisitsWithoutHostName();

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit.SetEndTime Method

Sets the end time for those occasions where the session has timed out

public void SetEndTime(
HttpSessionState session
);

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit.SetUserHostName Method

Sets the user host Name

public void SetUserHostName();

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisit.UpdateHostNames Method

Attempts to update the host Name of site visits that don't have host names, returning the number of successes

public static int UpdateHostNames();

See Also

WebsiteVisit Class | Shunde.Common Namespace


WebsiteVisitAction Class

An action during a visit

For a list of all members of this type, see WebsiteVisitAction Members.

System.Object
DBObject
WebsiteVisitAction

public class WebsiteVisitAction : DBObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Common

Assembly: Shunde (in Shunde.dll)

See Also

WebsiteVisitAction Members | Shunde.Common Namespace


WebsiteVisitAction Members

WebsiteVisitAction overview

Public Static Methods

GetUserVisits Gets an array of WebsiteVisitAction objects for the given WebsiteVisit

Public Instance Constructors

WebsiteVisitAction Constructor Initializes a new instance of the WebsiteVisitAction class.

Public Instance Properties

Description | A description of the action
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName (inherited from DBObject) | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
PreviousAction | The previous action this this visit
TimeStamp | The time of this view
Url | The URL, if possible, that the view took place at
ViewedObject | The object that was viewed
Visit | The visit that this view occured in

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


WebsiteVisitAction Constructor

Initializes a new instance of the WebsiteVisitAction class.

public WebsiteVisitAction();

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


WebsiteVisitAction Properties

The properties of the WebsiteVisitAction class are listed below. For a complete list of WebsiteVisitAction class members, see the WebsiteVisitAction Members topic.

Public Instance Properties

Description | A description of the action
DisplayOrder (inherited from DBObject) | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName (inherited from DBObject) | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id (inherited from DBObject) | The id of the object
IsDeleted (inherited from DBObject) | Specifies that this object is deleted
LastUpdate (inherited from DBObject) | The last time that this object was updated.
LastUpdatedBy (inherited from DBObject) | The person or user who last updated this object
PreviousAction | The previous action this this visit
TimeStamp | The time of this view
Url | The URL, if possible, that the view took place at
ViewedObject | The object that was viewed
Visit | The visit that this view occured in

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


Description Property

Shunde.NET Framework Class Library

WebsiteVisitAction.Description Property

A description of the action

public Description {get; set;}

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


PreviousAction Property

Shunde.NET Framework Class Library

WebsiteVisitAction.PreviousAction Property

The previous action this this visit

public PreviousAction {get; set;}

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


TimeStamp Property

Shunde.NET Framework Class Library

WebsiteVisitAction.TimeStamp Property

The time of this view

public TimeStamp {get; set;}

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


Url Property

Shunde.NET Framework Class Library

WebsiteVisitAction.Url Property

The URL, if possible, that the view took place at

public Url {get; set;}

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


ViewedObject Property

Shunde.NET Framework Class Library

WebsiteVisitAction.ViewedObject Property

The object that was viewed

public ViewedObject {get; set;}

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


Visit Property

Shunde.NET Framework Class Library

WebsiteVisitAction.Visit Property

The visit that this view occured in

public Visit {get; set;}

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


WebsiteVisitAction Methods

The methods of the WebsiteVisitAction class are listed below. For a complete list of WebsiteVisitAction class members, see the WebsiteVisitAction Members topic.

Public Static Methods

GetUserVisits Gets an array of WebsiteVisitAction objects for the given WebsiteVisit

Public Instance Methods

Equals (inherited from DBObject) | Specifies that two DBObjects are equal
Exists (inherited from DBObject) | Checks to see if this object exists in the database
GetHashCode (inherited from DBObject) | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate (inherited from DBObject) | Populates this object from the database
PopulateBinaryData (inherited from DBObject) | Populates the data of all the BinaryData objects in this class
PopulateObjects (inherited from DBObject) | Populates the other DB objects in this class
ResetId (inherited from DBObject) | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save (inherited from DBObject) | Saves this object to the database
ToString (inherited from DBObject) | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


WebsiteVisitAction.GetUserVisits Method

Gets an array of WebsiteVisitAction objects for the given WebsiteVisit

public static WebsiteVisitAction[] GetUserVisits(
WebsiteVisit visit
);

See Also

WebsiteVisitAction Class | Shunde.Common Namespace


Shunde.Framework

Shunde.NET Framework Class Library

Shunde.Framework Namespace

Namespace hierarchy

Classes

Class | Description
DBColumn | Represents a Database column
DBObject | Represents a Database object.
DBTable | Represents a single Database Table
ObjectInfo | Information for a class. This contains the DBTables that make up this object, as well as the from clause and column clause to use in SQL statements, etc.

Structures

Structure | Description
BinaryData | A structure for holding binary data


BinaryData Structure

A structure for holding binary data

For a list of all members of this type, see BinaryData Members.

System.Object
ValueType
BinaryData

public struct BinaryData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Framework

Assembly: Shunde (in Shunde.dll)

See Also

BinaryData Members | Shunde.Framework Namespace


BinaryData Members

BinaryData overview

Public Instance Constructors

BinaryData Overloaded. Initializes a new instance of the BinaryData class.

Public Instance Properties

Data | The data
Exists | Checks whether this BinaryData has any data
Filename | The filename
MimeType | The MIME Type, if it is a file
Size | Gets the size, in bytes, of this data

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

BinaryData Structure | Shunde.Framework Namespace


BinaryData Constructor

Creates a new binary data with the specified data and mimetype

Overload List

Creates a new binary data with the specified data and mimetype

public BinaryData(Byte[],String,String);

Creates a new binary data with the specified size and mimetype

public BinaryData(Int32,String,String);

See Also

BinaryData Structure | Shunde.Framework Namespace


BinaryData Constructor (Byte[], String, String)

Creates a new binary data with the specified data and mimetype

public BinaryData(
Byte[] data,
String mimeType,
String filename
);

See Also

BinaryData Structure | Shunde.Framework Namespace | BinaryData Constructor Overload List


BinaryData Constructor (Int32, String, String)

Creates a new binary data with the specified size and mimetype

public BinaryData(
Int32 size,
String mimeType,
String filename
);

See Also

BinaryData Structure | Shunde.Framework Namespace | BinaryData Constructor Overload List


BinaryData Properties

The properties of the BinaryData structure are listed below. For a complete list of BinaryData structure members, see the BinaryData Members topic.

Public Instance Properties

Data | The data
Exists | Checks whether this BinaryData has any data
Filename | The filename
MimeType | The MIME Type, if it is a file
Size | Gets the size, in bytes, of this data

See Also

BinaryData Structure | Shunde.Framework Namespace


Data Property

Shunde.NET Framework Class Library

BinaryData.Data Property

The data

public Data {get; set;}

See Also

BinaryData Structure | Shunde.Framework Namespace


Exists Property

Shunde.NET Framework Class Library

BinaryData.Exists Property

Checks whether this BinaryData has any data

public Exists {get;}

See Also

BinaryData Structure | Shunde.Framework Namespace


Filename Property

Shunde.NET Framework Class Library

BinaryData.Filename Property

The filename

public Filename {get; set;}

See Also

BinaryData Structure | Shunde.Framework Namespace


MimeType Property

Shunde.NET Framework Class Library

BinaryData.MimeType Property

The MIME Type, if it is a file

public MimeType {get; set;}

See Also

BinaryData Structure | Shunde.Framework Namespace


Size Property

Shunde.NET Framework Class Library

BinaryData.Size Property

Gets the size, in bytes, of this data

public Size {get;}

See Also

BinaryData Structure | Shunde.Framework Namespace


DBColumn Class

Represents a Database column

For a list of all members of this type, see DBColumn Members.

System.Object
DBColumn

public class DBColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Framework

Assembly: Shunde (in Shunde.dll)

See Also

DBColumn Members | Shunde.Framework Namespace


DBColumn Members

DBColumn overview

Public Static Fields

DateTimeNullValue | The C# DateTime Value that represents the database NULL Value
DoubleNullValue | The C# double Value that represents the database NULL Value
FloatNullValue | The C# float Value that represents the database NULL Value
IntegerNullValue | The C# integer Value that represents the database NULL Value
LongNullValue | The C# long Value that represents the database NULL Value
ShortNullValue | The C# short Value that represents the database NULL Value

Public Static Methods

IsColumnNull Determines whether the given object should be considered to be null by the database.

Public Instance Constructors

DBColumn Overloaded. Initializes a new instance of the DBColumn class.

Public Instance Properties

AllowNulls | Specifies whether or not this column allows NULL values into the database.
Constraints | Any CHECK CONSTRAINTS that aren't covered by other fields in the DBColumn class can be specified manually.
DBTable | The Table that this column is a part of
FieldInfo | Gets the field info that corresponds to this column
IsUnique | Specifies that this column should be unique in the Table
MaxAllowed | Represents the maximum Value that this column is allowed.
MaxLength | This is the maximum number of characters allowed for a string in this column
MinAllowed | Represents the minimum Value that this column is allowed.
MinLength | This is the minimum number of characters allowed for a string in this column
Name | The Name of this column
Type | The C# Type of the column

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnName | Gets the database column Name of this column
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSqlText | Gets the Value of this object in a suitable manner for use in SQL statements
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks that the given Value is within the constraints placed upon it by this column.

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn Constructor

Creates a new DBColumn with the values specified. Also sets the Value of isDBObjectType.

Overload List

Creates a new DBColumn with the values specified. Also sets the Value of isDBObjectType.

public DBColumn(String,Type,Boolean);

Creates a new DBColumn with the values specified. Also sets the Value of isDBObjectType.

public DBColumn(String,Type,Boolean,IComparable,IComparable);

Creates a new DBColumn with the values specified. Also sets the Value of isDBObjectType.

public DBColumn(String,Type,Int32,Int32);

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn Constructor (String, Type, Boolean)

Creates a new DBColumn with the values specified. Also sets the Value of isDBObjectType.

public DBColumn(
String name,
Type type,
Boolean allowNulls
);

See Also

DBColumn Class | Shunde.Framework Namespace | DBColumn Constructor Overload List


DBColumn Constructor (String, Type, Boolean, IComparable, IComparable)

Creates a new DBColumn with the values specified. Also sets the Value of isDBObjectType.

public DBColumn(
String name,
Type type,
Boolean allowNulls,
IComparable minAllowed,
IComparable maxAllowed
);

Remarks

This constructor is normally used for DateTime, double, or int types where a minimum and/or maximum Value is set.

See Also

DBColumn Class | Shunde.Framework Namespace | DBColumn Constructor Overload List


DBColumn Constructor (String, Type, Int32, Int32)

Creates a new DBColumn with the values specified. Also sets the Value of isDBObjectType.

public DBColumn(
String name,
Type type,
Int32 minLength,
Int32 maxLength
);

Remarks

This constructor is normally used for string types where a minimum and/or maximum string length is needed. It sets allowNulls to false.

See Also

DBColumn Class | Shunde.Framework Namespace | DBColumn Constructor Overload List


DBColumn Fields

The fields of the DBColumn class are listed below. For a complete list of DBColumn class members, see the DBColumn Members topic.

Public Static Fields

DateTimeNullValue | The C# DateTime Value that represents the database NULL Value
DoubleNullValue | The C# double Value that represents the database NULL Value
FloatNullValue | The C# float Value that represents the database NULL Value
IntegerNullValue | The C# integer Value that represents the database NULL Value
LongNullValue | The C# long Value that represents the database NULL Value
ShortNullValue | The C# short Value that represents the database NULL Value

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.DateTimeNullValue Field

The C# DateTime Value that represents the database NULL Value

public static DateTime DateTimeNullValue;

Remarks

Setting a column's Value to this Value will cause this column to be set to NULL when saving to the database

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.DoubleNullValue Field

The C# double Value that represents the database NULL Value

public const Double DoubleNullValue = -1.79769313486232E+308;

Remarks

Setting a column's Value to this Value will cause this column to be set to NULL when saving to the database

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.FloatNullValue Field

The C# float Value that represents the database NULL Value

public const Single FloatNullValue = -3.402823E+38;

Remarks

Setting a column's Value to this Value will cause this column to be set to NULL when saving to the database

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.IntegerNullValue Field

The C# integer Value that represents the database NULL Value

public const Int32 IntegerNullValue = -2147483648;

Remarks

Setting a column's Value to this Value will cause this column to be set to NULL when saving to the database

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.LongNullValue Field

The C# long Value that represents the database NULL Value

public const Int64 LongNullValue = -9223372036854775808;

Remarks

Setting a column's Value to this Value will cause this column to be set to NULL when saving to the database

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.ShortNullValue Field

The C# short Value that represents the database NULL Value

public const Int32 ShortNullValue = -32768;

Remarks

Setting a column's Value to this Value will cause this column to be set to NULL when saving to the database

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn Properties

The properties of the DBColumn class are listed below. For a complete list of DBColumn class members, see the DBColumn Members topic.

Public Instance Properties

AllowNulls | Specifies whether or not this column allows NULL values into the database.
Constraints | Any CHECK CONSTRAINTS that aren't covered by other fields in the DBColumn class can be specified manually.
DBTable | The Table that this column is a part of
FieldInfo | Gets the field info that corresponds to this column
IsUnique | Specifies that this column should be unique in the Table
MaxAllowed | Represents the maximum Value that this column is allowed.
MaxLength | This is the maximum number of characters allowed for a string in this column
MinAllowed | Represents the minimum Value that this column is allowed.
MinLength | This is the minimum number of characters allowed for a string in this column
Name | The Name of this column
Type | The C# Type of the column

See Also

DBColumn Class | Shunde.Framework Namespace


AllowNulls Property

Shunde.NET Framework Class Library

DBColumn.AllowNulls Property

Specifies whether or not this column allows NULL values into the database.

public AllowNulls {get; set;}

Remarks

If a this is set to false and the Value being saved is null, then a ValidationException will be thrown.

See Also

DBColumn Class | Shunde.Framework Namespace


Constraints Property

Shunde.NET Framework Class Library

DBColumn.Constraints Property

Any CHECK CONSTRAINTS that aren't covered by other fields in the DBColumn class can be specified manually.

public Constraints {get; set;}

Example

The className field of the DBObject class requires that the Value start with 1 or more characters, followed by a period, followed by one or more characters. This is achieved with the following way: DBColumn cnCol = new DBColumn( "className", typeof(string), 1, 100); cnCol.Constraints = "className LIKE '_%._%'";

See Also

DBColumn Class | Shunde.Framework Namespace


DBTable Property

Shunde.NET Framework Class Library

DBColumn.DBTable Property

The Table that this column is a part of

public DBTable {get; set;}

See Also

DBColumn Class | Shunde.Framework Namespace


FieldInfo Property

Shunde.NET Framework Class Library

DBColumn.FieldInfo Property

Gets the field info that corresponds to this column

public FieldInfo {get;}

See Also

DBColumn Class | Shunde.Framework Namespace


IsUnique Property

Shunde.NET Framework Class Library

DBColumn.IsUnique Property

Specifies that this column should be unique in the Table

public IsUnique {get; set;}

Remarks

If IsUnique is set to true, a ValidationException is thrown when saving the object if there is another row with the same Value in the database for this column. Unlike in Sql Server, two null values are considered Unique in this context.

See Also

DBColumn Class | Shunde.Framework Namespace


MaxAllowed Property

Shunde.NET Framework Class Library

DBColumn.MaxAllowed Property

Represents the maximum Value that this column is allowed.

public MaxAllowed {get; set;}

Remarks

If a column has a Value higher than the set Value, then a ValidationException will be thrown.

If there is no maximum, then this should be null.

See Also

DBColumn Class | Shunde.Framework Namespace


MaxLength Property

Shunde.NET Framework Class Library

DBColumn.MaxLength Property

This is the maximum number of characters allowed for a string in this column

public MaxLength {get; set;}

Remarks

If this is set to a positive Value then the type of column is assumed to be nvarchar. A Value of -1 means that the column is assumed to be an ntext column.

If a string column has a Value longer than the set Value and the set Value is positive, then a ValidationException will be thrown.

See Also

DBColumn Class | Shunde.Framework Namespace


MinAllowed Property

Shunde.NET Framework Class Library

DBColumn.MinAllowed Property

Represents the minimum Value that this column is allowed.

public MinAllowed {get; set;}

Remarks

If there is no minimum, then this should be null.

If a column has a Value lower than the set Value, then a ValidationException will be thrown.

See Also

DBColumn Class | Shunde.Framework Namespace


MinLength Property

Shunde.NET Framework Class Library

DBColumn.MinLength Property

This is the minimum number of characters allowed for a string in this column

public MinLength {get; set;}

Remarks

For a string Value, this should always be at least 0. For other types, this Value is ignored.

If a string column has a Value shorter than the set Value, then a ValidationException will be thrown.

See Also

DBColumn Class | Shunde.Framework Namespace


Name Property

Shunde.NET Framework Class Library

DBColumn.Name Property

The Name of this column

public Name {get;}

See Also

DBColumn Class | Shunde.Framework Namespace


Type Property

Shunde.NET Framework Class Library

DBColumn.Type Property

The C# Type of the column

public Type {get;}

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn Methods

The methods of the DBColumn class are listed below. For a complete list of DBColumn class members, see the DBColumn Members topic.

Public Static Methods

IsColumnNull Determines whether the given object should be considered to be null by the database.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetColumnName | Gets the database column Name of this column
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSqlText | Gets the Value of this object in a suitable manner for use in SQL statements
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Checks that the given Value is within the constraints placed upon it by this column.

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.GetColumnName Method

Gets the database column Name of this column

public string GetColumnName();

Remarks

This is normally the same as the Name specified in Name, however for DBObject types it has "Id" appended.

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.GetSqlText Method

Gets the Value of this object in a suitable manner for use in SQL statements

public string GetSqlText(
Object value
);

Remarks

string values will have apostrophes escaped, and be enclosed by apostrophes. Varchar columns will also have the string.Trim method called on them. Null values will be returned as "null", and all other types are converted to an appropriate string representation.

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.IsColumnNull Method

Determines whether the given object should be considered to be null by the database.

public static bool IsColumnNull(
Object value
);

Remarks

This is true if the Value is null, but also if an int has the Value IntegerNullValue etc.

See Also

DBColumn Class | Shunde.Framework Namespace


DBColumn.Validate Method

Checks that the given Value is within the constraints placed upon it by this column.

public void Validate(
DBObject obj,
Object value
);

Remarks

This does not check the specific constraints specified in the constraints field. A Value violating those constraints will be found when attempting to save the object.

Exceptions

Exception Type | Condition
ValidationException | Thrown if the Value violates the constraints of this column. The Message property contains a friendly error message, suitable to show to end users, on why the validation failed.

See Also

DBColumn Class | Shunde.Framework Namespace


DBObject Class

Represents a Database object.

For a list of all members of this type, see DBObject Members.

System.Object
DBObject
Derived types

public class DBObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This is the base type of a framework used for applications that save object info in SQL Server. Each object extends this object, with that objects columns specified by an array of DBColumn objects. This base class implements Code that will save and populate objects.

Requirements

Namespace: Shunde.Framework

Assembly: Shunde (in Shunde.dll)

See Also

DBObject Members | Shunde.Framework Namespace


DBObject Members

DBObject overview

Public Static Methods

CreateObject | Creates a new DBObject which belongs in the given Assembly with the classname, where the classname includes the namespace
GetObject | Overloaded. Gets and populates a single DBObject
GetObjects | Overloaded. Gets and (possibly partially) populates all the DBObjects for a given SQL Statement

Public Instance Constructors

DBObject Constructor Creates a new DBObject

Public Instance Properties

DisplayOrder | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id | The id of the object
IsDeleted | Specifies that this object is deleted
LastUpdate | The last time that this object was updated.
LastUpdatedBy | The person or user who last updated this object

Public Instance Methods

Equals | Specifies that two DBObjects are equal
Exists | Checks to see if this object exists in the database
GetHashCode | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate | Populates this object from the database
PopulateBinaryData | Populates the data of all the BinaryData objects in this class
PopulateObjects | Populates the other DB objects in this class
ResetId | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save | Saves this object to the database
ToString | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject Constructor

Creates a new DBObject

public DBObject();

Remarks

This Constructor loads the reference to the ObjectInfo of the class that this type belongs to.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject Properties

The properties of the DBObject class are listed below. For a complete list of DBObject class members, see the DBObject Members topic.

Public Instance Properties

DisplayOrder | The relative (to other DBObjects) display order that this DBObject should appear in
FriendlyName | Gets a Name that can be displayed to the end user for this object, if such a Name exists
Id | The id of the object
IsDeleted | Specifies that this object is deleted
LastUpdate | The last time that this object was updated.
LastUpdatedBy | The person or user who last updated this object

See Also

DBObject Class | Shunde.Framework Namespace


DisplayOrder Property

Shunde.NET Framework Class Library

DBObject.DisplayOrder Property

The relative (to other DBObjects) display order that this DBObject should appear in

public DisplayOrder {get; set;}

See Also

DBObject Class | Shunde.Framework Namespace


FriendlyName Property

Shunde.NET Framework Class Library

DBObject.FriendlyName Property

Gets a Name that can be displayed to the end user for this object, if such a Name exists

public virtual FriendlyName {get;}

See Also

DBObject Class | Shunde.Framework Namespace


Id Property

Shunde.NET Framework Class Library

DBObject.Id Property

The id of the object

public Id {get; set;}

See Also

DBObject Class | Shunde.Framework Namespace


IsDeleted Property

Shunde.NET Framework Class Library

DBObject.IsDeleted Property

Specifies that this object is deleted

public IsDeleted {get; set;}

Remarks

Rather than deleting an object from the database, it is just marked as deleted. The lastUpdate field of the object should be the date that it was deleted on, and lastUpdatedBy should hold the Name of the user that deleted it.

See Also

DBObject Class | Shunde.Framework Namespace


LastUpdate Property

Shunde.NET Framework Class Library

DBObject.LastUpdate Property

The last time that this object was updated.

public LastUpdate {get;}

Remarks

This is automatically updated each time the object is saved.

See Also

DBObject Class | Shunde.Framework Namespace


LastUpdatedBy Property

Shunde.NET Framework Class Library

DBObject.LastUpdatedBy Property

The person or user who last updated this object

public LastUpdatedBy {get; set;}

See Also

DBObject Class | Shunde.Framework Namespace


DBObject Methods

The methods of the DBObject class are listed below. For a complete list of DBObject class members, see the DBObject Members topic.

Public Static Methods

CreateObject | Creates a new DBObject which belongs in the given Assembly with the classname, where the classname includes the namespace
GetObject | Overloaded. Gets and populates a single DBObject
GetObjects | Overloaded. Gets and (possibly partially) populates all the DBObjects for a given SQL Statement

Public Instance Methods

Equals | Specifies that two DBObjects are equal
Exists | Checks to see if this object exists in the database
GetHashCode | Gets the hash key for this object
GetType (inherited from Object) | Gets the Type of the current instance.
Populate | Populates this object from the database
PopulateBinaryData | Populates the data of all the BinaryData objects in this class
PopulateObjects | Populates the other DB objects in this class
ResetId | Resets the Id of the object so that when saved again, a new object will be created in the database.
Save | Saves this object to the database
ToString | Gets a String representation of this object

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.CreateObject Method

Creates a new DBObject which belongs in the given Assembly with the classname, where the classname includes the namespace

public static DBObject CreateObject(
Assembly callingAssembly,
String className
);

Remarks

First checks the constructors dictionary for the ConstructorInfo object. If not, it uses the Assembly to create a ConstructorInfo.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.Equals Method

Specifies that two DBObjects are equal

public override bool Equals(
Object another
);

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.Exists Method

Checks to see if this object exists in the database

public bool Exists();

Remarks

Currently, if the id is less than 1 then it is considered to not exist. There is no check in the database for performance reasons. This may change later on.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.GetHashCode Method

Gets the hash key for this object

public override int GetHashCode();

See Also

DBObject Class | Shunde.Framework Namespace


GetObject Method

Shunde.NET Framework Class Library

DBObject.GetObject Method

Gets and populates a single DBObject with the supplied ID

Overload List

Gets and populates a single DBObject with the supplied ID

public static DBObject GetObject(Int32);

Gets and populates a single DBObject of the given type with the supplied ID

public static DBObject GetObject(Int32,Type);

Gets and populates a single DBObject

public static DBObject GetObject(String);

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.GetObject Method (Int32)

Gets and populates a single DBObject with the supplied ID

public static DBObject GetObject(
Int32 id
);

Return Value

Returns a fully populated DBObject

Remarks

This is a useful method when you do not know the type of object you will get back.

Exceptions

Exception Type | Condition
ObjectDoesNotExistException | Thrown if the specified ID is not found in the database.

See Also

DBObject Class | Shunde.Framework Namespace | DBObject.GetObject Overload List


DBObject.GetObject Method (Int32, Type)

Gets and populates a single DBObject of the given type with the supplied ID

public static DBObject GetObject(
Int32 id,
Type objectType
);

Return Value

Returns a fully populated DBObject

Remarks

Use this method when you know the type as it is faster than GetObject

Exceptions

Exception Type | Condition
ObjectDoesNotExistException | Thrown if the specified ID is not found in the database.

See Also

DBObject Class | Shunde.Framework Namespace | DBObject.GetObject Overload List


DBObject.GetObject Method (String)

Gets and populates a single DBObject

public static DBObject GetObject(
String query
);

Parameters

String

Return Value

Returns a fully populated DBObject

Remarks

This is a useful method when you do not know the type of object you will get back. Just pass in a SQL statement that returns one id.

Exceptions

Exception Type | Condition
ValidationException | Thrown if the query returns more than one row.
ObjectDoesNotExistException | Thrown if the specified ID is not found in the database.

See Also

DBObject Class | Shunde.Framework Namespace | DBObject.GetObject Overload List


GetObjects Method

Shunde.NET Framework Class Library

DBObject.GetObjects Method

Gets and (possibly partially) populates all the DBObjects for a given SQL Statement

Overload List

Gets and (possibly partially) populates all the DBObjects for a given SQL Statement

public static DBObject[] GetObjects(String,Type);

Gets and populates all the DBObjects for a given SQL Statement using the Types given in extendingTypes

public static DBObject[] GetObjects(Type,Type[],Boolean,String);

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.GetObjects Method (String, Type)

Gets and (possibly partially) populates all the DBObjects for a given SQL Statement

public static DBObject[] GetObjects(
String query,
Type baseType
);

Parameters

String
Type

Remarks

The base type is the type that all the objects being retrieved extend. For example, if Notebook and Desktop both extend Computer, then the base type is Computer if getting all Notebooks and Desktops. The returned objects are then created as the type that they should be (ie. Notebooks and Desktops), however they are only partially populated up to the level of the base type (ie. Computer).

See Also

DBObject Class | Shunde.Framework Namespace | DBObject.GetObjects Overload List


DBObject.GetObjects Method (Type, Type[], Boolean, String)

Gets and populates all the DBObjects for a given SQL Statement using the Types given in extendingTypes

public static DBObject[] GetObjects(
Type baseType,
Type[] extendingTypes,
Boolean useView,
String where
);

Parameters

Type
Type[]
Boolean
String

Remarks

The base type is the type that all the objects being retrieved extend. For example, if Notebook and Desktop both extend Computer, then the base type is Computer if getting all Notebooks and Desktops. The returned objects are then created as the type that they should be (ie. Notebooks and Desktops), and fully populated if the type is included in the extendingTypes array. However, if the type is not included then it is only partially populated up to the level of the base type (ie. Computer).

See Also

DBObject Class | Shunde.Framework Namespace | DBObject.GetObjects Overload List


DBObject.Populate Method

Populates this object from the database

public virtual void Populate();

Exceptions

Exception Type | Condition
ObjectDoesNotExistException | Thrown if the specified Id is not found in the database.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.PopulateBinaryData Method

Populates the data of all the BinaryData objects in this class

public void PopulateBinaryData();

Remarks

When Populate is called on an object, any Binary Data is not fully populated. This must be therefore called before trying to access the binary data.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.PopulateObjects Method

Populates the other DB objects in this class

public void PopulateObjects();

Remarks

This will populate all DBOBjects in this object, that are in the columns of the DBTable for this class. Any DBObjects that are null are not populated.

Exceptions

Exception Type | Condition
ObjectDoesNotExistException | Thrown if one of the DBObjects in this class has an invalid id.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.ResetId Method

Resets the Id of the object so that when saved again, a new object will be created in the database.

public void ResetId();

Remarks

This is useful for those times when you would like to clone an existing object. Simply populate it, call ResetId, and save

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.Save Method

Saves this object to the database

public virtual void Save();

Exceptions

Exception Type | Condition
ValidationException | Thrown if the object fails the database constraints. The Message property contains detailed information on why it failed, which is suitable to be shown to the end user.
ConcurrencyException | Thrown if an object is read and updated by more than one user at the same time. The first to save will have no problem, but if anyone tries to save subsequent to another save without re-reading the data, then this exception will be thrown. The Message property contains detailed information suitable to be shown to the end user.

See Also

DBObject Class | Shunde.Framework Namespace


DBObject.ToString Method

Gets a String representation of this object

public override string ToString();

See Also

DBObject Class | Shunde.Framework Namespace


DBTable Class

Represents a single Database Table

For a list of all members of this type, see DBTable Members.

System.Object
DBTable

public class DBTable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Framework

Assembly: Shunde (in Shunde.dll)

See Also

DBTable Members | Shunde.Framework Namespace


DBTable Members

DBTable overview

Public Instance Constructors

DBTable Constructor Creates a new DBTable with the specified Name and columns

Public Instance Properties

Columns | The columns that make up the Table
Name | The Name of the Table
ObjectInfo | The object info corresponding to this Table
UniqueIndexColumns | A comma separated list of columns that, held together, need to be unique

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DBTable Class | Shunde.Framework Namespace


DBTable Constructor

Creates a new DBTable with the specified Name and columns

public DBTable(
String name,
DBColumn[] columns
);

See Also

DBTable Class | Shunde.Framework Namespace


DBTable Properties

The properties of the DBTable class are listed below. For a complete list of DBTable class members, see the DBTable Members topic.

Public Instance Properties

Columns | The columns that make up the Table
Name | The Name of the Table
ObjectInfo | The object info corresponding to this Table
UniqueIndexColumns | A comma separated list of columns that, held together, need to be unique

See Also

DBTable Class | Shunde.Framework Namespace


Columns Property

Shunde.NET Framework Class Library

DBTable.Columns Property

The columns that make up the Table

public Columns {get;}

See Also

DBTable Class | Shunde.Framework Namespace


Name Property

Shunde.NET Framework Class Library

DBTable.Name Property

The Name of the Table

public Name {get;}

See Also

DBTable Class | Shunde.Framework Namespace


ObjectInfo Property

Shunde.NET Framework Class Library

DBTable.ObjectInfo Property

The object info corresponding to this Table

public ObjectInfo {get; set;}

See Also

DBTable Class | Shunde.Framework Namespace


UniqueIndexColumns Property

Shunde.NET Framework Class Library

DBTable.UniqueIndexColumns Property

A comma separated list of columns that, held together, need to be unique

public UniqueIndexColumns {get; set;}

Remarks

The comma separated list must have no spaces between the column names. Leave it as an empty string to have no unique index created.

See Also

DBTable Class | Shunde.Framework Namespace


ObjectInfo Class

Information for a class. This contains the DBTables that make up this object, as well as the from clause and column clause to use in SQL statements, etc.

For a list of all members of this type, see ObjectInfo Members.

System.Object
ObjectInfo

public class ObjectInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Framework

Assembly: Shunde (in Shunde.dll)

See Also

ObjectInfo Members | Shunde.Framework Namespace


ObjectInfo Members

ObjectInfo overview

Public Static Methods

GetObjectInfo | Gets an ObjectInfo for the given Type
RegisterObjectInfo | Overloaded. Registers an ObjectInfo into the hash Table
SetupObjectInfo | Sets up an object info object

Public Instance Constructors

ObjectInfo Overloaded. Initializes a new instance of the ObjectInfo class.

Public Instance Properties

DBObjectType | The Type of the object that this ObjectInfo represents
Tables | The tables that make up this object
UseView | Specifies that a view exists for this Table. The view is the equivalent of the joined tables.
ViewName | The Name of the Sql Server View, applicable if a view is used for this object info

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetJoinedColumnClause | Returns the columns of this object LEFT joined onto the specified object types
GetJoinedFromClause | Returns a FROM clause that is LEFT joined onto the specified object types
GetSelectStatement | Overloaded. Creates a SELECT statement for this object with no WHERE clause
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ObjectInfo Class | Shunde.Framework Namespace


ObjectInfo Constructor

Creates a new ObjectInfo class and populates the fromClause

Overload List

Creates a new ObjectInfo class and populates the fromClause

public ObjectInfo(Type,DBTable);

Creates a new ObjectInfo class and populates the fromClause, with the option of specifying that this object uses a Database view.

public ObjectInfo(Type,DBTable,Boolean);

See Also

ObjectInfo Class | Shunde.Framework Namespace


ObjectInfo Constructor (Type, DBTable)

Creates a new ObjectInfo class and populates the fromClause

public ObjectInfo(
Type type,
DBTable table
);

See Also

ObjectInfo Class | Shunde.Framework Namespace | ObjectInfo Constructor Overload List


ObjectInfo Constructor (Type, DBTable, Boolean)

Creates a new ObjectInfo class and populates the fromClause, with the option of specifying that this object uses a Database view.

public ObjectInfo(
Type type,
DBTable table,
Boolean useView
);

See Also

ObjectInfo Class | Shunde.Framework Namespace | ObjectInfo Constructor Overload List


ObjectInfo Properties

The properties of the ObjectInfo class are listed below. For a complete list of ObjectInfo class members, see the ObjectInfo Members topic.

Public Instance Properties

DBObjectType | The Type of the object that this ObjectInfo represents
Tables | The tables that make up this object
UseView | Specifies that a view exists for this Table. The view is the equivalent of the joined tables.
ViewName | The Name of the Sql Server View, applicable if a view is used for this object info

See Also

ObjectInfo Class | Shunde.Framework Namespace


DBObjectType Property

Shunde.NET Framework Class Library

ObjectInfo.DBObjectType Property

The Type of the object that this ObjectInfo represents

public DBObjectType {get;}

See Also

ObjectInfo Class | Shunde.Framework Namespace


Tables Property

Shunde.NET Framework Class Library

ObjectInfo.Tables Property

The tables that make up this object

public Tables {get;}

See Also

ObjectInfo Class | Shunde.Framework Namespace


UseView Property

Shunde.NET Framework Class Library

ObjectInfo.UseView Property

Specifies that a view exists for this Table. The view is the equivalent of the joined tables.

public UseView {get; set;}

See Also

ObjectInfo Class | Shunde.Framework Namespace


ViewName Property

Shunde.NET Framework Class Library

ObjectInfo.ViewName Property

The Name of the Sql Server View, applicable if a view is used for this object info

public ViewName {get;}

See Also

ObjectInfo Class | Shunde.Framework Namespace


ObjectInfo Methods

The methods of the ObjectInfo class are listed below. For a complete list of ObjectInfo class members, see the ObjectInfo Members topic.

Public Static Methods

GetObjectInfo | Gets an ObjectInfo for the given Type
RegisterObjectInfo | Overloaded. Registers an ObjectInfo into the hash Table
SetupObjectInfo | Sets up an object info object

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetJoinedColumnClause | Returns the columns of this object LEFT joined onto the specified object types
GetJoinedFromClause | Returns a FROM clause that is LEFT joined onto the specified object types
GetSelectStatement | Overloaded. Creates a SELECT statement for this object with no WHERE clause
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ObjectInfo Class | Shunde.Framework Namespace


ObjectInfo.GetJoinedColumnClause Method

Returns the columns of this object LEFT joined onto the specified object types

public string GetJoinedColumnClause(
Type[] types
);

See Also

ObjectInfo Class | Shunde.Framework Namespace


ObjectInfo.GetJoinedFromClause Method

Returns a FROM clause that is LEFT joined onto the specified object types

public string GetJoinedFromClause(
Type[] types
);

See Also

ObjectInfo Class | Shunde.Framework Namespace


ObjectInfo.GetObjectInfo Method

Gets an ObjectInfo for the given Type

public static ObjectInfo GetObjectInfo(
Type type
);

See Also

ObjectInfo Class | Shunde.Framework Namespace


GetSelectStatement Method

Shunde.NET Framework Class Library

ObjectInfo.GetSelectStatement Method

Creates a SELECT statement for this object with no WHERE clause

Overload List

Creates a SELECT statement for this object with no WHERE clause

public string GetSelectStatement();

Creates a SELECT statement for this object with no WHERE clause selecting the TOP numberToGet records, or unlimited if -1

public string GetSelectStatement(Int32);

See Also

ObjectInfo Class | Shunde.Framework Namespace


ObjectInfo.GetSelectStatement Method ()

Creates a SELECT statement for this object with no WHERE clause

public string GetSelectStatement();

See Also

ObjectInfo Class | Shunde.Framework Namespace | ObjectInfo.GetSelectStatement Overload List


ObjectInfo.GetSelectStatement Method (Int32)

Creates a SELECT statement for this object with no WHERE clause selecting the TOP numberToGet records, or unlimited if -1

public string GetSelectStatement(
Int32 numberToGet
);

See Also

ObjectInfo Class | Shunde.Framework Namespace | ObjectInfo.GetSelectStatement Overload List


RegisterObjectInfo Method

Shunde.NET Framework Class Library

ObjectInfo.RegisterObjectInfo Method

Registers an ObjectInfo into the hash Table

Overload List

Registers an ObjectInfo into the hash Table

public static void RegisterObjectInfo(ObjectInfo);

Registers an ObjectInfo into the hash Table

public static void RegisterObjectInfo(Type,DBTable);

See Also

ObjectInfo Class | Shunde.Framework Namespace


ObjectInfo.RegisterObjectInfo Method (ObjectInfo)

Registers an ObjectInfo into the hash Table

public static void RegisterObjectInfo(
ObjectInfo oi
);

See Also

ObjectInfo Class | Shunde.Framework Namespace | ObjectInfo.RegisterObjectInfo Overload List


ObjectInfo.RegisterObjectInfo Method (Type, DBTable)

Registers an ObjectInfo into the hash Table

public static void RegisterObjectInfo(
Type type,
DBTable table
);

See Also

ObjectInfo Class | Shunde.Framework Namespace | ObjectInfo.RegisterObjectInfo Overload List


ObjectInfo.SetupObjectInfo Method

Sets up an object info object

public static void SetupObjectInfo(
ObjectInfo oi
);

Remarks

Creates the FROM and COLUMN clauses. This is called by the constructor and is only necessary if something like useView has its Value changed

See Also

ObjectInfo Class | Shunde.Framework Namespace


Shunde.Utilities

Shunde.NET Framework Class Library

Shunde.Utilities Namespace

Namespace hierarchy

Classes

Class | Description
ColumnInfo | A Utility class for specifying values of a DBColumn for programmatically creating ASP.NET controls.
ComparableRow | A Panel with a display order so that you can order the panels after creating them
DBCreation | A class for creating database tables for DBObjects
DBUtils | Database Utilities for the Shunde framework
Encrypter | Some methods for encrypting text
ImageUtils | An image with methods to load, resize, and save images
ObjectUtils | A Utility class for the DBObject Class
PagingUtil | A class that helps create paging for an array of objects
TextUtils | A Utility class for text
WebUtils | A utility class for web-related tasks, eg making web requests or sending emails

Delegates

Delegate | Description
FindObjectDelegate | A delegate to handle the creation of a new object, given only the name.

Enumerations

Enumeration | Description
SelectionMode | These are the different modes available for selecting an object in the ObjectEditor


ColumnInfo Class

A Utility class for specifying values of a DBColumn for programmatically creating ASP.NET controls.

For a list of all members of this type, see ColumnInfo Members.

System.Object
ColumnInfo

public class ColumnInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

ColumnInfo Members | Shunde.Utilities Namespace


ColumnInfo Members

ColumnInfo overview

Public Static Fields

EmailRegex | The regular expression that matches an email address in standard Regular Expression syntax
SqlEmailRegex | The regular expression that matches an email address in SQL Server

Public Instance Constructors

ColumnInfo Constructor Initializes a new instance of the ColumnInfo class.

Public Instance Properties

AddOnTheFly | Specifies that, for a selection, new values can be typed in by the user
AutoPopulate | If true, then for a selection, the Object Editor will automatically populate the selections
DefaultValue | The default Value of the column
DisplayOrder | The order to display this column in, relative to others
FindObjectDelegate | If a TextBox mode is being used, then this delegate will be called to either find or create an object
FriendlyName | The Name to show end users, rather than the database Name
IsInvisible | Specifies that this column should be made into a text box in the form, however it should be invisible to the user (by using an Html hidden input field).
MaxAllowedInDropDown | The maximum number of options in a drop down allowed before a popup window is used to select an object. To force the use of a pop up window, set this to -1
MoreInfo | A description of the column to show end users
NoSelectionName | The option Name in a dropdown list to signify that no selection has been made
RegexErrorMessage | The error message to give when the user entered data does not match against ValidationRegex
SearchBoxUrl | The url of the page which will return the search results of that which is being typed in, if the selection mode for this column is set to SearchBox
SelectionMode | If this is a selections column, then this specifies the mode to use to select objects.
Selections | The available selections for a drop-down list
SelectionsPopupUrl | The Url of the popup window to select the object from
ShowThisColumn | Specifies whether to display this column to the end user
ShowTimeWithDate | Specifies that on a date field, a box for entering the time should be shown also. True, by default.
TexboxHeight | The height of the textbox. If null, then the default for the datatype is used.
TextboxWidth | The width of the textbox. If null, then the default for the datatype is used.
UseRichTextEditor | If this is an unbounded string, then a RTE can be used if this is set to true
ValidationRegex | An optional regular expression to match against user input
ViewBinaryDataUrl | The address to preview binary data

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMoreInfoAsJavascriptPopupHtml | Gets the html to create a link which invokes a javascript alert containing the MoreInfo details
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ColumnInfo Constructor

Initializes a new instance of the ColumnInfo class.

public ColumnInfo();

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ColumnInfo Fields

The fields of the ColumnInfo class are listed below. For a complete list of ColumnInfo class members, see the ColumnInfo Members topic.

Public Static Fields

EmailRegex | The regular expression that matches an email address in standard Regular Expression syntax
SqlEmailRegex | The regular expression that matches an email address in SQL Server

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ColumnInfo.EmailRegex Field

The regular expression that matches an email address in standard Regular Expression syntax

public static String EmailRegex;

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ColumnInfo.SqlEmailRegex Field

The regular expression that matches an email address in SQL Server

public static String SqlEmailRegex;

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ColumnInfo Properties

The properties of the ColumnInfo class are listed below. For a complete list of ColumnInfo class members, see the ColumnInfo Members topic.

Public Instance Properties

AddOnTheFly | Specifies that, for a selection, new values can be typed in by the user
AutoPopulate | If true, then for a selection, the Object Editor will automatically populate the selections
DefaultValue | The default Value of the column
DisplayOrder | The order to display this column in, relative to others
FindObjectDelegate | If a TextBox mode is being used, then this delegate will be called to either find or create an object
FriendlyName | The Name to show end users, rather than the database Name
IsInvisible | Specifies that this column should be made into a text box in the form, however it should be invisible to the user (by using an Html hidden input field).
MaxAllowedInDropDown | The maximum number of options in a drop down allowed before a popup window is used to select an object. To force the use of a pop up window, set this to -1
MoreInfo | A description of the column to show end users
NoSelectionName | The option Name in a dropdown list to signify that no selection has been made
RegexErrorMessage | The error message to give when the user entered data does not match against ValidationRegex
SearchBoxUrl | The url of the page which will return the search results of that which is being typed in, if the selection mode for this column is set to SearchBox
SelectionMode | If this is a selections column, then this specifies the mode to use to select objects.
Selections | The available selections for a drop-down list
SelectionsPopupUrl | The Url of the popup window to select the object from
ShowThisColumn | Specifies whether to display this column to the end user
ShowTimeWithDate | Specifies that on a date field, a box for entering the time should be shown also. True, by default.
TexboxHeight | The height of the textbox. If null, then the default for the datatype is used.
TextboxWidth | The width of the textbox. If null, then the default for the datatype is used.
UseRichTextEditor | If this is an unbounded string, then a RTE can be used if this is set to true
ValidationRegex | An optional regular expression to match against user input
ViewBinaryDataUrl | The address to preview binary data

See Also

ColumnInfo Class | Shunde.Utilities Namespace


AddOnTheFly Property

Shunde.NET Framework Class Library

ColumnInfo.AddOnTheFly Property

Specifies that, for a selection, new values can be typed in by the user

public AddOnTheFly {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


AutoPopulate Property

Shunde.NET Framework Class Library

ColumnInfo.AutoPopulate Property

If true, then for a selection, the Object Editor will automatically populate the selections

public AutoPopulate {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


DefaultValue Property

Shunde.NET Framework Class Library

ColumnInfo.DefaultValue Property

The default Value of the column

public DefaultValue {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


DisplayOrder Property

Shunde.NET Framework Class Library

ColumnInfo.DisplayOrder Property

The order to display this column in, relative to others

public DisplayOrder {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


FindObjectDelegate Property

Shunde.NET Framework Class Library

ColumnInfo.FindObjectDelegate Property

If a TextBox mode is being used, then this delegate will be called to either find or create an object

public FindObjectDelegate {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


FriendlyName Property

Shunde.NET Framework Class Library

ColumnInfo.FriendlyName Property

The Name to show end users, rather than the database Name

public FriendlyName {get; set;}

Remarks

If left blank, then this gets populated automatically using MakeFriendly on the column Name

See Also

ColumnInfo Class | Shunde.Utilities Namespace


IsInvisible Property

Shunde.NET Framework Class Library

ColumnInfo.IsInvisible Property

Specifies that this column should be made into a text box in the form, however it should be invisible to the user (by using an Html hidden input field).

public IsInvisible {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


MaxAllowedInDropDown Property

Shunde.NET Framework Class Library

ColumnInfo.MaxAllowedInDropDown Property

The maximum number of options in a drop down allowed before a popup window is used to select an object. To force the use of a pop up window, set this to -1

public MaxAllowedInDropDown {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


MoreInfo Property

Shunde.NET Framework Class Library

ColumnInfo.MoreInfo Property

A description of the column to show end users

public MoreInfo {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


NoSelectionName Property

Shunde.NET Framework Class Library

ColumnInfo.NoSelectionName Property

The option Name in a dropdown list to signify that no selection has been made

public NoSelectionName {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


RegexErrorMessage Property

Shunde.NET Framework Class Library

ColumnInfo.RegexErrorMessage Property

The error message to give when the user entered data does not match against ValidationRegex

public RegexErrorMessage {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


SearchBoxUrl Property

Shunde.NET Framework Class Library

ColumnInfo.SearchBoxUrl Property

The url of the page which will return the search results of that which is being typed in, if the selection mode for this column is set to SearchBox

public SearchBoxUrl {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


SelectionMode Property

Shunde.NET Framework Class Library

ColumnInfo.SelectionMode Property

If this is a selections column, then this specifies the mode to use to select objects.

public SelectionMode {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


Selections Property

Shunde.NET Framework Class Library

ColumnInfo.Selections Property

The available selections for a drop-down list

public Selections {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


SelectionsPopupUrl Property

Shunde.NET Framework Class Library

ColumnInfo.SelectionsPopupUrl Property

The Url of the popup window to select the object from

public SelectionsPopupUrl {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ShowThisColumn Property

Shunde.NET Framework Class Library

ColumnInfo.ShowThisColumn Property

Specifies whether to display this column to the end user

public ShowThisColumn {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ShowTimeWithDate Property

Shunde.NET Framework Class Library

ColumnInfo.ShowTimeWithDate Property

Specifies that on a date field, a box for entering the time should be shown also. True, by default.

public ShowTimeWithDate {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


TexboxHeight Property

Shunde.NET Framework Class Library

ColumnInfo.TexboxHeight Property

The height of the textbox. If null, then the default for the datatype is used.

public TexboxHeight {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


TextboxWidth Property

Shunde.NET Framework Class Library

ColumnInfo.TextboxWidth Property

The width of the textbox. If null, then the default for the datatype is used.

public TextboxWidth {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


UseRichTextEditor Property

Shunde.NET Framework Class Library

ColumnInfo.UseRichTextEditor Property

If this is an unbounded string, then a RTE can be used if this is set to true

public UseRichTextEditor {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ValidationRegex Property

Shunde.NET Framework Class Library

ColumnInfo.ValidationRegex Property

An optional regular expression to match against user input

public ValidationRegex {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ViewBinaryDataUrl Property

Shunde.NET Framework Class Library

ColumnInfo.ViewBinaryDataUrl Property

The address to preview binary data

public ViewBinaryDataUrl {get; set;}

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ColumnInfo Methods

The methods of the ColumnInfo class are listed below. For a complete list of ColumnInfo class members, see the ColumnInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMoreInfoAsJavascriptPopupHtml | Gets the html to create a link which invokes a javascript alert containing the MoreInfo details
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ColumnInfo.GetMoreInfoAsJavascriptPopupHtml Method

Gets the html to create a link which invokes a javascript alert containing the MoreInfo details

public string GetMoreInfoAsJavascriptPopupHtml();

See Also

ColumnInfo Class | Shunde.Utilities Namespace


ComparableRow Class

A Panel with a display order so that you can order the panels after creating them

For a list of all members of this type, see ComparableRow Members.

System.Object
Control
WebControl
TableRow
ComparableRow

public class ComparableRow : TableRow,

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

ComparableRow Members | Shunde.Utilities Namespace


ComparableRow Members

ComparableRow overview

Public Instance Constructors

ComparableRow Constructor Initializes a new instance of the ComparableRow class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
Cells (inherited from TableRow) | Gets a collection of TableCell objects that represent the cells of a row in a Table control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DisplayOrder | The relative number to order this panel to another with
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
HorizontalAlign (inherited from TableRow) | Gets or sets the horizontal alignment of the contents in the row.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TableSection (inherited from TableRow) | Gets or sets the location for a TableRow object in a Table control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
VerticalAlign (inherited from TableRow) | Gets or sets the vertical alignment of the contents in the row.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CompareTo |
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs after the Control object is loaded but prior to rendering.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateControlCollection (inherited from TableRow) | Creates a new ControlCollection object for the TableRow control.
CreateControlStyle (inherited from TableRow) | Creates a TableItemStyle object for the TableRow control.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
CreateChildControls (inherited from Control) | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnInit (inherited from Control) | Raises the Init event.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from WebControl) | Renders the control to the specified HTML writer.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

ComparableRow Class | Shunde.Utilities Namespace


ComparableRow Constructor

Initializes a new instance of the ComparableRow class.

public ComparableRow();

See Also

ComparableRow Class | Shunde.Utilities Namespace


ComparableRow Properties

The properties of the ComparableRow class are listed below. For a complete list of ComparableRow class members, see the ComparableRow Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
Cells (inherited from TableRow) | Gets a collection of TableCell objects that represent the cells of a row in a Table control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DisplayOrder | The relative number to order this panel to another with
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
HorizontalAlign (inherited from TableRow) | Gets or sets the horizontal alignment of the contents in the row.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TableSection (inherited from TableRow) | Gets or sets the location for a TableRow object in a Table control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
VerticalAlign (inherited from TableRow) | Gets or sets the vertical alignment of the contents in the row.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

See Also

ComparableRow Class | Shunde.Utilities Namespace


DisplayOrder Property

Shunde.NET Framework Class Library

ComparableRow.DisplayOrder Property

The relative number to order this panel to another with

public DisplayOrder {get; set;}

See Also

ComparableRow Class | Shunde.Utilities Namespace


ComparableRow Methods

The methods of the ComparableRow class are listed below. For a complete list of ComparableRow class members, see the ComparableRow Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CompareTo |
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateControlCollection (inherited from TableRow) | Creates a new ControlCollection object for the TableRow control.
CreateControlStyle (inherited from TableRow) | Creates a TableItemStyle object for the TableRow control.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
CreateChildControls (inherited from Control) | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnInit (inherited from Control) | Raises the Init event.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from WebControl) | Renders the control to the specified HTML writer.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
RenderContents (inherited from WebControl) | Renders the contents of the control to the specified writer. This method is used primarily by control developers.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

ComparableRow Class | Shunde.Utilities Namespace


ComparableRow.CompareTo Method

public int CompareTo(
Object another
);

Implements

IComparable.

See Also

ComparableRow Class | Shunde.Utilities Namespace


DBCreation Class

A class for creating database tables for DBObjects

For a list of all members of this type, see DBCreation Members.

System.Object
DBCreation

public class DBCreation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class creates SQL Code to create database tables and views, along with foreign key constraints etc, by using the information in the ObjectInfo class for a given type.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

DBCreation Members | Shunde.Utilities Namespace


DBCreation Members

DBCreation overview

Public Static Methods

GetCreateTable | Creates SQL Code to create a Table for the given type
GetCreateView | Creates SQL Code to create an indexed view
GetForeignKeyConstraints | Creates constraints for a Table

Public Instance Constructors

DBCreation Constructor Initializes a new instance of the DBCreation class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBCreation Class | Shunde.Utilities Namespace


DBCreation Constructor

Initializes a new instance of the DBCreation class.

public DBCreation();

See Also

DBCreation Class | Shunde.Utilities Namespace


DBCreation Methods

The methods of the DBCreation class are listed below. For a complete list of DBCreation class members, see the DBCreation Members topic.

Public Static Methods

GetCreateTable | Creates SQL Code to create a Table for the given type
GetCreateView | Creates SQL Code to create an indexed view
GetForeignKeyConstraints | Creates constraints for a Table

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBCreation Class | Shunde.Utilities Namespace


DBCreation.GetCreateTable Method

Creates SQL Code to create a Table for the given type

public static string GetCreateTable(
Type type,
List<T> checker,
Boolean tableAlreadyExists
);

Remarks

Pass a list of already-created Table names into checker to make sure that no duplicate tables are being created

See Also

DBCreation Class | Shunde.Utilities Namespace


DBCreation.GetCreateView Method

Creates SQL Code to create an indexed view

public static string GetCreateView(
Type type
);

See Also

DBCreation Class | Shunde.Utilities Namespace


DBCreation.GetForeignKeyConstraints Method

Creates constraints for a Table

public static string GetForeignKeyConstraints(
Type type
);

Remarks

Does not create any constraints for DBObjects

See Also

DBCreation Class | Shunde.Utilities Namespace


DBUtils Class

Database Utilities for the Shunde framework

For a list of all members of this type, see DBUtils Members.

System.Object
DBUtils

public class DBUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

DBUtils Members | Shunde.Utilities Namespace


DBUtils Members

DBUtils overview

Public Static Fields

storageContainer

Public Static Methods

BeginTransaction | Starts an Sql Transaction
CloseSqlConnection | Closes the database connection for the current HttpContext
CommitTransaction | Commits the currently started Sql Transaction
ExecuteSqlCommand | Overloaded. Executes a non-query SQL Command
ExecuteSqlQuery | Overloaded. Executes an SQL Query
GetBoolValue | Gets a boolean Value from the given SqlDataReader
GetDateTimeValue | Gets a DateTime Value from the given SqlDataReader
GetIntFromSqlSelect | Overloaded. Executes an SQL Query that is known to return just one integer Value
GetIntValue | Gets an int Value from the given SqlDataReader
getIntValueMayBeNull | Gets an int Value from the given SqlDataReader, where the int Value may be null
GetSqlConnection | Gets the SqlConnection
GetSqlDbType | Gets the SqlDataType for the given column
HasRows | Executes the given SQL Query and returns a boolean indicating whether 1 or more rows were returned
ParseSql | Overloaded. Escapes all apostrophes in an SQL Statement.
RollbackTransaction | Rolls back the current Sql Transaction
SetSqlConnection | Each HttpContext has it's own SqlConnection. This method sets the SqlConnection, ready to be used.

Public Instance Constructors

DBUtils Constructor Initializes a new instance of the DBUtils class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils Constructor

Initializes a new instance of the DBUtils class.

public DBUtils();

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils Fields

The fields of the DBUtils class are listed below. For a complete list of DBUtils class members, see the DBUtils Members topic.

Public Static Fields

storageContainer

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.storageContainer Field

public static IDictionary storageContainer;

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils Methods

The methods of the DBUtils class are listed below. For a complete list of DBUtils class members, see the DBUtils Members topic.

Public Static Methods

BeginTransaction | Starts an Sql Transaction
CloseSqlConnection | Closes the database connection for the current HttpContext
CommitTransaction | Commits the currently started Sql Transaction
ExecuteSqlCommand | Overloaded. Executes a non-query SQL Command
ExecuteSqlQuery | Overloaded. Executes an SQL Query
GetBoolValue | Gets a boolean Value from the given SqlDataReader
GetDateTimeValue | Gets a DateTime Value from the given SqlDataReader
GetIntFromSqlSelect | Overloaded. Executes an SQL Query that is known to return just one integer Value
GetIntValue | Gets an int Value from the given SqlDataReader
getIntValueMayBeNull | Gets an int Value from the given SqlDataReader, where the int Value may be null
GetSqlConnection | Gets the SqlConnection
GetSqlDbType | Gets the SqlDataType for the given column
HasRows | Executes the given SQL Query and returns a boolean indicating whether 1 or more rows were returned
ParseSql | Overloaded. Escapes all apostrophes in an SQL Statement.
RollbackTransaction | Rolls back the current Sql Transaction
SetSqlConnection | Each HttpContext has it's own SqlConnection. This method sets the SqlConnection, ready to be used.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.BeginTransaction Method

Starts an Sql Transaction

public static void BeginTransaction();

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.CloseSqlConnection Method

Closes the database connection for the current HttpContext

public static void CloseSqlConnection();

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.CommitTransaction Method

Commits the currently started Sql Transaction

public static void CommitTransaction();

See Also

DBUtils Class | Shunde.Utilities Namespace


ExecuteSqlCommand Method

Shunde.NET Framework Class Library

DBUtils.ExecuteSqlCommand Method

Executes a non-query SQL Command using the supplied SqlCommand object (useful for transactions)

Overload List

Executes a non-query SQL Command using the supplied SqlCommand object (useful for transactions)

public static void ExecuteSqlCommand(SqlCommand);

Executes a non-query SQL Command

public static void ExecuteSqlCommand(String);

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.ExecuteSqlCommand Method (SqlCommand)

Executes a non-query SQL Command using the supplied SqlCommand object (useful for transactions)

public static void ExecuteSqlCommand(
SqlCommand sqlCommand
);

Parameters

SqlCommand

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ExecuteSqlCommand Overload List


DBUtils.ExecuteSqlCommand Method (String)

Executes a non-query SQL Command

public static void ExecuteSqlCommand(
String sqlStatement
);

Parameters

String

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ExecuteSqlCommand Overload List


ExecuteSqlQuery Method

Shunde.NET Framework Class Library

DBUtils.ExecuteSqlQuery Method

Executes an SQL Query using the specified SqlCommand object (useful in Transactions)

Overload List

Executes an SQL Query using the specified SqlCommand object (useful in Transactions)

public static SqlDataReader ExecuteSqlQuery(SqlCommand);

Executes an SQL Query

public static SqlDataReader ExecuteSqlQuery(String);

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.ExecuteSqlQuery Method (SqlCommand)

Executes an SQL Query using the specified SqlCommand object (useful in Transactions)

public static SqlDataReader ExecuteSqlQuery(
SqlCommand sqlCommand
);

Parameters

SqlCommand

Return Value

Returns an SqlDataReader object with the results from the query

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ExecuteSqlQuery Overload List


DBUtils.ExecuteSqlQuery Method (String)

Executes an SQL Query

public static SqlDataReader ExecuteSqlQuery(
String sqlQuery
);

Parameters

String

Return Value

Returns an SqlDataReader object with the results from the query

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ExecuteSqlQuery Overload List


DBUtils.GetBoolValue Method

Gets a boolean Value from the given SqlDataReader

public static bool GetBoolValue(
SqlDataReader sdr,
String columnName
);

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.GetDateTimeValue Method

Gets a DateTime Value from the given SqlDataReader

public static DateTime GetDateTimeValue(
SqlDataReader sdr,
String columnName
);

See Also

DBUtils Class | Shunde.Utilities Namespace


GetIntFromSqlSelect Method

Shunde.NET Framework Class Library

DBUtils.GetIntFromSqlSelect Method

Executes an SQL Query that is known to return just one integer Value

Overload List

Executes an SQL Query that is known to return just one integer Value

public static int GetIntFromSqlSelect(SqlCommand);

Executes an SQL Query that is known to return just one integer Value

public static int GetIntFromSqlSelect(String);

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.GetIntFromSqlSelect Method (SqlCommand)

Executes an SQL Query that is known to return just one integer Value

public static int GetIntFromSqlSelect(
SqlCommand sqlCommand
);

Parameters

SqlCommand

Return Value

Returns the integer Value returned by the SQL statement

Remarks

To use this, set the column Name holding the integer to intValue. If no results are found, or more than 1 result is found, or intValue is an invalid column Name or does not hold an integer, a MiscException will be thrown

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.GetIntFromSqlSelect Overload List


DBUtils.GetIntFromSqlSelect Method (String)

Executes an SQL Query that is known to return just one integer Value

public static int GetIntFromSqlSelect(
String sqlQuery
);

Parameters

String

Return Value

Returns the integer Value returned by the SQL statement

Remarks

To use this, set the column Name holding the integer to intValue. If no results are found, or more than 1 result is found, or intValue is an invalid column Name or does not hold an integer, a MiscException will be thrown

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.GetIntFromSqlSelect Overload List


DBUtils.GetIntValue Method

Gets an int Value from the given SqlDataReader

public static int GetIntValue(
SqlDataReader sdr,
String columnName
);

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.getIntValueMayBeNull Method

Gets an int Value from the given SqlDataReader, where the int Value may be null

public static int getIntValueMayBeNull(
SqlDataReader sdr,
String columnName
);

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.GetSqlConnection Method

Gets the SqlConnection

public static SqlConnection GetSqlConnection();

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.GetSqlDbType Method

Gets the SqlDataType for the given column

public static SqlDbType GetSqlDbType(
DBColumn col
);

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.HasRows Method

Executes the given SQL Query and returns a boolean indicating whether 1 or more rows were returned

public static bool HasRows(
String query
);

See Also

DBUtils Class | Shunde.Utilities Namespace


ParseSql Method

Shunde.NET Framework Class Library

DBUtils.ParseSql Method

Converts a boolean into the SQL equivalent

Overload List

Converts a boolean into the SQL equivalent

public static string ParseSql(Boolean);

Parse a date-time, to be put into SQL Server

public static string ParseSql(DateTime);

Converts an int Value into the SQL equivalent, or NULL if int = int.MinValue

public static string ParseSql(Int32);

Escapes all apostrophes in an SQL Statement.

public static string ParseSql(String);

Escapes all apostrophes in an SQL Statement.

public static string ParseSql(String,Boolean);

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.ParseSql Method (Boolean)

Converts a boolean into the SQL equivalent

public static string ParseSql(
Boolean boolValue
);

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ParseSql Overload List


DBUtils.ParseSql Method (DateTime)

Parse a date-time, to be put into SQL Server

public static string ParseSql(
DateTime dateValue
);

Remarks

Sets Value to Null if DateTime.MinValue

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ParseSql Overload List


DBUtils.ParseSql Method (Int32)

Converts an int Value into the SQL equivalent, or NULL if int = int.MinValue

public static string ParseSql(
Int32 intValue
);

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ParseSql Overload List


DBUtils.ParseSql Method (String)

Escapes all apostrophes in an SQL Statement.

public static string ParseSql(
String sql
);

Parameters

String

Return Value

Returns escaped SQL string. This is an empty string if the passed string was null

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ParseSql Overload List


DBUtils.ParseSql Method (String, Boolean)

Escapes all apostrophes in an SQL Statement.

public static string ParseSql(
String sql,
Boolean encloseInSingleQuotes
);

Parameters

String
Boolean

Return Value

Returns escaped SQL string.

See Also

DBUtils Class | Shunde.Utilities Namespace | DBUtils.ParseSql Overload List


DBUtils.RollbackTransaction Method

Rolls back the current Sql Transaction

public static void RollbackTransaction();

See Also

DBUtils Class | Shunde.Utilities Namespace


DBUtils.SetSqlConnection Method

Each HttpContext has it's own SqlConnection. This method sets the SqlConnection, ready to be used.

public static void SetSqlConnection(
String connectionString
);

See Also

DBUtils Class | Shunde.Utilities Namespace


Encrypter Class

Some methods for encrypting text

For a list of all members of this type, see Encrypter Members.

System.Object
Encrypter

public class Encrypter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

Encrypter Members | Shunde.Utilities Namespace


Encrypter Members

Encrypter overview

Public Static Fields

HexDigits The hex digits in use

Public Static Methods

EncryptOneWay | Makes a one-way encryption on a string
ToHexString | Converts an array of bytes into hexadecimal digits

Public Instance Constructors

Encrypter Constructor Initializes a new instance of the Encrypter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Encrypter Class | Shunde.Utilities Namespace


Encrypter Constructor

Initializes a new instance of the Encrypter class.

public Encrypter();

See Also

Encrypter Class | Shunde.Utilities Namespace


Encrypter Fields

The fields of the Encrypter class are listed below. For a complete list of Encrypter class members, see the Encrypter Members topic.

Public Static Fields

HexDigits The hex digits in use

See Also

Encrypter Class | Shunde.Utilities Namespace


Encrypter.HexDigits Field

The hex digits in use

public static Char[] HexDigits;

See Also

Encrypter Class | Shunde.Utilities Namespace


Encrypter Methods

The methods of the Encrypter class are listed below. For a complete list of Encrypter class members, see the Encrypter Members topic.

Public Static Methods

EncryptOneWay | Makes a one-way encryption on a string
ToHexString | Converts an array of bytes into hexadecimal digits

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Encrypter Class | Shunde.Utilities Namespace


Encrypter.EncryptOneWay Method

Makes a one-way encryption on a string

public static string EncryptOneWay(
String hash,
String input
);

Parameters

String
A hash key to blend in with the input
String
The string to encrypt

Return Value

Returns an encrypted string which should be nearly impossible to return to the original string

See Also

Encrypter Class | Shunde.Utilities Namespace


Encrypter.ToHexString Method

Converts an array of bytes into hexadecimal digits

public static string ToHexString(
Byte[] bytes
);

See Also

Encrypter Class | Shunde.Utilities Namespace


FindObjectDelegate Delegate

A delegate to handle the creation of a new object, given only the name.

public delegate DBObject FindObjectDelegate(
String name,
Boolean createIfNotExists
);

Parameters

String
The name that the user has typed in
Boolean
If true, then the object will be attempted to be created, if possible, based on just the name

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.Utilities Namespace


ImageUtils Class

An image with methods to load, resize, and save images

For a list of all members of this type, see ImageUtils Members.

System.Object
ImageUtils

public class ImageUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

ImageUtils Members | Shunde.Utilities Namespace


ImageUtils Members

ImageUtils overview

Public Static Methods

CreatedResizedCopy | Overloaded. Creates a thumbnail of the current image, keeping width/height dimensions
CreateFromBinaryData | Instantiates a new ShundeImage from the given URI
CreateFromUri | Instantiates a new ShundeImage from the given URI
GetBytes | Overloaded. Gets this image as an array of bytes
GetJpgCodec | Gets the JPG codec
GetResizeMultiplier | Calculates amount to strectch image so the width and height are at a maximum while retaining aspect ratio

Public Instance Constructors

ImageUtils Constructor Initializes a new instance of the ImageUtils class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageUtils Class | Shunde.Utilities Namespace


ImageUtils Constructor

Initializes a new instance of the ImageUtils class.

public ImageUtils();

See Also

ImageUtils Class | Shunde.Utilities Namespace


ImageUtils Methods

The methods of the ImageUtils class are listed below. For a complete list of ImageUtils class members, see the ImageUtils Members topic.

Public Static Methods

CreatedResizedCopy | Overloaded. Creates a thumbnail of the current image, keeping width/height dimensions
CreateFromBinaryData | Instantiates a new ShundeImage from the given URI
CreateFromUri | Instantiates a new ShundeImage from the given URI
GetBytes | Overloaded. Gets this image as an array of bytes
GetJpgCodec | Gets the JPG codec
GetResizeMultiplier | Calculates amount to strectch image so the width and height are at a maximum while retaining aspect ratio

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImageUtils Class | Shunde.Utilities Namespace


CreatedResizedCopy Method

Shunde.NET Framework Class Library

ImageUtils.CreatedResizedCopy Method

Creates a thumbnail of the current image, keeping width/height dimensions

Overload List

Creates a thumbnail of the current image, keeping width/height dimensions

public static Bitmap CreatedResizedCopy(Image,Size,Boolean);

Creates a thumbnail of the current image, keeping width/height dimensions

public static Bitmap CreatedResizedCopy(Image,Int32,Int32,Boolean);

Creates a thumbnail of the current image, keeping width/height dimensions

public static Bitmap CreatedResizedCopy(Image,Int32,Int32,Boolean,Color);

Creates a thumbnail of the current image, keeping width/height dimensions

public static Bitmap CreatedResizedCopy(Image,Int32,Int32,Boolean,Color,VerticalAlign,HorizontalAlign);

See Also

ImageUtils Class | Shunde.Utilities Namespace


ImageUtils.CreatedResizedCopy Method (Image, Size, Boolean)

Creates a thumbnail of the current image, keeping width/height dimensions

public static Bitmap CreatedResizedCopy(
Image image,
Size newSize,
Boolean addWhiteSpace
);

Parameters

Image
Size
Boolean

See Also

ImageUtils Class | Shunde.Utilities Namespace | ImageUtils.CreatedResizedCopy Overload List


ImageUtils.CreatedResizedCopy Method (Image, Int32, Int32, Boolean)

Creates a thumbnail of the current image, keeping width/height dimensions

public static Bitmap CreatedResizedCopy(
Image image,
Int32 newWidth,
Int32 newHeight,
Boolean addWhiteSpace
);

Parameters

Image
Int32
Int32
Boolean

See Also

ImageUtils Class | Shunde.Utilities Namespace | ImageUtils.CreatedResizedCopy Overload List


ImageUtils.CreatedResizedCopy Method (Image, Int32, Int32, Boolean, Color)

Creates a thumbnail of the current image, keeping width/height dimensions

public static Bitmap CreatedResizedCopy(
Image image,
Int32 newWidth,
Int32 newHeight,
Boolean addWhiteSpace,
Color backgroundColor
);

Parameters

Image
Int32
Int32
Boolean
Color

See Also

ImageUtils Class | Shunde.Utilities Namespace | ImageUtils.CreatedResizedCopy Overload List


ImageUtils.CreatedResizedCopy Method (Image, Int32, Int32, Boolean, Color, VerticalAlign, HorizontalAlign)

Creates a thumbnail of the current image, keeping width/height dimensions

public static Bitmap CreatedResizedCopy(
Image image,
Int32 newWidth,
Int32 newHeight,
Boolean addWhiteSpace,
Color backgroundColor,
VerticalAlign verticalAlign,
HorizontalAlign horizontalAlign
);

Parameters

Image
Int32
Int32
Boolean
Color
VerticalAlign
HorizontalAlign

See Also

ImageUtils Class | Shunde.Utilities Namespace | ImageUtils.CreatedResizedCopy Overload List


ImageUtils.CreateFromBinaryData Method

Instantiates a new ShundeImage from the given URI

public static Bitmap CreateFromBinaryData(
BinaryData bd
);

See Also

ImageUtils Class | Shunde.Utilities Namespace


ImageUtils.CreateFromUri Method

Instantiates a new ShundeImage from the given URI

public static Bitmap CreateFromUri(
Uri uri
);

See Also

ImageUtils Class | Shunde.Utilities Namespace


GetBytes Method

Shunde.NET Framework Class Library

ImageUtils.GetBytes Method

Gets this image as an array of bytes

Overload List

Gets this image as an array of bytes

public static byte[] GetBytes(Bitmap);

Gets this image as an array of bytes

public static byte[] GetBytes(Bitmap,Int64);

See Also

ImageUtils Class | Shunde.Utilities Namespace


ImageUtils.GetBytes Method (Bitmap)

Gets this image as an array of bytes

public static byte[] GetBytes(
Bitmap bitmap
);

See Also

ImageUtils Class | Shunde.Utilities Namespace | ImageUtils.GetBytes Overload List


ImageUtils.GetBytes Method (Bitmap, Int64)

Gets this image as an array of bytes

public static byte[] GetBytes(
Bitmap bitmap,
Int64 compression
);

See Also

ImageUtils Class | Shunde.Utilities Namespace | ImageUtils.GetBytes Overload List


ImageUtils.GetJpgCodec Method

Gets the JPG codec

public static ImageCodecInfo GetJpgCodec();

See Also

ImageUtils Class | Shunde.Utilities Namespace


ImageUtils.GetResizeMultiplier Method

Calculates amount to strectch image so the width and height are at a maximum while retaining aspect ratio

public static double GetResizeMultiplier(
Image image,
Double newWidth,
Double newHeight
);

Parameters

Image
Double
Double

See Also

ImageUtils Class | Shunde.Utilities Namespace


ObjectUtils Class

A Utility class for the DBObject Class

For a list of all members of this type, see ObjectUtils Members.

System.Object
ObjectUtils

public class ObjectUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

ObjectUtils Members | Shunde.Utilities Namespace


ObjectUtils Members

ObjectUtils overview

Public Static Methods

AddObjectsToCache | Adds a collection of DBObjects to the cache, which can later be accessed using GetObjectFromCache.
AddToArray | Adds an object to an array, or replaces it if it's already in the array
DeleteFromList | Deletes an DBObject from an array of DBObjects
GetFromList | Gets a DBObject with the given id from an array of DBObjects, or null if the DBObject is not in the array
GetIDsAsCSV | Returns a comma separated list of object IDs
GetObjectFromCache | Populates an object with the given id, and saves it to the cache. In future instances, the cached version is used.
RemoveObjectFromCache | Removes the object with the given id from the cache
SaveListOfObjects | Saves an array of DBObjects
WriteObjectsToXml | Writes a list of DBObjects to a stream as XML

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils Methods

The methods of the ObjectUtils class are listed below. For a complete list of ObjectUtils class members, see the ObjectUtils Members topic.

Public Static Methods

AddObjectsToCache | Adds a collection of DBObjects to the cache, which can later be accessed using GetObjectFromCache.
AddToArray | Adds an object to an array, or replaces it if it's already in the array
DeleteFromList | Deletes an DBObject from an array of DBObjects
GetFromList | Gets a DBObject with the given id from an array of DBObjects, or null if the DBObject is not in the array
GetIDsAsCSV | Returns a comma separated list of object IDs
GetObjectFromCache | Populates an object with the given id, and saves it to the cache. In future instances, the cached version is used.
RemoveObjectFromCache | Removes the object with the given id from the cache
SaveListOfObjects | Saves an array of DBObjects
WriteObjectsToXml | Writes a list of DBObjects to a stream as XML

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.AddObjectsToCache Method

Adds a collection of DBObjects to the cache, which can later be accessed using GetObjectFromCache.

public static void AddObjectsToCache(
Cache cache,
IEnumerable<T> objectsToAdd
);

Parameters

Cache
The cache to use
IEnumerable<T>
The objects to add

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.AddToArray Method

Adds an object to an array, or replaces it if it's already in the array

public static void AddToArray(
DBObject[] array,
DBObject toAdd
);

Parameters

DBObject[]
An array of objects
DBObject
The object to be updated or added

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.DeleteFromList Method

Deletes an DBObject from an array of DBObjects

public static void DeleteFromList(
IEnumerable<T> objects,
DBObject objectToBeDeleted
);

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.GetFromList Method

Gets a DBObject with the given id from an array of DBObjects, or null if the DBObject is not in the array

public static DBObject GetFromList(
IEnumerable<T> objects,
Int32 objectId
);

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.GetIDsAsCSV Method

Returns a comma separated list of object IDs

public static string GetIDsAsCSV(
IEnumerable<T> objects
);

Parameters

IEnumerable<T>

Return Value

A comma separated list as a string

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.GetObjectFromCache Method

Populates an object with the given id, and saves it to the cache. In future instances, the cached version is used.

public static DBObject GetObjectFromCache(
Cache cache,
Int32 objectId
);

Parameters

Cache
The Cache to use
Int32
The ID of the object to populate

Return Value

A fully populated DBObject

Exceptions

Exception Type | Condition
ObjectDoesNotExistException | Thrown when the object does not exist in the database

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.RemoveObjectFromCache Method

Removes the object with the given id from the cache

public static void RemoveObjectFromCache(
Cache cache,
Int32 objectId
);

Parameters

Cache
The cache to use
Int32
The id of the object to remove

Remarks

No exception is thrown if the object is not already in the cache

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.SaveListOfObjects Method

Saves an array of DBObjects

public static void SaveListOfObjects(
IEnumerable<T> objects
);

Parameters

IEnumerable<T>

Exceptions

Exception Type | Condition
ValidationException | Thrown if an object in the array fails the database constraints. The Message property contains detailed information on why it failed, which may or may not be suitable to show on the end user, depending on the situation.
ConcurrencyException | Thrown if an object is read and updated by more than one user at the same time. The first to save will have no problem, but if anyone tries to save subsequent to another save without re-reading the data, then this exception will be thrown. The Message property contains detailed information suitable to be shown to the end user.

See Also

ObjectUtils Class | Shunde.Utilities Namespace


ObjectUtils.WriteObjectsToXml Method

Writes a list of DBObjects to a stream as XML

public static void WriteObjectsToXml(
Stream outputStream,
IList<T> objects
);

Parameters

Stream
The stream to write to
IList<T>
The DBObjects to write

See Also

ObjectUtils Class | Shunde.Utilities Namespace


PagingUtil Class

A class that helps create paging for an array of objects

For a list of all members of this type, see PagingUtil Members.

System.Object
PagingUtil

public class PagingUtil

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

PagingUtil Members | Shunde.Utilities Namespace


PagingUtil Members

PagingUtil overview

Public Instance Constructors

PagingUtil Overloaded. Initializes a new instance of the PagingUtil class.

Public Instance Properties

CurrentPage | Holds Value of property currentPage
HasNextPage | Specifies whether there is another page or not
HasPreviousPage | Specifies whether there is a previous page or not
NumberOfItems | Holds Value of property size
NumberPerPage | Holds Value of property numberPerPage
TotalPages | The total number of pages of items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnd | Gets the end index for this page
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPageLinksAsHtml | Gets the list of pages, with next, page nums, and previous buttons
getPageXOfY | Gets text saying Page X of Y
GetStart | Gets the start index for this page
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PagingUtil Class | Shunde.Utilities Namespace


PagingUtil Constructor

Creates a new Paging Util object

Overload List

Creates a new Paging Util object

public PagingUtil();

Creates a new Paging Util object

public PagingUtil(Int32,Int32,Int32);

See Also

PagingUtil Class | Shunde.Utilities Namespace


PagingUtil Constructor ()

Creates a new Paging Util object

public PagingUtil();

See Also

PagingUtil Class | Shunde.Utilities Namespace | PagingUtil Constructor Overload List


PagingUtil Constructor (Int32, Int32, Int32)

Creates a new Paging Util object

public PagingUtil(
Int32 currentPage,
Int32 numberOfItems,
Int32 numberPerPage
);

Parameters

Int32
Int32
Int32

See Also

PagingUtil Class | Shunde.Utilities Namespace | PagingUtil Constructor Overload List


PagingUtil Properties

The properties of the PagingUtil class are listed below. For a complete list of PagingUtil class members, see the PagingUtil Members topic.

Public Instance Properties

CurrentPage | Holds Value of property currentPage
HasNextPage | Specifies whether there is another page or not
HasPreviousPage | Specifies whether there is a previous page or not
NumberOfItems | Holds Value of property size
NumberPerPage | Holds Value of property numberPerPage
TotalPages | The total number of pages of items

See Also

PagingUtil Class | Shunde.Utilities Namespace


CurrentPage Property

Shunde.NET Framework Class Library

PagingUtil.CurrentPage Property

Holds Value of property currentPage

public CurrentPage {get; set;}

See Also

PagingUtil Class | Shunde.Utilities Namespace


HasNextPage Property

Shunde.NET Framework Class Library

PagingUtil.HasNextPage Property

Specifies whether there is another page or not

public HasNextPage {get;}

See Also

PagingUtil Class | Shunde.Utilities Namespace


HasPreviousPage Property

Shunde.NET Framework Class Library

PagingUtil.HasPreviousPage Property

Specifies whether there is a previous page or not

public HasPreviousPage {get;}

See Also

PagingUtil Class | Shunde.Utilities Namespace


NumberOfItems Property

Shunde.NET Framework Class Library

PagingUtil.NumberOfItems Property

Holds Value of property size

public NumberOfItems {get; set;}

See Also

PagingUtil Class | Shunde.Utilities Namespace


NumberPerPage Property

Shunde.NET Framework Class Library

PagingUtil.NumberPerPage Property

Holds Value of property numberPerPage

public NumberPerPage {get; set;}

See Also

PagingUtil Class | Shunde.Utilities Namespace


TotalPages Property

Shunde.NET Framework Class Library

PagingUtil.TotalPages Property

The total number of pages of items

public TotalPages {get;}

See Also

PagingUtil Class | Shunde.Utilities Namespace


PagingUtil Methods

The methods of the PagingUtil class are listed below. For a complete list of PagingUtil class members, see the PagingUtil Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnd | Gets the end index for this page
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPageLinksAsHtml | Gets the list of pages, with next, page nums, and previous buttons
getPageXOfY | Gets text saying Page X of Y
GetStart | Gets the start index for this page
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PagingUtil Class | Shunde.Utilities Namespace


PagingUtil.GetEnd Method

Gets the end index for this page

public int GetEnd();

See Also

PagingUtil Class | Shunde.Utilities Namespace


PagingUtil.GetPageLinksAsHtml Method

Gets the list of pages, with next, page nums, and previous buttons

public string GetPageLinksAsHtml(
String linkUrl,
String separator
);

See Also

PagingUtil Class | Shunde.Utilities Namespace


PagingUtil.getPageXOfY Method

Gets text saying Page X of Y

public string getPageXOfY();

See Also

PagingUtil Class | Shunde.Utilities Namespace


PagingUtil.GetStart Method

Gets the start index for this page

public int GetStart();

See Also

PagingUtil Class | Shunde.Utilities Namespace


SelectionMode Enumeration

These are the different modes available for selecting an object in the ObjectEditor

public enum SelectionMode

Members

Member Name | Description
DropDownList | Uses a dropdown list to select the object.
RadioButtonList | Uses a radiobuttonlist. This is best when there are only a few options to choose from.
TextBox | Uses a textbox to allow the user to enter in a name to find the object. If a url for a popup window is given, then it uses a popup window. This is best when there are hundreds or more objects, or some advanced search is required to find the object. If an XML search url is specified, then as they write, matching objects are displayed, allowing them to select an object.
Default | The default action is to use a dropdown list, unless a specified threshold is passed.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.Utilities Namespace


TextUtils Class

A Utility class for text

For a list of all members of this type, see TextUtils Members.

System.Object
TextUtils

public class TextUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

TextUtils Members | Shunde.Utilities Namespace


TextUtils Members

TextUtils overview

Public Static Methods

AppendNameValueToUrl | Appends a Name and Value pair to a URL
AreSameDay | Returns true if 2 date times are on the same day
AreSameTime | Returns true if 2 date times have the same Hour and Minute values
CutText | Cuts a string to end at the end of a word. It appends "..." to the end if the text is cut (that is, if length is greater than the length of the string).
GetExceptionReportAsHtml | Gets a diagnostic report of an exception
GetFriendlyDate | Gets the textual representation of a date in a "friendly" format, using the specified month and year formats. If the time is not midnight, then the time is included
GetFriendlyDateRange | Gets, as text, the start and end date and time for a start date and end date using the format strings for the month and year
GetFriendlyFileSize | Converts a number of bytes into a friendly Name, such as 603 bytes, 14 KB, 1,048 MB etc
GetNoiseWords | Creates a dictionary containing all the words in the noise file
GetOrdinalSuffix | Gets a number as an ordered number, if you know what I mean. For example, converts 1 to "1st" or 2 to "2nd"
IsMidnight | Returns true if the time is midnight
IsValidEmailAddress | Checks to see if a string is a valid email address. A valid email address is at least 5 characters, and has an '@' and a '.' in it
JavascriptStringEncode | Converts a string so that it can be used as a javascript string
MakeFriendly | Converts a string in camel format suchAsThis into a string Such As This
ParseStringForFullTextSearch | Overloaded. Parses a string so that it is suitable for a CONTAINSTABLE query
RemoveIllegalCharactersFromFilename | Removes illegal characters, such as ':' and '\' from filenames
RemoveNonAlphaNumeric | Strips a string of all but the alpha-numeric characters
RemoveNonNumeric | Strips a string of all but the numeric characters
ToHtml | Converts a string's line breaks into Html line breaks

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils Methods

The methods of the TextUtils class are listed below. For a complete list of TextUtils class members, see the TextUtils Members topic.

Public Static Methods

AppendNameValueToUrl | Appends a Name and Value pair to a URL
AreSameDay | Returns true if 2 date times are on the same day
AreSameTime | Returns true if 2 date times have the same Hour and Minute values
CutText | Cuts a string to end at the end of a word. It appends "..." to the end if the text is cut (that is, if length is greater than the length of the string).
GetExceptionReportAsHtml | Gets a diagnostic report of an exception
GetFriendlyDate | Gets the textual representation of a date in a "friendly" format, using the specified month and year formats. If the time is not midnight, then the time is included
GetFriendlyDateRange | Gets, as text, the start and end date and time for a start date and end date using the format strings for the month and year
GetFriendlyFileSize | Converts a number of bytes into a friendly Name, such as 603 bytes, 14 KB, 1,048 MB etc
GetNoiseWords | Creates a dictionary containing all the words in the noise file
GetOrdinalSuffix | Gets a number as an ordered number, if you know what I mean. For example, converts 1 to "1st" or 2 to "2nd"
IsMidnight | Returns true if the time is midnight
IsValidEmailAddress | Checks to see if a string is a valid email address. A valid email address is at least 5 characters, and has an '@' and a '.' in it
JavascriptStringEncode | Converts a string so that it can be used as a javascript string
MakeFriendly | Converts a string in camel format suchAsThis into a string Such As This
ParseStringForFullTextSearch | Overloaded. Parses a string so that it is suitable for a CONTAINSTABLE query
RemoveIllegalCharactersFromFilename | Removes illegal characters, such as ':' and '\' from filenames
RemoveNonAlphaNumeric | Strips a string of all but the alpha-numeric characters
RemoveNonNumeric | Strips a string of all but the numeric characters
ToHtml | Converts a string's line breaks into Html line breaks

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.AppendNameValueToUrl Method

Appends a Name and Value pair to a URL

public static string AppendNameValueToUrl(
String url,
String name,
String value
);

Remarks

Automatically adds the '?' or '&' as necessary, and URLEncodes the Value

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.AreSameDay Method

Returns true if 2 date times are on the same day

public static bool AreSameDay(
DateTime d1,
DateTime d2
);

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.AreSameTime Method

Returns true if 2 date times have the same Hour and Minute values

public static bool AreSameTime(
DateTime d1,
DateTime d2
);

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.CutText Method

Cuts a string to end at the end of a word. It appends "..." to the end if the text is cut (that is, if length is greater than the length of the string).

public static string CutText(
String str,
Int32 length
);

Parameters

String
Int32

Return Value

A string cut at the specified point

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.GetExceptionReportAsHtml Method

Gets a diagnostic report of an exception

public static string GetExceptionReportAsHtml(
Exception ex,
HttpRequest request,
String extraInformation
);

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.GetFriendlyDate Method

Gets the textual representation of a date in a "friendly" format, using the specified month and year formats. If the time is not midnight, then the time is included

public static string GetFriendlyDate(
DateTime date,
String monthFormat,
String yearFormat
);

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.GetFriendlyDateRange Method

Gets, as text, the start and end date and time for a start date and end date using the format strings for the month and year

public static string GetFriendlyDateRange(
DateTime start,
DateTime end,
String monthFormat,
String yearFormat
);

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.GetFriendlyFileSize Method

Converts a number of bytes into a friendly Name, such as 603 bytes, 14 KB, 1,048 MB etc

public static string GetFriendlyFileSize(
Int64 sizeInBytes
);

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.GetNoiseWords Method

Creates a dictionary containing all the words in the noise file

public static Dictionary<TKey,TValue> GetNoiseWords(
String filePath
);

Parameters

String

Return Value

Returns a hash Table

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.GetOrdinalSuffix Method

Gets a number as an ordered number, if you know what I mean. For example, converts 1 to "1st" or 2 to "2nd"

public static string GetOrdinalSuffix(
Int32 number
);

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.IsMidnight Method

Returns true if the time is midnight

public static bool IsMidnight(
DateTime d
);

Remarks

Ignores the seconds and milliseconds

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.IsValidEmailAddress Method

Checks to see if a string is a valid email address. A valid email address is at least 5 characters, and has an '@' and a '.' in it

public static bool IsValidEmailAddress(
String email
);

Parameters

String

Return Value

Returns boolean indicating whether this is a valid email address or not

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.JavascriptStringEncode Method

Converts a string so that it can be used as a javascript string

public static string JavascriptStringEncode(
String s
);

Remarks

Uses escape codes for new lines, apostrophes, speech marks

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.MakeFriendly Method

Converts a string in camel format suchAsThis into a string Such As This

public static string MakeFriendly(
String s
);

See Also

TextUtils Class | Shunde.Utilities Namespace


ParseStringForFullTextSearch Method

Shunde.NET Framework Class Library

TextUtils.ParseStringForFullTextSearch Method

Parses a string so that it is suitable for a CONTAINSTABLE query

Overload List

Parses a string so that it is suitable for a CONTAINSTABLE query

public static string ParseStringForFullTextSearch(String,Dictionary<TKey,TValue>,String);

Parses a string so that it is suitable for a CONTAINSTABLE query

public static string ParseStringForFullTextSearch(String,String[],String);

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.ParseStringForFullTextSearch Method (String, Dictionary`2, String)

Parses a string so that it is suitable for a CONTAINSTABLE query

public static string ParseStringForFullTextSearch(
String searchQuery,
Dictionary<TKey,TValue> noiseWords,
String searchType
);

Parameters

String
Dictionary<TKey,TValue>
String

Return Value

The string ready to be queried

See Also

TextUtils Class | Shunde.Utilities Namespace | TextUtils.ParseStringForFullTextSearch Overload List


TextUtils.ParseStringForFullTextSearch Method (String, String[], String)

Parses a string so that it is suitable for a CONTAINSTABLE query

public static string ParseStringForFullTextSearch(
String searchQuery,
String[] noiseWords,
String searchType
);

Parameters

String
String[]
String

Return Value

The string ready to be queried

See Also

TextUtils Class | Shunde.Utilities Namespace | TextUtils.ParseStringForFullTextSearch Overload List


TextUtils.RemoveIllegalCharactersFromFilename Method

Removes illegal characters, such as ':' and '\' from filenames

public static string RemoveIllegalCharactersFromFilename(
String filename
);

Parameters

String

Return Value

The filename where any illegal characters are replaced with underscores

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.RemoveNonAlphaNumeric Method

Strips a string of all but the alpha-numeric characters

public static string RemoveNonAlphaNumeric(
String input
);

Parameters

String

Return Value

Returns just the alpha-numeric characters of the input string

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.RemoveNonNumeric Method

Strips a string of all but the numeric characters

public static string RemoveNonNumeric(
String input
);

Parameters

String

Return Value

Returns just the numeric characters of the input string

See Also

TextUtils Class | Shunde.Utilities Namespace


TextUtils.ToHtml Method

Converts a string's line breaks into Html line breaks

public static string ToHtml(
String text
);

See Also

TextUtils Class | Shunde.Utilities Namespace


WebUtils Class

A utility class for web-related tasks, eg making web requests or sending emails

For a list of all members of this type, see WebUtils Members.

System.Object
WebUtils

public class WebUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.Utilities

Assembly: Shunde (in Shunde.dll)

See Also

WebUtils Members | Shunde.Utilities Namespace


WebUtils Members

WebUtils overview

Public Static Fields

EmailsPerNewsletter The number of email addresses put into the Blind Carbon Copy field that can be sent at once, for bulk email sending

Public Static Methods

GetHostName | Gets the host Name from an IP Address
GetResponse | Makes a request to a Uri, and returns the Response
MakeWebRequest | Overloaded. Makes a request to a Uri, and returns the output
RenderControlToString | Renders a control to a string. Useful for things such as using a control to create HTML for an email
RenderWebUserControlToString | Renders a control to a string. Useful for things such as using a control to create HTML for an email
sendBulkEmail | Sends a bulk email

Public Instance Constructors

WebUtils Constructor Initializes a new instance of the WebUtils class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils Constructor

Initializes a new instance of the WebUtils class.

public WebUtils();

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils Fields

The fields of the WebUtils class are listed below. For a complete list of WebUtils class members, see the WebUtils Members topic.

Public Static Fields

EmailsPerNewsletter The number of email addresses put into the Blind Carbon Copy field that can be sent at once, for bulk email sending

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils.EmailsPerNewsletter Field

The number of email addresses put into the Blind Carbon Copy field that can be sent at once, for bulk email sending

public const Int32 EmailsPerNewsletter = 100;

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils Methods

The methods of the WebUtils class are listed below. For a complete list of WebUtils class members, see the WebUtils Members topic.

Public Static Methods

GetHostName | Gets the host Name from an IP Address
GetResponse | Makes a request to a Uri, and returns the Response
MakeWebRequest | Overloaded. Makes a request to a Uri, and returns the output
RenderControlToString | Renders a control to a string. Useful for things such as using a control to create HTML for an email
RenderWebUserControlToString | Renders a control to a string. Useful for things such as using a control to create HTML for an email
sendBulkEmail | Sends a bulk email

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils.GetHostName Method

Gets the host Name from an IP Address

public static string GetHostName(
String ipAddress
);

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils.GetResponse Method

Makes a request to a Uri, and returns the Response

public static HttpWebResponse GetResponse(
Uri target,
String postValue,
NetworkCredential networkCredentials
);

Parameters

Uri
String
NetworkCredential

Return Value

The output of the requested Uri

See Also

WebUtils Class | Shunde.Utilities Namespace


MakeWebRequest Method

Shunde.NET Framework Class Library

WebUtils.MakeWebRequest Method

Makes a request to a Uri, and returns the output

Overload List

Makes a request to a Uri, and returns the output

public static string MakeWebRequest(Uri,String);

Makes a request to a Uri, and returns the output

public static string MakeWebRequest(Uri,String,NetworkCredential);

Makes a request to a Uri, and returns the output

public static string MakeWebRequest(Uri,String,String,String,String);

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils.MakeWebRequest Method (Uri, String)

Makes a request to a Uri, and returns the output

public static string MakeWebRequest(
Uri target,
String postValue
);

Parameters

Uri
String

Return Value

The output of the requested Uri

See Also

WebUtils Class | Shunde.Utilities Namespace | WebUtils.MakeWebRequest Overload List


WebUtils.MakeWebRequest Method (Uri, String, NetworkCredential)

Makes a request to a Uri, and returns the output

public static string MakeWebRequest(
Uri target,
String postValue,
NetworkCredential networkCredentials
);

Parameters

Uri
String
NetworkCredential

Return Value

The output of the requested Uri

See Also

WebUtils Class | Shunde.Utilities Namespace | WebUtils.MakeWebRequest Overload List


WebUtils.MakeWebRequest Method (Uri, String, String, String, String)

Makes a request to a Uri, and returns the output

public static string MakeWebRequest(
Uri target,
String postValue,
String userName,
String password,
String domain
);

Parameters

Uri
String
String
String
String

Return Value

The output of the requested Uri

See Also

WebUtils Class | Shunde.Utilities Namespace | WebUtils.MakeWebRequest Overload List


WebUtils.RenderControlToString Method

Renders a control to a string. Useful for things such as using a control to create HTML for an email

public static string RenderControlToString(
Control control
);

Parameters

Control

Return Value

The HTML as a string of the control

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils.RenderWebUserControlToString Method

Renders a control to a string. Useful for things such as using a control to create HTML for an email

public static string RenderWebUserControlToString(
Page page,
Control control
);

Parameters

Page
Control

Return Value

The HTML as a string of the control

See Also

WebUtils Class | Shunde.Utilities Namespace


WebUtils.sendBulkEmail Method

Sends a bulk email

public static void sendBulkEmail(
String from,
String[] to,
String subject,
String body,
String styles
);

See Also

WebUtils Class | Shunde.Utilities Namespace


Shunde.WebControls

Shunde.NET Framework Class Library

Shunde.WebControls Namespace

Some useful web controls for use in ASP.NET 2.0 applications.

Namespace hierarchy

Classes

Class | Description
ObjectEditor | A Control that renders text boxes to edit a DBObject
TextSectionDisplayer | A control to render a TextSection to an HTML page
TreeDisplayer | Displays a forest of trees, using HTML unordered lists

Delegates

Delegate | Description
AfterObjectDeletedDelegate | Called after an object is deleted
AfterObjectSavedDelegate | Called after the object has been saved
BeforeSaveDelegate | Called after the object has been saved
EditCancelledDelegate | A delegate to take care of saving the object
NodeToHtmlDelegate | A delegate that gets an HTML representation for the treenode
ObjectDeleteDelegate | A delegate to take care of saving the object
ObjectSaveDelegate | A delegate to take care of saving the object


AfterObjectDeletedDelegate Delegate

Called after an object is deleted

public delegate void AfterObjectDeletedDelegate();

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.WebControls Namespace


AfterObjectSavedDelegate Delegate

Called after the object has been saved

public delegate void AfterObjectSavedDelegate();

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.WebControls Namespace


BeforeSaveDelegate Delegate

Called after the object has been saved

public delegate void BeforeSaveDelegate();

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.WebControls Namespace


EditCancelledDelegate Delegate

A delegate to take care of saving the object

public delegate void EditCancelledDelegate();

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.WebControls Namespace


NodeToHtmlDelegate Delegate

A delegate that gets an HTML representation for the treenode

public delegate string NodeToHtmlDelegate(
TreeNode node
);

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.WebControls Namespace


ObjectDeleteDelegate Delegate

A delegate to take care of saving the object

public delegate void ObjectDeleteDelegate();

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.WebControls Namespace


ObjectEditor Class

A Control that renders text boxes to edit a DBObject

For a list of all members of this type, see ObjectEditor Members.

System.Object
Control
WebControl
ObjectEditor

public class ObjectEditor : WebControl,

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

ObjectEditor Members | Shunde.WebControls Namespace


ObjectEditor Members

ObjectEditor overview

Public Instance Constructors

ObjectEditor Constructor Creates a new Object Editor

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
AfterObjectDeletedDelegate | If the object editor deletes the object, then this will be called upon a successful delete, upon which the delegate will probably redirect to another page.
AfterObjectSavedDelegate | If the object editor saves the object, then this will be called upon a successful save, upon which the delegate will probably redirect to another page.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
AutoPopulateSelections | If true, then selections will be automatically populated, if they aren't already
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BeforeSaveDelegate | If this is set and ObjectSaveDelegate is null, then this will be called after populating the object with the values from the object editor, but before the Save method is called.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
CancelButton |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DateTextBoxWidth | The default width of date textboxes
DBObject | The object being edited
DeleteButton |
EditCancelledDelegate | Called when the 'cancel' button is pressed
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileUploaderWidth | The default width of file uploaders
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
IsForPublic | If set to false, then extra info is given in dropdown boxes. This should be false almost always.
MultilineTextBoxHeight | The default width of string textboxes
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
NumberTextBoxWidth | The default width of number textboxes
ObjectDeleteDelegate | If this is set, then this will be called when the object editor 'delete' button is pressed. If it is null, then the object editor will delete the object.
ObjectSaveDelegate | If this is set, then this will be called when the object editor 'save' button is pressed. If it is null, then the object editor will save the object.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
SaveButton |
ShowOnlySpecified | If true, then only those columns that have information in the info hashtable will be shown
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
StringTextBoxWidth | The default width of string textboxes
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
UpdaterName | An optional Name to record who updated this object
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
GetCI | Gets the column info of a column
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
PopulateTable | Makes the table
RenderBeginTag | Renders the begin tag
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SaveUserInputToObject | Writes the user-inputted values to the object
SetFriendlyName | Sets the friendly Name of a database column
SetOrders | Pass an array of strings and column infos for each string will be made with display order in ascending order
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs after the Control object is loaded but prior to rendering.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey | Gets the tag that surrounds this control
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit | The OnInit event
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RenderContents | This method is created solely for the design view of visual studio
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
CreateChildControls (inherited from Control) | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from WebControl) | Renders the control to the specified HTML writer.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor Constructor

Creates a new Object Editor

public ObjectEditor();

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor Properties

The properties of the ObjectEditor class are listed below. For a complete list of ObjectEditor class members, see the ObjectEditor Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
AfterObjectDeletedDelegate | If the object editor deletes the object, then this will be called upon a successful delete, upon which the delegate will probably redirect to another page.
AfterObjectSavedDelegate | If the object editor saves the object, then this will be called upon a successful save, upon which the delegate will probably redirect to another page.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
AutoPopulateSelections | If true, then selections will be automatically populated, if they aren't already
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BeforeSaveDelegate | If this is set and ObjectSaveDelegate is null, then this will be called after populating the object with the values from the object editor, but before the Save method is called.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
CancelButton |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DateTextBoxWidth | The default width of date textboxes
DBObject | The object being edited
DeleteButton |
EditCancelledDelegate | Called when the 'cancel' button is pressed
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileUploaderWidth | The default width of file uploaders
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
IsForPublic | If set to false, then extra info is given in dropdown boxes. This should be false almost always.
MultilineTextBoxHeight | The default width of string textboxes
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
NumberTextBoxWidth | The default width of number textboxes
ObjectDeleteDelegate | If this is set, then this will be called when the object editor 'delete' button is pressed. If it is null, then the object editor will delete the object.
ObjectSaveDelegate | If this is set, then this will be called when the object editor 'save' button is pressed. If it is null, then the object editor will save the object.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
SaveButton |
ShowOnlySpecified | If true, then only those columns that have information in the info hashtable will be shown
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
StringTextBoxWidth | The default width of string textboxes
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
UpdaterName | An optional Name to record who updated this object
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey | Gets the tag that surrounds this control
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

See Also

ObjectEditor Class | Shunde.WebControls Namespace


AfterObjectDeletedDelegate Property

Shunde.NET Framework Class Library

ObjectEditor.AfterObjectDeletedDelegate Property

If the object editor deletes the object, then this will be called upon a successful delete, upon which the delegate will probably redirect to another page.

public AfterObjectDeletedDelegate {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


AfterObjectSavedDelegate Property

Shunde.NET Framework Class Library

ObjectEditor.AfterObjectSavedDelegate Property

If the object editor saves the object, then this will be called upon a successful save, upon which the delegate will probably redirect to another page.

public AfterObjectSavedDelegate {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


AutoPopulateSelections Property

Shunde.NET Framework Class Library

ObjectEditor.AutoPopulateSelections Property

If true, then selections will be automatically populated, if they aren't already

public AutoPopulateSelections {get; set;}

Remarks

This simply returns all the (non-deleted) objects of the specified type in the database

See Also

ObjectEditor Class | Shunde.WebControls Namespace


BeforeSaveDelegate Property

Shunde.NET Framework Class Library

ObjectEditor.BeforeSaveDelegate Property

If this is set and ObjectSaveDelegate is null, then this will be called after populating the object with the values from the object editor, but before the Save method is called.

public BeforeSaveDelegate {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


CancelButton Property

Shunde.NET Framework Class Library

ObjectEditor.CancelButton Property

public CancelButton {get;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


DateTextBoxWidth Property

Shunde.NET Framework Class Library

ObjectEditor.DateTextBoxWidth Property

The default width of date textboxes

public DateTextBoxWidth {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


DBObject Property

Shunde.NET Framework Class Library

ObjectEditor.DBObject Property

The object being edited

public DBObject {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


DeleteButton Property

Shunde.NET Framework Class Library

ObjectEditor.DeleteButton Property

public DeleteButton {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


EditCancelledDelegate Property

Shunde.NET Framework Class Library

ObjectEditor.EditCancelledDelegate Property

Called when the 'cancel' button is pressed

public EditCancelledDelegate {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


FileUploaderWidth Property

Shunde.NET Framework Class Library

ObjectEditor.FileUploaderWidth Property

The default width of file uploaders

public FileUploaderWidth {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


IsForPublic Property

Shunde.NET Framework Class Library

ObjectEditor.IsForPublic Property

If set to false, then extra info is given in dropdown boxes. This should be false almost always.

public IsForPublic {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


MultilineTextBoxHeight Property

Shunde.NET Framework Class Library

ObjectEditor.MultilineTextBoxHeight Property

The default width of string textboxes

public MultilineTextBoxHeight {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


NumberTextBoxWidth Property

Shunde.NET Framework Class Library

ObjectEditor.NumberTextBoxWidth Property

The default width of number textboxes

public NumberTextBoxWidth {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectDeleteDelegate Property

Shunde.NET Framework Class Library

ObjectEditor.ObjectDeleteDelegate Property

If this is set, then this will be called when the object editor 'delete' button is pressed. If it is null, then the object editor will delete the object.

public ObjectDeleteDelegate {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectSaveDelegate Property

Shunde.NET Framework Class Library

ObjectEditor.ObjectSaveDelegate Property

If this is set, then this will be called when the object editor 'save' button is pressed. If it is null, then the object editor will save the object.

public ObjectSaveDelegate {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


SaveButton Property

Shunde.NET Framework Class Library

ObjectEditor.SaveButton Property

public SaveButton {get;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ShowOnlySpecified Property

Shunde.NET Framework Class Library

ObjectEditor.ShowOnlySpecified Property

If true, then only those columns that have information in the info hashtable will be shown

public ShowOnlySpecified {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


StringTextBoxWidth Property

Shunde.NET Framework Class Library

ObjectEditor.StringTextBoxWidth Property

The default width of string textboxes

public StringTextBoxWidth {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


TagKey Property

Shunde.NET Framework Class Library

ObjectEditor.TagKey Property

Gets the tag that surrounds this control

protected override TagKey {get;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


UpdaterName Property

Shunde.NET Framework Class Library

ObjectEditor.UpdaterName Property

An optional Name to record who updated this object

public UpdaterName {get; set;}

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor Methods

The methods of the ObjectEditor class are listed below. For a complete list of ObjectEditor class members, see the ObjectEditor Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
GetCI | Gets the column info of a column
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
PopulateTable | Makes the table
RenderBeginTag | Renders the begin tag
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SaveUserInputToObject | Writes the user-inputted values to the object
SetFriendlyName | Sets the friendly Name of a database column
SetOrders | Pass an array of strings and column infos for each string will be made with display order in ascending order
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnInit | The OnInit event
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RenderContents | This method is created solely for the design view of visual studio
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
CreateChildControls (inherited from Control) | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from WebControl) | Renders the control to the specified HTML writer.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor.GetCI Method

Gets the column info of a column

public ColumnInfo GetCI(
String columnName
);

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor.OnInit Method

The OnInit event

protected override void OnInit(
EventArgs e
);

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor.PopulateTable Method

Makes the table

public void PopulateTable();

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor.RenderBeginTag Method

Renders the begin tag

public override void RenderBeginTag(
HtmlTextWriter writer
);

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor.RenderContents Method

This method is created solely for the design view of visual studio

protected override void RenderContents(
HtmlTextWriter writer
);

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor.SaveUserInputToObject Method

Writes the user-inputted values to the object

public void SaveUserInputToObject();

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor.SetFriendlyName Method

Sets the friendly Name of a database column

public void SetFriendlyName(
String columnName,
String friendlyName
);

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectEditor.SetOrders Method

Pass an array of strings and column infos for each string will be made with display order in ascending order

public void SetOrders(
String[] names
);

See Also

ObjectEditor Class | Shunde.WebControls Namespace


ObjectSaveDelegate Delegate

A delegate to take care of saving the object

public delegate void ObjectSaveDelegate();

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

Shunde.WebControls Namespace


TextSectionDisplayer Class

A control to render a TextSection to an HTML page

For a list of all members of this type, see TextSectionDisplayer Members.

System.Object
Control
WebControl
TextSectionDisplayer

public class TextSectionDisplayer : WebControl,

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

TextSectionDisplayer Members | Shunde.WebControls Namespace


TextSectionDisplayer Members

TextSectionDisplayer overview

Public Instance Constructors

TextSectionDisplayer Constructor Initializes a new instance of the TextSectionDisplayer class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
AllowEditing | Specifies that the user viewing this has authorisation to edit the text.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
ShowHeader | Specifies whether or not to show the header, which if true will be wrapped in <h1> tags.
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
TextSection | The text section to be written to the page
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs after the Control object is loaded but prior to rendering.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey | Gets the tag that surrounds this control
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls | Creates the child controls of this control
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnPreRender | Checks to see if rendering should start
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RenderContents | Renders the control as HTML
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnInit (inherited from Control) | Raises the Init event.
OnLoad (inherited from Control) | Raises the Load event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from WebControl) | Renders the control to the specified HTML writer.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TextSectionDisplayer Constructor

Initializes a new instance of the TextSectionDisplayer class.

public TextSectionDisplayer();

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TextSectionDisplayer Properties

The properties of the TextSectionDisplayer class are listed below. For a complete list of TextSectionDisplayer class members, see the TextSectionDisplayer Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
AllowEditing | Specifies that the user viewing this has authorisation to edit the text.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
ShowHeader | Specifies whether or not to show the header, which if true will be wrapped in <h1> tags.
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
TextSection | The text section to be written to the page
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey | Gets the tag that surrounds this control
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


AllowEditing Property

Shunde.NET Framework Class Library

TextSectionDisplayer.AllowEditing Property

Specifies that the user viewing this has authorisation to edit the text.

public AllowEditing {get; set;}

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


ShowHeader Property

Shunde.NET Framework Class Library

TextSectionDisplayer.ShowHeader Property

Specifies whether or not to show the header, which if true will be wrapped in <h1> tags.

public ShowHeader {get; set;}

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TagKey Property

Shunde.NET Framework Class Library

TextSectionDisplayer.TagKey Property

Gets the tag that surrounds this control

protected override TagKey {get;}

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TextSection Property

Shunde.NET Framework Class Library

TextSectionDisplayer.TextSection Property

The text section to be written to the page

public TextSection {get; set;}

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TextSectionDisplayer Methods

The methods of the TextSectionDisplayer class are listed below. For a complete list of TextSectionDisplayer class members, see the TextSectionDisplayer Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateChildControls | Creates the child controls of this control
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
OnPreRender | Checks to see if rendering should start
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RenderContents | Renders the control as HTML
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnInit (inherited from Control) | Raises the Init event.
OnLoad (inherited from Control) | Raises the Load event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from WebControl) | Renders the control to the specified HTML writer.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TextSectionDisplayer.CreateChildControls Method

Creates the child controls of this control

protected override void CreateChildControls();

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TextSectionDisplayer.OnPreRender Method

Checks to see if rendering should start

protected override void OnPreRender(
EventArgs e
);

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TextSectionDisplayer.RenderContents Method

Renders the control as HTML

protected override void RenderContents(
HtmlTextWriter output
);

See Also

TextSectionDisplayer Class | Shunde.WebControls Namespace


TreeDisplayer Class

Displays a forest of trees, using HTML unordered lists

For a list of all members of this type, see TreeDisplayer Members.

System.Object
Control
WebControl
TreeDisplayer

public class TreeDisplayer : WebControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Shunde.WebControls

Assembly: Shunde (in Shunde.dll)

See Also

TreeDisplayer Members | Shunde.WebControls Namespace


TreeDisplayer Members

TreeDisplayer overview

Public Instance Constructors

TreeDisplayer Constructor Initializes a new instance of the TreeDisplayer class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Forest | The forest of treenodes to display
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
NodeToHtmlDelegate | A delegate that converts a node to HTML. Each node that gets displayed will use this delegate to create the text to show. If no delegate is specified, then the Name field will be used.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs after the Control object is loaded but prior to rendering.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RenderContents | Renders the control
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
CreateChildControls (inherited from Control) | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnInit (inherited from Control) | Raises the Init event.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from WebControl) | Renders the control to the specified HTML writer.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

TreeDisplayer Class | Shunde.WebControls Namespace


TreeDisplayer Constructor

Initializes a new instance of the TreeDisplayer class.

public TreeDisplayer();

See Also

TreeDisplayer Class | Shunde.WebControls Namespace


TreeDisplayer Properties

The properties of the TreeDisplayer class are listed below. For a complete list of TreeDisplayer class members, see the TreeDisplayer Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key that allows you to quickly navigate to the Web server control.
AppRelativeTemplateSourceDirectory (inherited from Control) | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) | Gets the control that contains this control's data binding.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableTheming (inherited from WebControl) | Gets or sets a value indicating whether themes apply to this control.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Forest | The forest of treenodes to display
HasAttributes (inherited from WebControl) | Gets a value indicating whether the control has attributes set.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
NodeToHtmlDelegate | A delegate that converts a node to HTML. Each node that gets displayed will use this delegate to create the text to show. If no delegate is specified, then the Name field will be used.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the container that hosts the current control when rendered on a design surface.
SkinID (inherited from WebControl) | Gets or sets the skin to apply to the control.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
TemplateControl (inherited from Control) | Gets or sets a reference to the template that contains this control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically qualified identifier for the server control.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from WebControl) | Gets or sets the width of the Web server control.

Protected Instance Properties

Adapter (inherited from Control) | Gets the browser-specific adapter for the control.
ChildControlsCreated (inherited from Control) | Gets a value that indicates whether the server control's child controls have been created.
ClientIDSeparator (inherited from Control) | Gets a character value representing the separator character used in the ClientID property.
Events (inherited from Control) | Gets a list of event handler delegates for the control. This property is read-only.
HasChildViewState (inherited from Control) | Gets a value indicating whether the current server control's child controls have any saved view-state settings.
IdSeparator (inherited from Control) | Gets the character used to separate control identifiers.
IsTrackingViewState (inherited from Control) | Gets a value that indicates whether the server control is saving changes to its view state.
LoadViewStateByID (inherited from Control) | Gets a value indicating whether the control participates in loading its view state by ID instead of index.
TagKey (inherited from WebControl) | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
TagName (inherited from WebControl) | Gets the name of the control tag. This property is used primarily by control developers.
ViewState (inherited from Control) | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.
ViewStateIgnoresCase (inherited from Control) | Gets a value that indicates whether the StateBag object is case-insensitive.

Protected Internal Instance Properties

Context (inherited from Control) | Gets the HttpContext object associated with the server control for the current Web request.
DesignMode (inherited from Control) | Gets a value indicating whether a control is being used on a design surface.
IsChildControlStateCleared (inherited from Control) | Gets a value indicating whether controls contained within this control have control state.
IsEnabled (inherited from WebControl) | Gets a value indicating whether the control is enabled.
IsViewStateEnabled (inherited from Control) | Gets a value indicating whether view state is enabled for this control.

See Also

TreeDisplayer Class | Shunde.WebControls Namespace


Forest Property

Shunde.NET Framework Class Library

TreeDisplayer.Forest Property

The forest of treenodes to display

public Forest {get; set;}

See Also

TreeDisplayer Class | Shunde.WebControls Namespace


NodeToHtmlDelegate Property

Shunde.NET Framework Class Library

TreeDisplayer.NodeToHtmlDelegate Property

A delegate that converts a node to HTML. Each node that gets displayed will use this delegate to create the text to show. If no delegate is specified, then the Name field will be used.

public NodeToHtmlDelegate {get; set;}

See Also

TreeDisplayer Class | Shunde.WebControls Namespace


TreeDisplayer Methods

The methods of the TreeDisplayer class are listed below. For a complete list of TreeDisplayer class members, see the TreeDisplayer Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
ApplyStyleSheetSkin (inherited from Control) | Applies the style properties defined in the page style sheet to the control.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id parameter.
Focus (inherited from Control) | Sets input focus to a control.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveClientUrl (inherited from Control) | Gets a URL that can be used by the browser.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) | Assigns an event handler delegate to render the server control and its content into its parent control.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers.
AddParsedSubObject (inherited from Control) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object.
BuildProfileTree (inherited from Control) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page.
ClearChildControlState (inherited from Control) | Deletes the control-state information for the server control's child controls.
ClearChildState (inherited from Control) | Deletes the view-state and control-state information for all the server control's child controls.
ClearChildViewState (inherited from Control) | Deletes the view-state information for all the server control's child controls.
CreateControlCollection (inherited from Control) | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control.
CreateControlStyle (inherited from WebControl) | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers.
DataBind (inherited from Control) | Overloaded. Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.
DataBindChildren (inherited from Control) | Binds a data source to the server control's child controls.
EnsureChildControls (inherited from Control) | Determines whether the server control contains child controls. If it does not, it creates child controls.
EnsureID (inherited from Control) | Creates an identifier for controls that do not have an identifier assigned.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) | Overloaded. Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method.
GetDesignModeState (inherited from Control) | Gets design-time data for a control.
HasEvents (inherited from Control) | Returns a value indicating whether events are registered for the control or any child controls.
IsLiteralContent (inherited from Control) | Determines if the server control holds only literal content.
LoadViewState (inherited from WebControl) | Restores view-state information from a previous request that was saved with the SaveViewState method.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) | Determines whether the event for the server control is passed up the page's UI server control hierarchy.
OnDataBinding (inherited from Control) | Raises the DataBinding event.
RaiseBubbleEvent (inherited from Control) | Assigns any sources of the event and its information to the control's parent.
RenderContents | Renders the control
RenderControl (inherited from Control) | Overloaded. Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.
ResolveAdapter (inherited from Control) | Gets the control adapter responsible for rendering the specified control.
SaveViewState (inherited from WebControl) | Saves any state that was modified after the TrackViewState method was invoked.
SetDesignModeState (inherited from Control) | Sets design-time data for a control.
TrackViewState (inherited from WebControl) | Causes the control to track changes to its view state so they can be stored in the object's ViewState property.

Protected Internal Instance Methods

AddedControl (inherited from Control) | Called after a child control is added to the Controls collection of the Control object.
CreateChildControls (inherited from Control) | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
LoadControlState (inherited from Control) | Restores control-state information from a previous page request that was saved by the SaveControlState method.
MapPathSecure (inherited from Control) | Retrieves the physical path that a virtual path, either absolute or relative, maps to.
OnInit (inherited from Control) | Raises the Init event.
OnLoad (inherited from Control) | Raises the Load event.
OnPreRender (inherited from Control) | Raises the PreRender event.
OnUnload (inherited from Control) | Raises the Unload event.
OpenFile (inherited from Control) | Gets a Stream used to read a file.
RemovedControl (inherited from Control) | Called after a control is removed from the Controls collection of another control.
Render (inherited from WebControl) | Renders the control to the specified HTML writer.
RenderChildren (inherited from Control) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
SaveControlState (inherited from Control) | Saves any server control state changes that have occurred since the time the page was posted back to the server.

See Also

TreeDisplayer Class | Shunde.WebControls Namespace


TreeDisplayer.RenderContents Method

Renders the control

protected override void RenderContents(
HtmlTextWriter output
);

See Also

TreeDisplayer Class | Shunde.WebControls Namespace


Hierarchy

System.Object
Shunde.Common.IAttribRelation
Shunde.Framework.DBObject
Shunde.Common.AttribDataType
Shunde.Common.AttribRelation ---- Shunde.Common.IAttribRelation
Shunde.Common.AttribType
Shunde.Common.GenericType
Shunde.Common.GenericTypeType
Shunde.Common.TextSection
Shunde.Common.TreeNode ---- System.IComparable
Shunde.Common.Attrib
Shunde.Common.WebsiteVisit
Shunde.Common.WebsiteVisitAction
System.Net.Mail.MailMessage ---- System.IDisposable
Shunde.Common.Email
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IControlBuilderAccessor, System.Web.UI.IControlDesignerAccessor, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IExpressionsAccessor, System.Web.UI.IParserAccessor, System.Web.UI.IUrlResolutionService
System.Web.UI.TemplateControl ---- System.Web.UI.IFilterResolutionService, System.Web.UI.INamingContainer
System.Web.UI.Page ---- System.Web.IHttpHandler
Shunde.Common.WebPage

See Also

Shunde.Common Namespace


DBObject Hierarchy

System.Object
DBObject
AttribDataType
AttribRelation
AttribType
GenericType
GenericTypeType
TextSection
TreeNode
WebsiteVisit
WebsiteVisitAction

See Also

DBObject Class | DBObject Members | Shunde.Framework Namespace


Hierarchy

System.Object
Shunde.Framework.DBColumn
Shunde.Framework.DBObject
Shunde.Framework.DBTable
Shunde.Framework.ObjectInfo
System.ValueType
Shunde.Framework.BinaryData

See Also

Shunde.Framework Namespace


Hierarchy

System.Object
Shunde.Utilities.ColumnInfo
Shunde.Utilities.DBCreation
Shunde.Utilities.DBUtils
Shunde.Utilities.Encrypter
Shunde.Utilities.ImageUtils
Shunde.Utilities.ObjectUtils
Shunde.Utilities.PagingUtil
Shunde.Utilities.TextUtils
Shunde.Utilities.WebUtils
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Shunde.Utilities.FindObjectDelegate
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Shunde.Utilities.SelectionMode
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IControlBuilderAccessor, System.Web.UI.IControlDesignerAccessor, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IExpressionsAccessor, System.Web.UI.IParserAccessor, System.Web.UI.IUrlResolutionService
System.Web.UI.WebControls.WebControl ---- System.Web.UI.IAttributeAccessor
System.Web.UI.WebControls.TableRow
Shunde.Utilities.ComparableRow ---- System.IComparable

See Also

Shunde.Utilities Namespace


Hierarchy

System.Object
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Shunde.WebControls.AfterObjectDeletedDelegate
Shunde.WebControls.AfterObjectSavedDelegate
Shunde.WebControls.BeforeSaveDelegate
Shunde.WebControls.EditCancelledDelegate
Shunde.WebControls.NodeToHtmlDelegate
Shunde.WebControls.ObjectDeleteDelegate
Shunde.WebControls.ObjectSaveDelegate
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IControlBuilderAccessor, System.Web.UI.IControlDesignerAccessor, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IExpressionsAccessor, System.Web.UI.IParserAccessor, System.Web.UI.IUrlResolutionService
System.Web.UI.WebControls.WebControl ---- System.Web.UI.IAttributeAccessor
Shunde.WebControls.ObjectEditor ---- System.Web.UI.INamingContainer
Shunde.WebControls.TextSectionDisplayer ---- System.Web.UI.INamingContainer
Shunde.WebControls.TreeDisplayer

See Also

Shunde.WebControls Namespace


Hierarchy

System.Object
System.Exception ---- System.Runtime.Serialization.ISerializable
Shunde.ShundeException
Shunde.ObjectDoesNotExistException
Shunde.ValidationException
Shunde.ConcurrencyException
Shunde.WarningException
Shunde.ShundeSqlException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Shunde.SearchType

See Also

Shunde Namespace